mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/pacman to 4.0.1-4
This commit is contained in:
parent
401a6d1521
commit
8fed691557
6 changed files with 86 additions and 146 deletions
|
@ -1,32 +0,0 @@
|
|||
From c493eef643ecb3a54c79083c51a8975f816ed9de Mon Sep 17 00:00:00 2001
|
||||
From: Allan McRae <allan@archlinux.org>
|
||||
Date: Tue, 28 Jun 2011 22:47:35 +1000
|
||||
Subject: [PATCH] makepkg: fix removing symbolic link
|
||||
|
||||
The path was not being stripped from $file before prefixing with
|
||||
$srcdir resulting in the attempted removal of a very weird
|
||||
filename.
|
||||
|
||||
Signed-off-by: Allan McRae <allan@archlinux.org>
|
||||
Signed-off-by: Dan McGee <dan@archlinux.org>
|
||||
(cherry picked from commit e92905a2c8c14c7855e2841f44d3c139aa40844c)
|
||||
---
|
||||
scripts/makepkg.sh.in | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/scripts/makepkg.sh.in b/scripts/makepkg.sh.in
|
||||
index 3ace945..b0b0882 100644
|
||||
--- a/scripts/makepkg.sh.in
|
||||
+++ b/scripts/makepkg.sh.in
|
||||
@@ -509,7 +509,7 @@ download_sources() {
|
||||
local file=$(get_filepath "$netfile" || true)
|
||||
if [[ -n "$file" ]]; then
|
||||
msg2 "$(gettext "Found %s")" "${file##*/}"
|
||||
- rm -f "$srcdir/$file"
|
||||
+ rm -f "$srcdir/${file##*/}"
|
||||
ln -s "$file" "$srcdir/"
|
||||
continue
|
||||
fi
|
||||
--
|
||||
1.7.6
|
||||
|
|
@ -1,38 +1,38 @@
|
|||
# $Id: PKGBUILD 135272 2011-08-11 19:58:54Z dreisner $
|
||||
# vim: set ts=2 sw=2 et:
|
||||
# $Id: PKGBUILD 146700 2012-01-16 19:48:37Z dreisner $
|
||||
# Maintainer: Dan McGee <dan@archlinux.org>
|
||||
# Maintainer: Dave Reisner <dave@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@plugapps.com>
|
||||
# - arch/host/flags for arm and armv7
|
||||
# - depend on current versions of libarchive, libfetch, xz to fix upgrade issues
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - arch/host/flags for arm and armv7h
|
||||
# - pacman.conf: architecture=arm/armv7h, added our aur repo
|
||||
# - makepkg.conf: add --no-check-certificate to http wget, adjusted C/CXX/LDFLAGS
|
||||
# - makepkg.conf: adjusted C/CXX/LDFLAGS
|
||||
|
||||
plugrel=1
|
||||
noautbuild=1
|
||||
|
||||
pkgname=pacman
|
||||
pkgver=3.5.4
|
||||
pkgver=4.0.1
|
||||
pkgrel=4
|
||||
pkgdesc="A library-based package manager with dependency support"
|
||||
arch=('arm' 'armv7h')
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.archlinux.org/pacman/"
|
||||
license=('GPL')
|
||||
groups=('base')
|
||||
depends=('bash' 'glibc>=2.14' 'libarchive>=2.8.4' 'libfetch>=2.33' 'pacman-mirrorlist' 'xz>=5.0.1')
|
||||
optdepends=('fakeroot: for makepkg usage as normal user'
|
||||
'curl: for rankmirrors usage')
|
||||
depends=('bash' 'glibc>=2.15' 'libarchive>=3.0.2' 'curl>=7.19.4'
|
||||
'gpgme' 'pacman-mirrorlist')
|
||||
makedepends=('asciidoc')
|
||||
optdepends=('fakeroot: for makepkg usage as normal user')
|
||||
backup=(etc/pacman.conf etc/makepkg.conf)
|
||||
install=pacman.install
|
||||
options=(!libtool)
|
||||
source=(ftp://ftp.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz
|
||||
pacman.conf
|
||||
pacman.conf.armv7
|
||||
makepkg.conf
|
||||
0001-makepkg-fix-removing-symbolic-link.patch)
|
||||
md5sums=('2dd3a85d55ee3dd89abd349aa837447c'
|
||||
'8a202e08a4e9ffe978c6aa6358e1b640'
|
||||
'5a572af37873bb8a521ffbf81aa2151e'
|
||||
'7af5a2b001a8baabb664a94b08dbddec'
|
||||
'749a4ddc6d8418d8d031f1c9b4e09d6f')
|
||||
makepkg.conf)
|
||||
md5sums=('76bd88eff8cd94bc9899faa091822dc1'
|
||||
'4605b3490d4fd1e5c6e20db17da9ded6'
|
||||
'a0edf98ad1845a4c7d902a86638d5d2d'
|
||||
'db051afbd12993b7743ccd4d58668499')
|
||||
|
||||
# keep an upgrade path for older installations
|
||||
PKGEXT='.pkg.tar.gz'
|
||||
|
@ -40,8 +40,6 @@ PKGEXT='.pkg.tar.gz'
|
|||
build() {
|
||||
cd $srcdir/$pkgname-$pkgver
|
||||
|
||||
patch -Np1 < "$srcdir/0001-makepkg-fix-removing-symbolic-link.patch"
|
||||
|
||||
./configure --prefix=/usr --sysconfdir=/etc \
|
||||
--localstatedir=/var --enable-doc
|
||||
make
|
||||
|
@ -54,6 +52,18 @@ package() {
|
|||
# install Arch specific stuff
|
||||
mkdir -p $pkgdir/etc
|
||||
case "$CARCH" in
|
||||
i686)
|
||||
install -m644 $srcdir/pacman.conf $pkgdir/etc/pacman.conf
|
||||
mycarch="i686"
|
||||
mychost="i686-pc-linux-gnu"
|
||||
myflags="-march=i686 "
|
||||
;;
|
||||
x86_64)
|
||||
install -m644 $srcdir/pacman.conf.x86_64 $pkgdir/etc/pacman.conf
|
||||
mycarch="x86_64"
|
||||
mychost="x86_64-unknown-linux-gnu"
|
||||
myflags="-march=x86-64 "
|
||||
;;
|
||||
arm)
|
||||
install -m644 $srcdir/pacman.conf $pkgdir/etc/pacman.conf
|
||||
mycarch="arm"
|
||||
|
@ -61,7 +71,7 @@ package() {
|
|||
myflags="-march=armv5te "
|
||||
;;
|
||||
armv7h)
|
||||
install -m644 $srcdir/pacman.conf.armv7 $pkgdir/etc/pacman.conf
|
||||
install -m644 $srcdir/pacman.conf $pkgdir/etc/pacman.conf
|
||||
mycarch="armv7h"
|
||||
mychost="armv7l-unknown-linux-gnueabi"
|
||||
myflags="-march=armv7-a -mfloat-abi=hard -mfpu=vfpv3-d16 "
|
||||
|
@ -73,6 +83,7 @@ package() {
|
|||
-e "s|@CARCH[@]|$mycarch|g" \
|
||||
-e "s|@CHOST[@]|$mychost|g" \
|
||||
-e "s|@CARCHFLAGS[@]|$myflags|g"
|
||||
sed -i $pkgdir/etc/pacman.conf -e "s|@CARCH[@]|$mycarch|g"
|
||||
|
||||
# install completion files
|
||||
mkdir -p $pkgdir/etc/bash_completion.d/
|
||||
|
@ -80,5 +91,6 @@ package() {
|
|||
mkdir -p $pkgdir/usr/share/zsh/site-functions/
|
||||
install -m644 contrib/zsh_completion $pkgdir/usr/share/zsh/site-functions/_pacman
|
||||
}
|
||||
|
||||
# vim: set ts=2 sw=2 et:
|
||||
md5sums=('76bd88eff8cd94bc9899faa091822dc1'
|
||||
'9c58ab16092e34eb359ea7e8d56bfc3a'
|
||||
'e6d44e71b847d2c98bb38087e33cd76b')
|
||||
|
|
|
@ -8,16 +8,16 @@
|
|||
#
|
||||
#-- The download utilities that makepkg should use to acquire sources
|
||||
# Format: 'protocol::agent'
|
||||
DLAGENTS=('ftp::/usr/bin/wget -c --passive-ftp -t 3 --waitretry=3 -O %o %u'
|
||||
'http::/usr/bin/wget -c -t 3 --waitretry=3 --no-check-certificate -O %o %u'
|
||||
'https::/usr/bin/wget -c -t 3 --waitretry=3 --no-check-certificate -O %o %u'
|
||||
DLAGENTS=('ftp::/usr/bin/curl -fC - --ftp-pasv --retry 3 --retry-delay 3 -o %o %u'
|
||||
'http::/usr/bin/curl -fLC - --retry 3 --retry-delay 3 -o %o %u'
|
||||
'https::/usr/bin/curl -fLC - --retry 3 --retry-delay 3 -o %o %u'
|
||||
'rsync::/usr/bin/rsync -z %u %o'
|
||||
'scp::/usr/bin/scp -C %u %o')
|
||||
|
||||
# Other common tools:
|
||||
# /usr/bin/snarf
|
||||
# /usr/bin/lftpget -c
|
||||
# /usr/bin/curl
|
||||
# /usr/bin/wget
|
||||
|
||||
#########################################################################
|
||||
# ARCHITECTURE, COMPILE FLAGS
|
||||
|
@ -26,7 +26,7 @@ DLAGENTS=('ftp::/usr/bin/wget -c --passive-ftp -t 3 --waitretry=3 -O %o %u'
|
|||
CARCH="@CARCH@"
|
||||
CHOST="@CHOST@"
|
||||
|
||||
#-- Exclusive: will only run on @CARCH@
|
||||
#-- Compiler and Linker Flags
|
||||
# -march (or -mcpu) builds exclusively for an architecture
|
||||
# -mtune optimizes for an architecture, but builds for whole processor family
|
||||
CFLAGS="@CARCHFLAGS@-O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2"
|
||||
|
@ -39,7 +39,7 @@ LDFLAGS=""
|
|||
# BUILD ENVIRONMENT
|
||||
#########################################################################
|
||||
#
|
||||
# Defaults: BUILDENV=(fakeroot !distcc color !ccache check)
|
||||
# Defaults: BUILDENV=(fakeroot !distcc color !ccache check !sign)
|
||||
# A negated environment option will do the opposite of the comments below.
|
||||
#
|
||||
#-- fakeroot: Allow building packages as a non-root user
|
||||
|
@ -47,19 +47,23 @@ LDFLAGS=""
|
|||
#-- color: Colorize output messages
|
||||
#-- ccache: Use ccache to cache compilation
|
||||
#-- check: Run the check() function if present in the PKGBUILD
|
||||
#-- sign: Generate PGP signature file
|
||||
#
|
||||
BUILDENV=(fakeroot !distcc color !ccache check)
|
||||
BUILDENV=(fakeroot !distcc color !ccache check !sign)
|
||||
#
|
||||
#-- If using DistCC, your MAKEFLAGS will also need modification. In addition,
|
||||
#-- specify a space-delimited list of hosts running in the DistCC cluster.
|
||||
#DISTCC_HOSTS=""
|
||||
#
|
||||
#-- Specify a directory for package building.
|
||||
#BUILDDIR=/tmp/makepkg
|
||||
|
||||
#########################################################################
|
||||
# GLOBAL PACKAGE OPTIONS
|
||||
# These are default values for the options=() settings
|
||||
#########################################################################
|
||||
#
|
||||
# Default: OPTIONS=(strip docs libtool emptydirs zipman purge)
|
||||
# Default: OPTIONS=(strip docs libtool emptydirs zipman purge !upx)
|
||||
# A negated option will do the opposite of the comments below.
|
||||
#
|
||||
#-- strip: Strip symbols from binaries/libraries
|
||||
|
@ -68,8 +72,9 @@ BUILDENV=(fakeroot !distcc color !ccache check)
|
|||
#-- emptydirs: Leave empty directories in packages
|
||||
#-- zipman: Compress manual (man and info) pages in MAN_DIRS with gzip
|
||||
#-- purge: Remove files specified by PURGE_TARGETS
|
||||
#-- upx: Compress binary executable files using UPX
|
||||
#
|
||||
OPTIONS=(strip docs libtool emptydirs zipman purge)
|
||||
OPTIONS=(strip docs libtool emptydirs zipman purge !upx)
|
||||
|
||||
#-- File integrity checks to use. Valid: md5, sha1, sha256, sha384, sha512
|
||||
INTEGRITY_CHECK=(md5)
|
||||
|
@ -100,6 +105,8 @@ PURGE_TARGETS=(usr/{,share}/info/dir .packlist *.pod)
|
|||
#SRCPKGDEST=/home/srcpackages
|
||||
#-- Packager: name/email of the person or organization building packages
|
||||
#PACKAGER="John Doe <john@doe.com>"
|
||||
#-- Specify a key to use for package signing
|
||||
#GPGKEY=""
|
||||
|
||||
#########################################################################
|
||||
# EXTENSION DEFAULTS
|
||||
|
|
|
@ -13,13 +13,14 @@
|
|||
#DBPath = /var/lib/pacman/
|
||||
#CacheDir = /var/cache/pacman/pkg/
|
||||
#LogFile = /var/log/pacman.log
|
||||
#GPGDir = /etc/pacman.d/gnupg/
|
||||
HoldPkg = pacman glibc
|
||||
# If upgrades are available for these packages they will be asked for first
|
||||
SyncFirst = pacman
|
||||
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
|
||||
#XferCommand = /usr/bin/curl -C - -f %u > %o
|
||||
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
|
||||
#CleanMethod = KeepInstalled
|
||||
Architecture = arm
|
||||
Architecture = @CARCH@
|
||||
|
||||
# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
|
||||
#IgnorePkg =
|
||||
|
@ -28,12 +29,25 @@ Architecture = arm
|
|||
#NoUpgrade =
|
||||
#NoExtract =
|
||||
|
||||
# Misc options (all disabled by default)
|
||||
# Misc options
|
||||
#UseSyslog
|
||||
#ShowSize
|
||||
#UseDelta
|
||||
#TotalDownload
|
||||
#CheckSpace
|
||||
CheckSpace
|
||||
#VerbosePkgLists
|
||||
|
||||
# PGP signature checking
|
||||
# NOTE: None of this will work without running `pacman-key --init` first.
|
||||
# The compiled in default is equivalent to the following line. This requires
|
||||
# you to locally sign and trust packager keys using `pacman-key` for them to be
|
||||
# considered valid.
|
||||
#SigLevel = Optional TrustedOnly
|
||||
# If you wish to check signatures but avoid local sign and trust issues, use
|
||||
# the following line. This will treat any key imported into pacman's keyring as
|
||||
# trusted.
|
||||
#SigLevel = Optional TrustAll
|
||||
# For now, off by default unless you read the above.
|
||||
SigLevel = Never
|
||||
|
||||
#
|
||||
# REPOSITORIES
|
||||
|
@ -59,19 +73,24 @@ Architecture = arm
|
|||
# after the header, and they will be used before the default mirrors.
|
||||
|
||||
[core]
|
||||
#SigLevel = PackageRequired
|
||||
Include = /etc/pacman.d/mirrorlist
|
||||
|
||||
[extra]
|
||||
#SigLevel = PackageOptional
|
||||
Include = /etc/pacman.d/mirrorlist
|
||||
|
||||
[community]
|
||||
#SigLevel = PackageOptional
|
||||
Include = /etc/pacman.d/mirrorlist
|
||||
|
||||
[aur]
|
||||
#SigLevel = PackageOptional
|
||||
Include = /etc/pacman.d/mirrorlist
|
||||
|
||||
# An example of a custom package repository. See the pacman manpage for
|
||||
# tips on creating your own repositories.
|
||||
#[custom]
|
||||
#SigLevel = Optional TrustAll
|
||||
#Server = file:///home/custompkgs
|
||||
|
||||
|
|
|
@ -1,77 +0,0 @@
|
|||
#
|
||||
# /etc/pacman.conf
|
||||
#
|
||||
# See the pacman.conf(5) manpage for option and repository directives
|
||||
|
||||
#
|
||||
# GENERAL OPTIONS
|
||||
#
|
||||
[options]
|
||||
# The following paths are commented out with their default values listed.
|
||||
# If you wish to use different paths, uncomment and update the paths.
|
||||
#RootDir = /
|
||||
#DBPath = /var/lib/pacman/
|
||||
#CacheDir = /var/cache/pacman/pkg/
|
||||
#LogFile = /var/log/pacman.log
|
||||
HoldPkg = pacman glibc
|
||||
# If upgrades are available for these packages they will be asked for first
|
||||
SyncFirst = pacman
|
||||
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
|
||||
#XferCommand = /usr/bin/curl -C - -f %u > %o
|
||||
#CleanMethod = KeepInstalled
|
||||
Architecture = armv7h
|
||||
|
||||
# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
|
||||
#IgnorePkg =
|
||||
#IgnoreGroup =
|
||||
|
||||
#NoUpgrade =
|
||||
#NoExtract =
|
||||
|
||||
# Misc options (all disabled by default)
|
||||
#UseSyslog
|
||||
#ShowSize
|
||||
#UseDelta
|
||||
#TotalDownload
|
||||
#CheckSpace
|
||||
|
||||
#
|
||||
# REPOSITORIES
|
||||
# - can be defined here or included from another file
|
||||
# - pacman will search repositories in the order defined here
|
||||
# - local/custom mirrors can be added here or in separate files
|
||||
# - repositories listed first will take precedence when packages
|
||||
# have identical names, regardless of version number
|
||||
# - URLs will have $repo replaced by the name of the current repo
|
||||
# - URLs will have $arch replaced by the name of the architecture
|
||||
#
|
||||
# Repository entries are of the format:
|
||||
# [repo-name]
|
||||
# Server = ServerName
|
||||
# Include = IncludePath
|
||||
#
|
||||
# The header [repo-name] is crucial - it must be present and
|
||||
# uncommented to enable the repo.
|
||||
#
|
||||
|
||||
# The testing repositories are disabled by default. To enable, uncomment the
|
||||
# repo name header and Include lines. You can add preferred servers immediately
|
||||
# after the header, and they will be used before the default mirrors.
|
||||
|
||||
[core]
|
||||
Include = /etc/pacman.d/mirrorlist
|
||||
|
||||
[extra]
|
||||
Include = /etc/pacman.d/mirrorlist
|
||||
|
||||
[community]
|
||||
Include = /etc/pacman.d/mirrorlist
|
||||
|
||||
[aur]
|
||||
Include = /etc/pacman.d/mirrorlist
|
||||
|
||||
# An example of a custom package repository. See the pacman manpage for
|
||||
# tips on creating your own repositories.
|
||||
#[custom]
|
||||
#Server = file:///home/custompkgs
|
||||
|
|
@ -9,6 +9,17 @@ post_upgrade() {
|
|||
if [ "$(vercmp $2 3.5.0)" -lt 0 ]; then
|
||||
_warnupgrade
|
||||
fi
|
||||
_check_pubring
|
||||
}
|
||||
|
||||
post_install() {
|
||||
_check_pubring
|
||||
}
|
||||
|
||||
_check_pubring() {
|
||||
if [ ! -f "etc/pacman.d/gnupg/pubring.gpg" ]; then
|
||||
echo " >>> Run \`pacman-key --init\` to set up your pacman keyring."
|
||||
fi
|
||||
}
|
||||
|
||||
_warnupgrade() {
|
||||
|
|
Loading…
Reference in a new issue