mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
community/blender to 2.79.b.git3.32432d91-11
This commit is contained in:
parent
ad56f17155
commit
8ff195e9fc
2 changed files with 41 additions and 14 deletions
|
@ -22,7 +22,7 @@ _gitcommit=32432d91bbec558cbd88e54aece61b0d641c1761
|
|||
pkgname=blender
|
||||
pkgver=2.79.b
|
||||
[[ -n $_gitcommit ]] && pkgver=${pkgver}.git3.${_gitcommit:0:8}
|
||||
pkgrel=10
|
||||
pkgrel=11
|
||||
epoch=17
|
||||
pkgdesc="A fully integrated 3D graphics creation suite"
|
||||
arch=('x86_64')
|
||||
|
@ -45,24 +45,26 @@ source=("git://git.blender.org/blender-addons.git"
|
|||
tree_hpp.patch
|
||||
util_sseb.patch
|
||||
openvdb3-abi.patch
|
||||
stl_export_iter.patch)
|
||||
stl_export_iter.patch
|
||||
gcc8.patch)
|
||||
if [[ -n $_gittag ]]; then
|
||||
source+=("${pkgname}-${pkgver}::git://git.blender.org/blender.git#tag=${_gittag}")
|
||||
elif [[ -n $_gitcommit ]]; then
|
||||
source+=("${pkgname}-${pkgver}::git://git.blender.org/blender.git#commit=${_gitcommit}")
|
||||
fi
|
||||
md5sums=('SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'1d6d2064db0e8e4e3a52735406f5106a'
|
||||
'da14d7cbdea1ab5499659a066658cdd2'
|
||||
'feea89510de171946c41c6208461f453'
|
||||
'53da216adbc2a9d555a59c15b8f0ef08'
|
||||
'3f9613fcb7ea61214982272e9c20a294'
|
||||
'f21e971208232d8d78d1a4c41013a101'
|
||||
'SKIP')
|
||||
sha512sums=('SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'e6b83d61cf1b48ce78aca11e04196c638f5510f84efc4fb1bd4554f54e0e6ab92911bcd8606845116f4257d0898fa52c026f402f934e1eb7f01bbe96d0afae2c'
|
||||
'446dd46557c7c976a68010c62e04693c61171980abea1cd0a900b00bcc3d525b83bb6ee200739623110e592e37e8f4783a18f234b40e9f85483830ea9785640d'
|
||||
'6c0a619fe8fbc215a9a7c9d4b9c6fc5ec355c37212ec41b05b50787465354bbc7200e76eaafba46a2253196391838190d3de3b2be132095d2162142940e87924'
|
||||
'429ffb6d36efb04c02d506858fc2691ea927ca486d950313dcb0c94d535a66409a14863807e69adc657dafbe243d0aad15cfaadf9f27bdc7c7759211da3fb8a8'
|
||||
'2bd8c59ab8f163b6c7f89b6dfe8aacee3307dae6ecdc0d4878e1376ba29584c891171edd0a57f12241a98e0dd43efff0675a16708d34122bc22faebe3fd8e181'
|
||||
'51f30acc407179f003d1dbec25fb47b0bf1fe8d2eb16e069a6ca83ab8b21f6032d636a42e0b140537ad1ad25ad38c52a87a2a33e51822729ab196fcef4682818'
|
||||
'86f8d6c766644090bb59715b219db74f7acbe31dcd92dc1ecc32beedc1c894a98d2875e9078efa9994511b79e094277a943746dd602be6bc33ba37b7a8a41269'
|
||||
'SKIP')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
@ -81,6 +83,7 @@ prepare() {
|
|||
patch -Np1 -i "$srcdir"/util_sseb.patch
|
||||
patch -Np1 -i "$srcdir"/openvdb3-abi.patch
|
||||
patch -Np1 -i "$srcdir"/stl_export_iter.patch
|
||||
patch -Np1 -i "$srcdir"/gcc8.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
24
community/blender/gcc8.patch
Normal file
24
community/blender/gcc8.patch
Normal file
|
@ -0,0 +1,24 @@
|
|||
commit e5767eaad1c48a23eb3d8fed4616722189a70aa1
|
||||
Author: Sergey Sharybin <sergey.vfx@gmail.com>
|
||||
Date: Mon Jul 2 15:11:48 2018 +0200
|
||||
|
||||
Cycles: Fix missing curve hair when building with GCC-8 in release mode
|
||||
|
||||
Reshuffle cast intrinsics to make XOR to operate on __m128i rather
|
||||
than on __m128.
|
||||
|
||||
Hopefully this does not affect performance.
|
||||
|
||||
diff --git a/intern/cycles/util/util_ssef.h b/intern/cycles/util/util_ssef.h
|
||||
index bb007ff84a9..e9a617bb2cc 100644
|
||||
--- a/intern/cycles/util/util_ssef.h
|
||||
+++ b/intern/cycles/util/util_ssef.h
|
||||
@@ -606,7 +606,7 @@ ccl_device_inline const ssef uint32_to_float(const ssei &in)
|
||||
template<size_t S1, size_t S2, size_t S3, size_t S4>
|
||||
ccl_device_inline const ssef set_sign_bit(const ssef &a)
|
||||
{
|
||||
- return a ^ cast(ssei(S1 << 31, S2 << 31, S3 << 31, S4 << 31));
|
||||
+ return cast(cast(a) ^ ssei(S1 << 31, S2 << 31, S3 << 31, S4 << 31));
|
||||
}
|
||||
|
||||
////////////////////////////////////////////////////////////////////////////////
|
Loading…
Reference in a new issue