community/scribus to 1.4.3-3

This commit is contained in:
Kevin Mihelich 2014-04-08 00:54:34 +00:00
parent 76ab949ad2
commit 8fffb0f7ba
2 changed files with 29 additions and 3 deletions

View file

@ -0,0 +1,23 @@
Modified: trunk/Scribus/scribus/plugins/scriptplugin/scripts/CalendarWizard.py
URL: http://scribus.net/websvn/diff.php?repname=Scribus&rev=18692&path=/trunk/Scribus/scribus/plugins/scriptplugin/scripts/CalendarWizard.py
==============================================================================
--- trunk/Scribus/scribus/plugins/scriptplugin/scripts/CalendarWizard.py (original)
+++ trunk/Scribus/scribus/plugins/scriptplugin/scripts/CalendarWizard.py Tue Jan 7 20:09:18 2014
@@ -491,11 +491,11 @@
self.langLabel = Label(self, text='Select language:')
self.langFrame = Frame(self)
- self.langFrame.pack()
- self.langScrollbar = Scrollbar(self.langFrame)
- self.langScrollbar.pack(fill=Y, side=RIGHT)
+ self.langFrame.grid()
+ self.langScrollbar = Scrollbar(self.langFrame, orient=VERTICAL)
+ self.langScrollbar.grid(row=0, column=1, sticky=N+S)
self.langListbox = Listbox(self.langFrame, selectmode=SINGLE, height=10, yscrollcommand=self.langScrollbar.set)
- self.langListbox.pack(fill=X,side=LEFT)
+ self.langListbox.grid(row=0, column=0, sticky=N+S+E+W)
self.langScrollbar.config(command=self.langListbox.yview)
keys = localization.keys()

View file

@ -10,7 +10,7 @@
pkgname=scribus
pkgver=1.4.3
pkgrel=2
pkgrel=3
pkgdesc='Desktop publishing software'
url="http://www.scribus.net/"
license=('GPL')
@ -20,8 +20,10 @@ depends=('qt4' 'cairo' 'lcms2' 'libcups' 'libxml2' 'hyphen'
'ghostscript' 'python2' 'podofo' 'boost-libs'
'desktop-file-utils' 'shared-mime-info')
source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.xz"
arm.patch)
'CalendarWizard.patch'
'arm.patch')
sha1sums=('30c111762790e4407c13236bbb4b06f04e907f71'
'a92629a98bc960a6f7f946faf2d6f06e9d1e9452'
'efb1fbf23b29527397f5fd7fe999bbeef50e5129')
options=('!libtool')
@ -29,7 +31,8 @@ install=install
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
patch -p1 -i "${srcdir}"/arm.patch
patch -p2 -i ../CalendarWizard.patch
patch -p1 -i "${srcdir}"/arm.patch
sed 's|Icon=scribus|Icon=/usr/share/scribus/icons/scribus.png|' -i scribus.desktop
sed \
-e 's|#!/usr/bin/python|#!/usr/bin/python2|' \