extra/chromium: fix

This commit is contained in:
Kevin Mihelich 2022-05-28 00:27:20 +00:00
parent 0d63994961
commit 90377cde81
4 changed files with 28 additions and 14 deletions

View file

@ -21,5 +21,5 @@ index b5821bf80a70f..bb49dca5f4664 100644
(target_os == "win" && (target_cpu == "x86" || target_cpu == "x64"))
--
2.35.1
2.36.1

View file

@ -21,5 +21,5 @@ index 3b474c47dc7ce..e7787535882f9 100644
rebase_path(web_idl_database, root_build_dir),
"--root_src_dir",
--
2.35.1
2.36.1

View file

@ -1,21 +1,21 @@
From d6c27f1f9f22f7285d1156b830683f3f2906ba8d Mon Sep 17 00:00:00 2001
From eedbf78a767be7161d58f4f1ae817f8db7fd5809 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Wed, 21 Jul 2021 21:37:31 -0600
Subject: [PATCH 3/3] Fix eu-strip build for newer GCC
---
.../third_party/eu-strip/0001-gcc-fixes.patch | 642 ++++++++++++++++++
.../third_party/eu-strip/0001-gcc-fixes.patch | 656 ++++++++++++++++++
buildtools/third_party/eu-strip/build.sh | 3 +-
2 files changed, 644 insertions(+), 1 deletion(-)
2 files changed, 658 insertions(+), 1 deletion(-)
create mode 100644 buildtools/third_party/eu-strip/0001-gcc-fixes.patch
diff --git a/buildtools/third_party/eu-strip/0001-gcc-fixes.patch b/buildtools/third_party/eu-strip/0001-gcc-fixes.patch
new file mode 100644
index 0000000000000..d6e49fc5260e6
index 0000000000000..14f45f2662938
--- /dev/null
+++ b/buildtools/third_party/eu-strip/0001-gcc-fixes.patch
@@ -0,0 +1,642 @@
+From 9402a72cccb52ec4b24d8ec3221ab2de39d40ab4 Mon Sep 17 00:00:00 2001
@@ -0,0 +1,656 @@
+From 62350f68539357e15fe7f6e1ec35be36af63fe43 Mon Sep 17 00:00:00 2001
+From: Kevin Mihelich <kevin@archlinuxarm.org>
+Date: Thu, 17 Feb 2022 19:58:58 -0700
+Subject: [PATCH] gcc fixes
@ -39,8 +39,9 @@ index 0000000000000..d6e49fc5260e6
+ libebl/libebl.h | 8 -----
+ libelf/libelfP.h | 4 +--
+ src/ar.c | 66 +++++++++++++++++++++++++-----------
+ src/elflint.c | 2 +-
+ tests/addrcfi.c | 2 +-
+ 19 files changed, 61 insertions(+), 259 deletions(-)
+ 20 files changed, 62 insertions(+), 260 deletions(-)
+ delete mode 100644 backends/i386_syscall.c
+ delete mode 100644 backends/ppc_syscall.c
+ delete mode 100644 backends/x86_64_syscall.c
@ -641,6 +642,19 @@ index 0000000000000..d6e49fc5260e6
+
+ return status;
+ }
+diff --git a/src/elflint.c b/src/elflint.c
+index 51e53c23..f3a85c3c 100644
+--- a/src/elflint.c
++++ b/src/elflint.c
+@@ -4073,7 +4073,7 @@ section [%2zu] '%s' has type NOBITS but is read from the file in segment of prog
+ bad = (databits == NULL
+ || databits->d_size != shdr->sh_size);
+ for (size_t idx = 0;
+- idx < databits->d_size && ! bad;
++ ! bad && idx < databits->d_size;
+ idx++)
+ bad = ((char *) databits->d_buf)[idx] != 0;
+
+diff --git a/tests/addrcfi.c b/tests/addrcfi.c
+index 589b8513..2b7d7bd0 100644
+--- a/tests/addrcfi.c
@ -655,7 +669,7 @@ index 0000000000000..d6e49fc5260e6
+ size_t nops;
+ int result = dwarf_frame_register (stuff->frame, regno, ops_mem, &ops, &nops);
+--
+2.35.1
+2.36.1
+
diff --git a/buildtools/third_party/eu-strip/build.sh b/buildtools/third_party/eu-strip/build.sh
index 86f2b67f6bbd1..c073e9a15827a 100755
@ -679,5 +693,5 @@ index 86f2b67f6bbd1..c073e9a15827a 100755
cd build
../configure --enable-maintainer-mode
--
2.35.1
2.36.1

View file

@ -56,9 +56,9 @@ sha256sums=('1a3797d36901fa3ba63744b9a870b65a8890c9a850442c160196bc64df886b1f'
'b94b2e88f63cfb7087486508b8139599c89f96d7a4181c61fec4b4e250ca327a'
'00c16ce83ea4ca924a50fa0cfc2b2a4d744c722f363b065323e6ba0fcbac45a5'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711'
'55011fb3e88733cfdf5ef845ad8c1dd749e6c6aa43353713aca57158a3935d97'
'5189b5780ae91170ebefbb9877a994beaf292df92e5f368f8c33141ec62cf298'
'5471654d71dd5bec2a1329f79fc8c91bb2cfb8e3adea71b84f0a99d0d054adb3')
'765d78ba10af7a4dfbf7badb1c32a2b9b4a21941531a766ca2cdc0ff00425d01'
'4c79e4beac02269c864e69264ba6325ea809a5fefb8f48553bb2a610b1bb45f5'
'597083226fd762c8e4fd527d4ea2478b8cbf9180f12740efd9c6a1f4798a5d3a')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
# Keys are the names in the above script; values are the dependencies in Arch