diff --git a/core/linux-armv7/PKGBUILD b/core/linux-armv7/PKGBUILD
index 66cbf621c..25c87df7f 100644
--- a/core/linux-armv7/PKGBUILD
+++ b/core/linux-armv7/PKGBUILD
@@ -7,7 +7,7 @@ pkgbase=linux-armv7
 _srcname=linux-3.15
 _kernelname=${pkgbase#linux}
 _desc="ARMv7 multi-platform"
-pkgver=3.15.0
+pkgver=3.15.1
 pkgrel=1
 rcnrel=armv7-x2
 arch=('armv7h')
@@ -16,29 +16,30 @@ license=('GPL2')
 makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git' 'uboot-tools')
 options=('!strip')
 source=("http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
-        #"http://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
+        "http://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
         "http://rcn-ee.net/deb/sid-armhf/v${pkgver}-${rcnrel}/patch-${pkgver%.0}-${rcnrel}.diff.gz"
-        #"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs${pkgver%.*}"
-        "git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.x-rcN"
+        "git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs${pkgver%.*}"
+        #"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.x-rcN"
         '0001-atags-add-support-for-marvell-uboot.patch'
         '0002-atags-retrieve-mac-addresses.patch'
         '0003-smileplug-devicetree.patch'
         '0004-emmc-timing-fix.patch'
         'config')
 md5sums=('97ca1625bb40368dc41b9a7971549071'
-         'ada2f334b3246e87bbfd44613eb1eb99'
+         '78a944411af297b9e5e9aa430056de4c'
+         '509b012f0f308d4cc3ce3fdf97021ce3'
          'SKIP'
          '3ad860d0d6daedc82091ea29c9730b95'
          '02cce6b8f88c4392f552b14d0bf2e71c'
          '0a0c5691aea2503cd0c503cb50244f48'
          '911bffe9c261ca5b91dd0a083d99e81f'
-         '3530333f5d95cf11109087b77be06901')
+         'aefe7c6a9c9fcc0e8dd038279e38364a')
 
 prepare() {
   cd "${srcdir}/${_srcname}"
 
   # add upstream patch
-  #patch -p1 -i ../patch-${pkgver}
+  patch -p1 -i ../patch-${pkgver}
 
   # RCN patch
   git apply ../patch-${pkgver%.0}-${rcnrel}.diff
diff --git a/core/linux-armv7/config b/core/linux-armv7/config
index e63d4c992..a2f3db66d 100644
--- a/core/linux-armv7/config
+++ b/core/linux-armv7/config
@@ -1,6 +1,6 @@
 #
 # Automatically generated file; DO NOT EDIT.
-# Linux/arm 3.15.0-1 Kernel Configuration
+# Linux/arm 3.15.1-1 Kernel Configuration
 #
 CONFIG_ARM=y
 CONFIG_ARM_HAS_SG_CHAIN=y
@@ -4547,7 +4547,7 @@ CONFIG_USB_EHCI_PCI=y
 CONFIG_USB_EHCI_HCD_OMAP=y
 CONFIG_USB_EHCI_HCD_ORION=y
 CONFIG_USB_EHCI_TEGRA=y
-# CONFIG_USB_EHCI_HCD_PLATFORM is not set
+CONFIG_USB_EHCI_HCD_PLATFORM=y
 # CONFIG_USB_OXU210HP_HCD is not set
 # CONFIG_USB_ISP116X_HCD is not set
 # CONFIG_USB_ISP1760_HCD is not set