extra/calligra: remove patch

This commit is contained in:
Kevin Mihelich 2015-10-08 01:44:19 +00:00
parent 2af700bc4e
commit 90ab6f7b4f
2 changed files with 2 additions and 43 deletions

View file

@ -5,7 +5,6 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - removed makedepend on vc - not for ARM
# - patch to remove qreal usage
pkgbase=calligra
pkgname=('calligra-braindump'
@ -35,11 +34,9 @@ makedepends=('cmake' 'automoc4' 'boost' 'kdepimlibs4' 'eigen' 'libmarble4'
'openjpeg' 'kdegraphics-okular' 'pstoedit' 'libvisio'
'libetonyek' 'libpqxx' 'libspnav' 'postgresql') # 'libqgit2'
groups=('calligra')
source=("http://download.kde.org/stable/${pkgbase}-${pkgver}/${pkgbase}-${pkgver}.tar.xz" 'libwps-0.4.patch'
'qreal.patch')
source=("http://download.kde.org/stable/${pkgbase}-${pkgver}/${pkgbase}-${pkgver}.tar.xz" 'libwps-0.4.patch')
md5sums=('c731ceb46211aea2a0e1798f646e0bcb'
'6ea15f8b3938838d89ea0aa08921afd1'
'266289d4f69f24941d3e94d526a350f2')
'6ea15f8b3938838d89ea0aa08921afd1')
prepare() {
mkdir -p build
@ -48,8 +45,6 @@ prepare() {
cd $pkgbase-$pkgver
patch -p1 -i "$srcdir"/libwps-0.4.patch
patch -p1 -i ../qreal.patch
# Fix build against libmarble4
sed -e 's|PATH_SUFFIXES marble|PATH_SUFFIXES marble4|g' -i CMakeLists.txt
sed -e 's|#include <marble/|#include <marble4/|g' -e 's|#include "marble/|#include "marble4/|g' \

View file

@ -1,36 +0,0 @@
diff -urN a/krita/plugins/paintops/chalk/kis_chalk_paintop_settings.cpp b/krita/plugins/paintops/chalk/kis_chalk_paintop_settings.cpp
--- a/krita/plugins/paintops/chalk/kis_chalk_paintop_settings.cpp 2015-08-29 08:39:29.000000000 -0600
+++ b/krita/plugins/paintops/chalk/kis_chalk_paintop_settings.cpp 2015-09-03 20:34:54.794178853 -0600
@@ -51,7 +51,7 @@
QPainterPath tiltLine;
QLineF tiltAngle(QPointF(0.0,0.0), QPointF(0.0,size));
- tiltAngle.setLength(qMax(size*0.5, qreal(50.0)) * (1 - info.tiltElevation(info, 60.0, 60.0, true)));
+ tiltAngle.setLength(qMax(size*0.5, 50.0) * (1 - info.tiltElevation(info, 60.0, 60.0, true)));
tiltAngle.setAngle((360.0 - fmod(KisPaintInformation::tiltDirection(info, true) * 360.0 + 270.0, 360.0))-3.0);
tiltLine.moveTo(tiltAngle.p1());
tiltLine.lineTo(tiltAngle.p2());
diff -urN a/krita/plugins/paintops/libpaintop/kis_brush_based_paintop_settings.cpp b/krita/plugins/paintops/libpaintop/kis_brush_based_paintop_settings.cpp
--- a/krita/plugins/paintops/libpaintop/kis_brush_based_paintop_settings.cpp 2015-08-29 08:39:29.000000000 -0600
+++ b/krita/plugins/paintops/libpaintop/kis_brush_based_paintop_settings.cpp 2015-09-03 20:34:32.054165712 -0600
@@ -73,7 +73,7 @@
QPainterPath realOutline = brush->outline();
QPainterPath tiltLine;
QLineF tiltAngle(realOutline.boundingRect().center(), realOutline.boundingRect().topLeft());
- tiltAngle.setLength(qMax(realOutline.boundingRect().width()*0.5, qreal(50.0)) * (1 - info.tiltElevation(info, 60.0, 60.0, true)));
+ tiltAngle.setLength(qMax(realOutline.boundingRect().width()*0.5, 50.0) * (1 - info.tiltElevation(info, 60.0, 60.0, true)));
tiltAngle.setAngle((360.0 - fmod(KisPaintInformation::tiltDirection(info, true) * 360.0 + 270.0, 360.0))-3.0);
tiltLine.moveTo(tiltAngle.p1());
tiltLine.lineTo(tiltAngle.p2());
diff -urN a/krita/plugins/paintops/sketch/kis_sketch_paintop_settings.cpp b/krita/plugins/paintops/sketch/kis_sketch_paintop_settings.cpp
--- a/krita/plugins/paintops/sketch/kis_sketch_paintop_settings.cpp 2015-08-29 08:39:29.000000000 -0600
+++ b/krita/plugins/paintops/sketch/kis_sketch_paintop_settings.cpp 2015-09-03 22:14:28.339044535 -0600
@@ -62,7 +62,7 @@
path = ellipseOutline(diameter, diameter, 1.0, 0.0/*brush->scale(), brush->angle()*/);
QPainterPath tiltLine;
QLineF tiltAngle(path.boundingRect().center(), path.boundingRect().topLeft());
- tiltAngle.setLength(qMax(diameter*0.5, qreal(50.0)) * (1 - info.tiltElevation(info, 60.0, 60.0, true)));
+ tiltAngle.setLength(qMax(diameter*0.5, 50.0) * (1 - info.tiltElevation(info, 60.0, 60.0, true)));
tiltAngle.setAngle((360.0 - fmod(KisPaintInformation::tiltDirection(info, true) * 360.0 + 270.0, 360.0))-3.0);
tiltLine.moveTo(tiltAngle.p1());
tiltLine.lineTo(tiltAngle.p2());