core/libsecret to 0.20.0-1

This commit is contained in:
Kevin Mihelich 2020-01-24 13:27:03 +00:00
parent c0b33d71d0
commit 90abb2a4cd
2 changed files with 11 additions and 35 deletions

View file

@ -1,26 +0,0 @@
From 0fc0d0059e0b8c1548da797d4996e20427295401 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Tue, 5 Mar 2019 20:05:09 -0700
Subject: [PATCH] Fix for building without valgrind
---
egg/egg-testing.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/egg/egg-testing.c b/egg/egg-testing.c
index 561e16a..85da119 100644
--- a/egg/egg-testing.c
+++ b/egg/egg-testing.c
@@ -27,7 +27,9 @@
#include <glib-object.h>
+#ifdef WITH_VALGRIND
#include <valgrind/valgrind.h>
+#endif
#include <glib.h>
#include <glib/gstdio.h>
--
2.21.0

View file

@ -2,11 +2,10 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - remove makedepend on valgrind
# - patch to fix building without valgrind
pkgname=libsecret
pkgver=0.19.1
pkgrel=3
pkgver=0.20.0
pkgrel=1
pkgdesc="Library for storing and retrieving passwords and other secrets"
url="https://wiki.gnome.org/Projects/Libsecret"
arch=(x86_64)
@ -15,11 +14,9 @@ depends=(glib2 libgcrypt)
checkdepends=(python-dbus dbus-glib python-gobject gjs)
makedepends=(docbook-xsl gobject-introspection vala git gtk-doc meson)
optdepends=('org.freedesktop.secrets: secret storage backend')
_commit=f576dfbe50f9aed22802ad0db0356d081f467d7a # tags/0.19.1^0
source=("git+https://gitlab.gnome.org/GNOME/libsecret.git#commit=$_commit"
'0001-Fix-for-building-without-valgrind.patch')
sha256sums=('SKIP'
'0dfdbe7bbccc388f7d76ac951c344aeec01f30e07fb64c3274d1b907c6b06ee8')
_commit=3939b03f39dfef9fa9c54f709d094893b90d82a0 # tags/0.20.0^0
source=("git+https://gitlab.gnome.org/GNOME/libsecret.git#commit=$_commit")
sha256sums=('SKIP')
pkgver() {
cd $pkgname
@ -28,7 +25,12 @@ pkgver() {
prepare() {
cd $pkgname
patch -p1 -i ../0001-Fix-for-building-without-valgrind.patch
# Build fixes
git cherry-pick -n \
cf21ad50b62f7c8e4b22ef374f0a73290a99bdb8 \
e6881d4ff1260c7308be56f21a9d354d7680dfaa \
2e85b13f8f3512f9cef0bed7cf8b6734af06bc9b
}
build() {