extra/claws-mail to 3.7.10-1

This commit is contained in:
Kevin Mihelich 2011-08-29 16:44:49 -04:00
parent fb38dd7335
commit 90ca23a1b1
3 changed files with 11 additions and 30 deletions

View file

@ -1,4 +1,4 @@
# $Id: PKGBUILD 135773 2011-08-18 15:03:55Z andyrtr $
# $Id: PKGBUILD 136386 2011-08-28 17:30:30Z andyrtr $
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
# ALARM: Kevin Mihelich <kevin@plugapps.com>
@ -7,8 +7,8 @@
plugrel=1
pkgname=claws-mail
pkgver=3.7.9
pkgrel=5
pkgver=3.7.10
pkgrel=1
pkgdesc="A GTK+ based e-mail client."
arch=('i686' 'x86_64')
license=('GPL3')
@ -19,21 +19,17 @@ makedepends=('compface' 'spamassassin' 'bogofilter')
optdepends=('python2: needed for some tools'
'perl: needed for some tools'
'spamassassin: adds support for spamfiltering'
'bogofilter: adds support for spamfiltering'
'html2ps: AUR pkg - adds support for printing html mails together with html plugins')
'bogofilter: adds support for spamfiltering')
replaces=('sylpheed-claws')
provides=('claws')
options=(!libtool)
install=claws-mail.install
source=(http://downloads.sourceforge.net/sourceforge/sylpheed-claws/${pkgname}-${pkgver}.tar.bz2
claws-notify-crash.patch)
md5sums=('2f9d2dcabf84e312cfeb56efa799b5b3'
'9a2903449f679344b5f5f51c91825b45')
source=(http://downloads.sourceforge.net/sourceforge/sylpheed-claws/${pkgname}-${pkgver}.tar.bz2)
md5sums=('fcf58dcff52f0908ff3bc368d820408b')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
patch -Np0 -i $srcdir/claws-notify-crash.patch
sed -i 's@^#!.*python.*@#!/usr/bin/python2@' tools/*.py
./configure --prefix=/usr --disable-static \

View file

@ -1,13 +1,16 @@
post_install() {
echo "install \"html2ps\" from AUR to add support for printing html mails together with html plugins"
gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
update-desktop-database -q
}
post_upgrade() {
post_install
gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
update-desktop-database -q
}
post_remove() {
post_install
gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
update-desktop-database -q
}

View file

@ -1,18 +0,0 @@
Index: src/main.c
===================================================================
RCS file: //claws/src/main.c,v
retrieving revision 1.115.2.237
retrieving revision 1.115.2.238
diff -u -r1.115.2.237 -r1.115.2.238
--- src/main.c 10 Apr 2011 17:19:04 -0000 1.115.2.237
+++ src/main.c 30 Apr 2011 19:27:15 -0000 1.115.2.238
@@ -331,7 +331,7 @@
gtk_widget_show(hack);
}
- xdisplay = gdk_display_get_default();
+ xdisplay = GDK_DISPLAY_XDISPLAY(gdk_display_get_default());
sn_display = sn_display_new(xdisplay,
sn_error_trap_push,
sn_error_trap_pop);