mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/linux-imx6-cubox-dt add lirc and fix dvi video
This commit is contained in:
parent
fe9aa556ac
commit
90cd5a21bc
3 changed files with 33 additions and 6 deletions
|
@ -15,7 +15,7 @@ _srcname=linux-linaro-stable-mx6-${_commit}
|
||||||
_kernelname=${pkgname#linux}
|
_kernelname=${pkgname#linux}
|
||||||
_basekernel=3.10
|
_basekernel=3.10
|
||||||
pkgver=${_basekernel}.30
|
pkgver=${_basekernel}.30
|
||||||
pkgrel=6
|
pkgrel=7
|
||||||
arch=('arm')
|
arch=('arm')
|
||||||
url="http://www.kernel.org/"
|
url="http://www.kernel.org/"
|
||||||
license=('GPL2')
|
license=('GPL2')
|
||||||
|
@ -23,10 +23,12 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'uboot-mkimage' 'git'
|
||||||
options=('!strip')
|
options=('!strip')
|
||||||
source=("https://github.com/solidrun/linux-linaro-stable-mx6/archive/${_commit}.tar.gz"
|
source=("https://github.com/solidrun/linux-linaro-stable-mx6/archive/${_commit}.tar.gz"
|
||||||
'config'
|
'config'
|
||||||
'change-default-console-loglevel.pat')
|
'change-default-console-loglevel.pat'
|
||||||
|
'mxc_hdmi-dont-require-cea-mode.patch')
|
||||||
md5sums=('40a7283cfa9b3519453928f787f67fe9'
|
md5sums=('40a7283cfa9b3519453928f787f67fe9'
|
||||||
'94076788e6115c7a6071a70f8626333d'
|
'40cddccd4c9ad68fcb98a089bde3842a'
|
||||||
'9d3c56a4b999c8bfbd4018089a62f662')
|
'9d3c56a4b999c8bfbd4018089a62f662'
|
||||||
|
'8dc29365fc5b0668c10f630cc5b5d82d')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd "${srcdir}/${_srcname}"
|
cd "${srcdir}/${_srcname}"
|
||||||
|
@ -43,7 +45,7 @@ prepare() {
|
||||||
# remove this when a Kconfig knob is made available by upstream
|
# remove this when a Kconfig knob is made available by upstream
|
||||||
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
|
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
|
||||||
patch -Np1 -i "${srcdir}/change-default-console-loglevel.pat"
|
patch -Np1 -i "${srcdir}/change-default-console-loglevel.pat"
|
||||||
|
patch -Np1 -i "${srcdir}/mxc_hdmi-dont-require-cea-mode.patch"
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
#
|
#
|
||||||
# Automatically generated file; DO NOT EDIT.
|
# Automatically generated file; DO NOT EDIT.
|
||||||
# Linux/arm 3.10.30-5 Kernel Configuration
|
# Linux/arm 3.10.30-7 Kernel Configuration
|
||||||
#
|
#
|
||||||
CONFIG_ARM=y
|
CONFIG_ARM=y
|
||||||
CONFIG_MIGHT_HAVE_PCI=y
|
CONFIG_MIGHT_HAVE_PCI=y
|
||||||
|
|
|
@ -0,0 +1,25 @@
|
||||||
|
This fixes problems with DVI monitors connected to the HDMI port
|
||||||
|
via a DVI <-> HDMI cable. With dvi monitors, the list of CEA modes
|
||||||
|
is always zero, preventing modes higher than 1024x768 to be used.
|
||||||
|
This patch disables the CEA mode check.
|
||||||
|
|
||||||
|
Upstream-Status: Pending
|
||||||
|
|
||||||
|
diff --git a/drivers/video/mxc/mxc_hdmi.c b/drivers/video/mxc/mxc_hdmi.c
|
||||||
|
index 544f352..fa67128 100644
|
||||||
|
--- a/drivers/video/mxc/mxc_hdmi.c
|
||||||
|
+++ b/drivers/video/mxc/mxc_hdmi.c
|
||||||
|
@@ -1804,10 +1804,10 @@ static void mxc_hdmi_edid_rebuild_modelist(struct mxc_hdmi *hdmi)
|
||||||
|
*/
|
||||||
|
mode = &hdmi->fbi->monspecs.modedb[i];
|
||||||
|
|
||||||
|
- if (!(mode->vmode & FB_VMODE_INTERLACED) &&
|
||||||
|
- (mxc_edid_mode_to_vic(mode) != 0)) {
|
||||||
|
+ if (!(mode->vmode & FB_VMODE_INTERLACED)) {
|
||||||
|
+ int vic = mxc_edid_mode_to_vic(mode);
|
||||||
|
|
||||||
|
- dev_dbg(&hdmi->pdev->dev, "Added mode %d:", i);
|
||||||
|
+ dev_dbg(&hdmi->pdev->dev, "%s: Added mode %d(VIC %u):", __func__, i, vic);
|
||||||
|
dev_dbg(&hdmi->pdev->dev,
|
||||||
|
"xres = %d, yres = %d, freq = %d, vmode = %d, flag = %d\n",
|
||||||
|
hdmi->fbi->monspecs.modedb[i].xres,
|
Loading…
Reference in a new issue