core/linux-armv7-rc fix

This commit is contained in:
Kevin Mihelich 2015-12-25 06:50:42 +00:00
parent 430ab3a95f
commit 90e712d138
10 changed files with 69 additions and 32 deletions

View file

@ -1,7 +1,7 @@
From 76442ff123d722a6a7542b35844cb57e17ea88c5 Mon Sep 17 00:00:00 2001
From 7c75672c751c1a9001f39bbe76c7ee092b4e6a29 Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:59:28 +0100
Subject: [PATCH 1/8] ARM: atags: add support for Marvell's u-boot
Subject: [PATCH 1/9] ARM: atags: add support for Marvell's u-boot
Marvell uses a specific atag in its u-boot which includes among other
information the MAC addresses for up to 4 network interfaces.
@ -47,5 +47,5 @@ index 979ff40..d1d0c19 100644
};
--
2.6.2
2.6.4

View file

@ -1,7 +1,7 @@
From a758b92c2e4ed56e4bddbffea97e104cf188f3d1 Mon Sep 17 00:00:00 2001
From 1fea82d0497ae305d2110585af7f57c81e0375df Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:56:58 +0100
Subject: [PATCH 2/8] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
Subject: [PATCH 2/9] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
loader
The atags are parsed and if a Marvell atag is found, up to 4 MAC
@ -43,5 +43,5 @@ index 9448aa0..ac7b6ae 100644
}
--
2.6.2
2.6.4

View file

@ -1,7 +1,7 @@
From dbea38d0148a1b3861b0e9ef06916838b9d24981 Mon Sep 17 00:00:00 2001
From 58707640a58c98688345a01cc4aaab5e9a5302ae Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:41:19 -0600
Subject: [PATCH 3/8] SMILE Plug device tree file
Subject: [PATCH 3/9] SMILE Plug device tree file
This adds a dts file for the SMILE Plug, which only differs from the Mirabox
dts with the LED definitions.
@ -205,5 +205,5 @@ index 0000000..d01308a
+ };
+};
--
2.6.2
2.6.4

View file

@ -1,7 +1,7 @@
From 92f52469dfbea8294ebbb988542fd2713cd2a306 Mon Sep 17 00:00:00 2001
From 279ad74e38e3c692eab7c59fae909fe22ea5d1dd Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:43:56 -0600
Subject: [PATCH 4/8] fix mvsdio eMMC timing
Subject: [PATCH 4/9] fix mvsdio eMMC timing
These changes from Globalscale change the MMC timing to allow the eMMC versions
of the Mirabox and SMILE Plug to work.
@ -34,5 +34,5 @@ index a448498..14441a6 100644
host->clock = ios->clock;
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
--
2.6.2
2.6.4

View file

@ -1,7 +1,7 @@
From 11f05ff2e937e42eab27b19d2f7c7554daa26c49 Mon Sep 17 00:00:00 2001
From dad3e39a200b3f91e5e4790fe95cdbfc27a18673 Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 5/8] net/smsc95xx: Allow mac address to be set as a parameter
Subject: [PATCH 5/9] net/smsc95xx: Allow mac address to be set as a parameter
---
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
@ -91,5 +91,5 @@ index 26423ad..e29a323 100644
if (smsc95xx_read_eeprom(dev, EEPROM_MAC_OFFSET, ETH_ALEN,
dev->net->dev_addr) == 0) {
--
2.6.2
2.6.4

View file

@ -1,7 +1,7 @@
From 5d8542ef5cfd5b09350f9eb61d439e25a63fc32e Mon Sep 17 00:00:00 2001
From 7e8b6c3551ea6a2b4e9201188a5fb79c5970f114 Mon Sep 17 00:00:00 2001
From: dobatog <dobatog@gmail.com>
Date: Thu, 26 Feb 2015 12:32:27 +0100
Subject: [PATCH 6/8] ARM: TLV320AIC23 SoC Audio Codec: Fix errors reported
Subject: [PATCH 6/9] ARM: TLV320AIC23 SoC Audio Codec: Fix errors reported
related to input routing signals.
The following patch, based on stable v3.19, corrects the errors that are reported in the boot trace in reference to the Input Signals of the audio codec TLV320AIC23:
@ -45,5 +45,5 @@ index cd8c02b..95e6b11 100644
/* input mux */
{"Capture Source", "Line", "Line Input"},
--
2.6.2
2.6.4

View file

@ -1,7 +1,7 @@
From 76a73d29fd0f45aa163d839ede4e21dd183f6ed3 Mon Sep 17 00:00:00 2001
From 31e04e014a3f8cc88b3755be8aa44a4d2051f53a Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 14 Feb 2015 12:32:27 +0100
Subject: [PATCH 7/8] set default cubietruck led triggers
Subject: [PATCH 7/9] set default cubietruck led triggers
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
@ -29,5 +29,5 @@ index e6b0192..fff91d3 100644
};
--
2.6.2
2.6.4

View file

@ -1,7 +1,7 @@
From 0ae1ec1ae555397c91db254b18c9d95d8fe7854f Mon Sep 17 00:00:00 2001
From 0bef4c3483f1a30f027ae375e1c04a2e6be91150 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 7 Feb 2015 12:32:27 +0100
Subject: [PATCH 8/8] USB armory support
Subject: [PATCH 8/9] USB armory support
---
arch/arm/boot/dts/Makefile | 5 +
@ -452,5 +452,5 @@ index 0000000..902a73b
+ status = "okay";
+};
--
2.6.2
2.6.4

View file

@ -0,0 +1,34 @@
From 1fdf53fafef2ccc0684a3b655e716b9921642197 Mon Sep 17 00:00:00 2001
From: Russell King <rmk+kernel@arm.linux.org.uk>
Date: Sun, 6 Dec 2015 23:28:37 +0000
Subject: [PATCH 9/9] ARM: dts: dove: add Dove divider clocks
Add the Dove divider clocks to the Dove dtsi file.
Acked-by: Andrew Lunn <andrew@lunn.ch>
Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
Signed-off-by: Gregory CLEMENT <gregory.clement@free-electrons.com>
---
arch/arm/boot/dts/dove.dtsi | 6 ++++++
1 file changed, 6 insertions(+)
diff --git a/arch/arm/boot/dts/dove.dtsi b/arch/arm/boot/dts/dove.dtsi
index 1791216..ea36a26 100644
--- a/arch/arm/boot/dts/dove.dtsi
+++ b/arch/arm/boot/dts/dove.dtsi
@@ -459,6 +459,12 @@
#clock-cells = <1>;
};
+ divider_clk: core-clock@0064 {
+ compatible = "marvell,dove-divider-clock";
+ reg = <0x0064 0x8>;
+ #clock-cells = <1>;
+ };
+
pinctrl: pin-ctrl@0200 {
compatible = "marvell,dove-pinctrl";
reg = <0x0200 0x14>,
--
2.6.4

View file

@ -31,6 +31,7 @@ source=(#"http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'0006-ARM-TLV320AIC23-SoC-Audio-Codec-Fix-errors-reported-.patch'
'0007-set-default-cubietruck-led-triggers.patch'
'0008-USB-armory-support.patch'
'0009-ARM-dts-dove-add-Dove-divider-clocks.patch'
'config'
'cmdline'
'kernel.its'
@ -38,14 +39,15 @@ source=(#"http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'kernel_data_key.vbprivk')
md5sums=('f167bbdeffcb172add1f574168083025'
'042633d1044aa984a503134e48ac59c6'
'8ea5f9e5dc4cccabb26a8fd0048da4a9'
'acc9cb3f7c34def13e311bbc7893c0d1'
'68b4a3e938d9ab24d8d82a2a7ddbff2a'
'649ae077135c10480ba52e8bad047780'
'7507fdc224b1000a81f87316befd0f6c'
'd77167c977871128b862b9aaffde23bc'
'acb3f83e664bd23fdddf69044b2b0eb4'
'825186972ceb93fe91a9b027731dd95b'
'57a686c6674aa9896a590181ac15bdd4'
'd589f8eb618b9e4b15d06d61482b6925'
'f973d396510cfd28a9e0024693d5caa7'
'e786bc0db8a868795545616e8e87d6e7'
'4384cc3a06932ef70d2981991a93ce62'
'2e6c1bda9a29b4308d82371e566f4332'
'a43cc24e0fc27caf96b03a7895dc6543'
'47a9efe2f0114b099662706a5c4d45e5'
'cc8885354fd6ce2bb63722a34c4d383a'
'7bb26e543e89e64aa98a7b668c1394db'
'1813b39074d01af6548951764a0f6444'
'4b0392e55063eb9f89d91affd1189fc5'
@ -70,6 +72,7 @@ prepare() {
git apply ../0006-ARM-TLV320AIC23-SoC-Audio-Codec-Fix-errors-reported-.patch
git apply ../0007-set-default-cubietruck-led-triggers.patch
git apply ../0008-USB-armory-support.patch
git apply ../0009-ARM-dts-dove-add-Dove-divider-clocks.patch
cat "${srcdir}/config" > ./.config