mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/qt5-webengine to 5.11.1-1
This commit is contained in:
parent
20ef368671
commit
9120b1b4a4
2 changed files with 8 additions and 53 deletions
|
@ -9,9 +9,9 @@ buildarch=12
|
|||
highmem=1
|
||||
|
||||
pkgname=qt5-webengine
|
||||
_qtver=5.11.0
|
||||
_qtver=5.11.1
|
||||
pkgver=${_qtver/-/}
|
||||
pkgrel=3
|
||||
pkgrel=1
|
||||
arch=('x86_64')
|
||||
url='http://qt-project.org/'
|
||||
license=('LGPL3' 'LGPL2.1' 'BSD')
|
||||
|
@ -22,17 +22,13 @@ makedepends=('python2' 'git' 'gperf' 'jsoncpp' 'ninja' 'qt5-tools')
|
|||
groups=('qt' 'qt5')
|
||||
_pkgfqn="${pkgname/5-/}-everywhere-src-${_qtver}"
|
||||
source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
|
||||
qtwebengine-harmony.patch qtwebengine-gcc8.patch qtwebengine-ffmpeg4.patch
|
||||
falkon-copy-menu.patch::"http://code.qt.io/cgit/qt/qtwebengine.git/patch/?id=af0c47b1"
|
||||
qtwebengine-wayland1.patch::"http://code.qt.io/cgit/qt/qtwebengine.git/patch/?id=9397251b"
|
||||
qtwebengine-wayland2.patch::"http://code.qt.io/cgit/qt/qtwebengine.git/patch/?id=a66d4cd8"
|
||||
qtwebengine-harmony.patch qtwebengine-ffmpeg4.patch
|
||||
qtwebengine-wayland.patch::"http://code.qt.io/cgit/qt/qtwebengine.git/patch/?id=a66d4cd8"
|
||||
0001-ARM-toolchain-fixes.patch)
|
||||
sha256sums=('5dd754d603c66d36e93b96b4f7c24a6e6269ae6a1682a524b8baa664d5c44b45'
|
||||
sha256sums=('389d9f42ca393ac11ec8932ce9771766dec91a4c761ffb685cc429c2a760d48c'
|
||||
'feca54ab09ac0fc9d0626770a6b899a6ac5a12173c7d0c1005bc3964ec83e7b3'
|
||||
'7f84891ef1ac9b7943ac5b92f2df8caf0c24c3695bdc6296926b581a87c0e856'
|
||||
'4a831d89fb0d6a6ced23115ced71e60513ce279fba4bd493178842647948f510'
|
||||
'b5b3d873c51ed2ad05b2ffe1f3d14cd95a732f0e1288c04a502d65576e316f5d'
|
||||
'6cd70c37f3b3aea926f1ee20c1f59354f2a02d240dbf344c6dc0a75f8aa8e07b'
|
||||
'6baeb241165a1fd94ada95b27924ba55f74761b1b9d406d73ebcce4b139abf60'
|
||||
'8202b09a1caa82538a2eacd79b62b61d8661c65cdfb275560d231aa31a362b12')
|
||||
|
||||
prepare() {
|
||||
|
@ -46,15 +42,10 @@ prepare() {
|
|||
|
||||
# FreeType 2.8.1
|
||||
patch -Np1 -i ../qtwebengine-harmony.patch
|
||||
|
||||
# Fix copy context menu
|
||||
patch -p1 -i ../falkon-copy-menu.patch
|
||||
# Fix openGL detection on Wayland
|
||||
patch -p1 -i ../qtwebengine-wayland1.patch
|
||||
patch -p1 -i ../qtwebengine-wayland2.patch
|
||||
# Fix build with gcc8 (Fedora)
|
||||
patch -p1 -i ../qtwebengine-wayland.patch
|
||||
|
||||
cd src/3rdparty/chromium
|
||||
patch -p1 -i "$srcdir"/qtwebengine-gcc8.patch
|
||||
# Fix build with ffmpeg 4
|
||||
patch -p2 -i "$srcdir"/qtwebengine-ffmpeg4.patch
|
||||
|
||||
|
|
|
@ -1,36 +0,0 @@
|
|||
diff -up chromium-65.0.3325.162/mojo/public/cpp/bindings/associated_interface_ptr_info.h.boolfix chromium-65.0.3325.162/mojo/public/cpp/bindings/associated_interface_ptr_info.h
|
||||
--- chromium-65.0.3325.162/mojo/public/cpp/bindings/associated_interface_ptr_info.h.boolfix 2018-03-15 13:07:54.999428755 -0400
|
||||
+++ chromium-65.0.3325.162/mojo/public/cpp/bindings/associated_interface_ptr_info.h 2018-03-15 13:08:21.270794252 -0400
|
||||
@@ -45,7 +45,7 @@ class AssociatedInterfacePtrInfo {
|
||||
|
||||
bool is_valid() const { return handle_.is_valid(); }
|
||||
|
||||
- explicit operator bool() const { return handle_; }
|
||||
+ explicit operator bool() const { return (bool) handle_; }
|
||||
|
||||
ScopedInterfaceEndpointHandle PassHandle() {
|
||||
return std::move(handle_);
|
||||
diff -up chromium-65.0.3325.162/mojo/public/cpp/bindings/associated_interface_request.h.boolfix chromium-65.0.3325.162/mojo/public/cpp/bindings/associated_interface_request.h
|
||||
--- chromium-65.0.3325.162/mojo/public/cpp/bindings/associated_interface_request.h.boolfix 2018-03-15 13:07:09.680523296 -0400
|
||||
+++ chromium-65.0.3325.162/mojo/public/cpp/bindings/associated_interface_request.h 2018-03-15 13:07:44.429684037 -0400
|
||||
@@ -50,7 +50,7 @@ class AssociatedInterfaceRequest {
|
||||
// handle.
|
||||
bool is_pending() const { return handle_.is_valid(); }
|
||||
|
||||
- explicit operator bool() const { return handle_; }
|
||||
+ explicit operator bool() const { return (bool) handle_; }
|
||||
|
||||
ScopedInterfaceEndpointHandle PassHandle() { return std::move(handle_); }
|
||||
|
||||
diff -up chromium-65.0.3325.162/mojo/public/cpp/bindings/interface_request.h.boolfix chromium-65.0.3325.162/mojo/public/cpp/bindings/interface_request.h
|
||||
--- chromium-65.0.3325.162/mojo/public/cpp/bindings/interface_request.h.boolfix 2018-03-15 13:08:33.494499025 -0400
|
||||
+++ chromium-65.0.3325.162/mojo/public/cpp/bindings/interface_request.h 2018-03-15 13:10:39.218462546 -0400
|
||||
@@ -54,7 +54,7 @@ class InterfaceRequest {
|
||||
// Indicates whether the request currently contains a valid message pipe.
|
||||
bool is_pending() const { return handle_.is_valid(); }
|
||||
|
||||
- explicit operator bool() const { return handle_; }
|
||||
+ explicit operator bool() const { return (bool) handle_; }
|
||||
|
||||
// Removes the message pipe from the request and returns it.
|
||||
ScopedMessagePipeHandle PassMessagePipe() { return std::move(handle_); }
|
Loading…
Reference in a new issue