mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
community/libopenshot-audio to 0.1.9-1
This commit is contained in:
parent
7343660406
commit
914ebe37c3
2 changed files with 25 additions and 22 deletions
|
@ -7,39 +7,38 @@
|
||||||
# - patch to link v5/v6 with libatomic
|
# - patch to link v5/v6 with libatomic
|
||||||
|
|
||||||
pkgname=libopenshot-audio
|
pkgname=libopenshot-audio
|
||||||
pkgver=0.1.8
|
pkgver=0.1.9
|
||||||
pkgrel=3
|
pkgrel=1
|
||||||
pkgdesc="A high-quality audio editing and playback library used by libopenshot."
|
pkgdesc="A high-quality audio editing and playback library used by libopenshot."
|
||||||
arch=('x86_64')
|
arch=('x86_64')
|
||||||
url="https://openshot.org/"
|
url="https://openshot.org/"
|
||||||
license=('GPL3')
|
license=('GPL3')
|
||||||
depends=('alsa-lib' 'gcc-libs' 'glibc' 'zlib')
|
depends=('gcc-libs' 'glibc' 'zlib')
|
||||||
makedepends=('cmake' 'doxygen' 'freetype2' 'libx11')
|
makedepends=('alsa-lib' 'cmake' 'doxygen' 'freetype2' 'libx11')
|
||||||
provides=('libopenshot-audio.so')
|
provides=('libopenshot-audio.so')
|
||||||
source=("$pkgname-$pkgver.tar.gz::https://github.com/OpenShot/libopenshot-audio/archive/v$pkgver.tar.gz"
|
source=("$pkgname-$pkgver.tar.gz::https://github.com/OpenShot/libopenshot-audio/archive/v$pkgver.tar.gz"
|
||||||
"$pkgname-cleanup-juce.patch::https://patch-diff.githubusercontent.com/raw/OpenShot/libopenshot-audio/pull/39.patch"
|
atomic.patch)
|
||||||
'atomic.patch')
|
sha512sums=('8113bf6f5747b0f72391a30560f49c97b13c68994097170797cdfeb44813791b90b073a6caffc91ba1a2153a41b86e8c1b188de0daaec3f5c785013c049c1b4d'
|
||||||
sha256sums=('384d0ef39c78f16d77048de3c96152321724084f978dc622675dd6bb16e15e19'
|
'5b527fc2406342bff8d29a2736226ce214dbf6ecf90a0e90e424ff68edf535d5eefcbe720201af3876c2c0b86eda1c8749c52984d3996d471d80ecabafad39e9')
|
||||||
'ae784a96730f7cf09ba7bf29d06704ba6a0eca662d242d786b0a86a4343e9dc9'
|
|
||||||
'f066a57428a6239af4cde7a81a6dc579cc85062f4877def11b0650673f34eb6f')
|
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd "${pkgname}-${pkgver}"
|
cd "${pkgname}-${pkgver}"
|
||||||
patch -Np1 -i "../$pkgname-cleanup-juce.patch"
|
|
||||||
mkdir -vp build
|
|
||||||
if [[ $CARCH == "armv6h" || $CARCH == "arm" ]]; then
|
if [[ $CARCH == "armv6h" || $CARCH == "arm" ]]; then
|
||||||
patch -p0 -i ../atomic.patch
|
patch -p1 -i ../atomic.patch
|
||||||
fi
|
fi
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd "${pkgname}-${pkgver}"
|
cd "${pkgname}-${pkgver}"
|
||||||
cmake -DCMAKE_INSTALL_PREFIX=/usr \
|
cmake -DCMAKE_INSTALL_PREFIX=/usr \
|
||||||
-B build
|
-B build \
|
||||||
make -C build
|
-S .
|
||||||
|
make VERBOSE=1 -C build
|
||||||
}
|
}
|
||||||
|
|
||||||
package() {
|
package() {
|
||||||
|
depends+=('libasound.so')
|
||||||
cd "${pkgname}-${pkgver}"
|
cd "${pkgname}-${pkgver}"
|
||||||
make -C build DESTDIR="${pkgdir}" install
|
make VERBOSE=1 DESTDIR="${pkgdir}" install -C build
|
||||||
|
install -vDm 644 {AUTHORS,README.md} -t "${pkgdir}/usr/share/doc/${pkgname}"
|
||||||
}
|
}
|
||||||
|
|
|
@ -1,10 +1,14 @@
|
||||||
--- CMakeLists.txt.orig 2019-09-14 18:32:29.243288029 -0600
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||||
+++ CMakeLists.txt 2019-09-14 18:32:37.747281464 -0600
|
index 9a80f95..1bf02ab 100644
|
||||||
@@ -177,6 +177,7 @@
|
--- a/CMakeLists.txt
|
||||||
|
+++ b/CMakeLists.txt
|
||||||
|
@@ -202,7 +202,8 @@ target_link_libraries(openshot-audio PUBLIC ZLIB::ZLIB)
|
||||||
|
|
||||||
|
target_link_libraries(openshot-audio PUBLIC
|
||||||
${CMAKE_DL_LIBS}
|
${CMAKE_DL_LIBS}
|
||||||
${CMAKE_THREAD_LIBS_INIT}
|
- ${JUCE_PLATFORM_SPECIFIC_LIBRARIES} )
|
||||||
${JUCE_PLATFORM_SPECIFIC_LIBRARIES}
|
+ ${JUCE_PLATFORM_SPECIFIC_LIBRARIES}
|
||||||
+ atomic
|
+ atomic)
|
||||||
)
|
|
||||||
|
|
||||||
# PROCESS SUB-DIRECTORIES
|
# PROCESS SUB-DIRECTORIES
|
||||||
|
add_subdirectory(src)
|
||||||
|
|
Loading…
Reference in a new issue