community/libopenshot-audio to 0.1.9-1

This commit is contained in:
Kevin Mihelich 2020-02-11 13:43:47 +00:00
parent 7343660406
commit 914ebe37c3
2 changed files with 25 additions and 22 deletions

View file

@ -7,39 +7,38 @@
# - patch to link v5/v6 with libatomic
pkgname=libopenshot-audio
pkgver=0.1.8
pkgrel=3
pkgver=0.1.9
pkgrel=1
pkgdesc="A high-quality audio editing and playback library used by libopenshot."
arch=('x86_64')
url="https://openshot.org/"
license=('GPL3')
depends=('alsa-lib' 'gcc-libs' 'glibc' 'zlib')
makedepends=('cmake' 'doxygen' 'freetype2' 'libx11')
depends=('gcc-libs' 'glibc' 'zlib')
makedepends=('alsa-lib' 'cmake' 'doxygen' 'freetype2' 'libx11')
provides=('libopenshot-audio.so')
source=("$pkgname-$pkgver.tar.gz::https://github.com/OpenShot/libopenshot-audio/archive/v$pkgver.tar.gz"
"$pkgname-cleanup-juce.patch::https://patch-diff.githubusercontent.com/raw/OpenShot/libopenshot-audio/pull/39.patch"
'atomic.patch')
sha256sums=('384d0ef39c78f16d77048de3c96152321724084f978dc622675dd6bb16e15e19'
'ae784a96730f7cf09ba7bf29d06704ba6a0eca662d242d786b0a86a4343e9dc9'
'f066a57428a6239af4cde7a81a6dc579cc85062f4877def11b0650673f34eb6f')
atomic.patch)
sha512sums=('8113bf6f5747b0f72391a30560f49c97b13c68994097170797cdfeb44813791b90b073a6caffc91ba1a2153a41b86e8c1b188de0daaec3f5c785013c049c1b4d'
'5b527fc2406342bff8d29a2736226ce214dbf6ecf90a0e90e424ff68edf535d5eefcbe720201af3876c2c0b86eda1c8749c52984d3996d471d80ecabafad39e9')
prepare() {
cd "${pkgname}-${pkgver}"
patch -Np1 -i "../$pkgname-cleanup-juce.patch"
mkdir -vp build
if [[ $CARCH == "armv6h" || $CARCH == "arm" ]]; then
patch -p0 -i ../atomic.patch
patch -p1 -i ../atomic.patch
fi
}
build() {
cd "${pkgname}-${pkgver}"
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-B build
make -C build
-B build \
-S .
make VERBOSE=1 -C build
}
package() {
depends+=('libasound.so')
cd "${pkgname}-${pkgver}"
make -C build DESTDIR="${pkgdir}" install
make VERBOSE=1 DESTDIR="${pkgdir}" install -C build
install -vDm 644 {AUTHORS,README.md} -t "${pkgdir}/usr/share/doc/${pkgname}"
}

View file

@ -1,10 +1,14 @@
--- CMakeLists.txt.orig 2019-09-14 18:32:29.243288029 -0600
+++ CMakeLists.txt 2019-09-14 18:32:37.747281464 -0600
@@ -177,6 +177,7 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9a80f95..1bf02ab 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -202,7 +202,8 @@ target_link_libraries(openshot-audio PUBLIC ZLIB::ZLIB)
target_link_libraries(openshot-audio PUBLIC
${CMAKE_DL_LIBS}
${CMAKE_THREAD_LIBS_INIT}
${JUCE_PLATFORM_SPECIFIC_LIBRARIES}
+ atomic
)
- ${JUCE_PLATFORM_SPECIFIC_LIBRARIES} )
+ ${JUCE_PLATFORM_SPECIFIC_LIBRARIES}
+ atomic)
# PROCESS SUB-DIRECTORIES
add_subdirectory(src)