added extra/gnome-shell

This commit is contained in:
Kevin Mihelich 2017-05-12 01:40:07 +00:00
parent 5bb1a5c0d7
commit 915616f820
2 changed files with 85 additions and 0 deletions

View file

@ -0,0 +1,73 @@
# $Id$
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Flamelab <panosfilip@gmail.com
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - configure with --enable-compile-warnings=no
pkgname=gnome-shell
pkgver=3.24.2
pkgrel=1
pkgdesc="The next generation GNOME Shell"
url="https://wiki.gnome.org/Projects/GnomeShell"
arch=(i686 x86_64)
license=(GPL2)
depends=(accountsservice caribou gcr gjs gnome-bluetooth gnome-menus upower
gnome-session gnome-settings-daemon gnome-themes-standard gsettings-desktop-schemas
libcanberra-pulse libcroco libgdm libsecret mutter nm-connection-editor
telepathy-logger telepathy-mission-control unzip gstreamer)
makedepends=(intltool gtk-doc gnome-control-center evolution-data-server python
gobject-introspection git gnome-common)
optdepends=('gnome-control-center: System settings'
'evolution-data-server: Evolution calendar integration')
groups=(gnome)
_commit=58ed983b65d3406c18a2dafb657af5c770b4c49f # tags/3.24.2^0
source=("git+https://git.gnome.org/browse/gnome-shell#commit=$_commit"
"git+https://git.gnome.org/browse/libgnome-volume-control"
"git+https://git.gnome.org/browse/gnome-shell-sass"
nm-libexecdir.patch)
sha256sums=('SKIP'
'SKIP'
'SKIP'
'e5bb10ad2e5c3e0fde3d05babd1bfdda701e553e02d493f7e54cb7832ce7e607')
pkgver() {
cd $pkgname
git describe --tags | sed 's/-/+/g'
}
prepare() {
cd $pkgname
git submodule init
git config --local submodule.src/gvc.url "$srcdir/libgnome-volume-control"
git config --local submodule.data/theme/gnome-shell-sass.url "$srcdir/gnome-shell-sass"
git submodule update
# FS#30747 FS#32730 Problems due to libexecdir different from NM
patch -Np1 -i ../nm-libexecdir.patch
NOCONFIGURE=1 ./autogen.sh
}
build() {
cd $pkgname
./configure --prefix=/usr --sysconfdir=/etc \
--libexecdir=/usr/lib/gnome-shell \
--localstatedir=/var --disable-static \
--disable-schemas-compile --enable-gtk-doc --enable-compile-warnings=no \
BROWSER_PLUGIN_DIR=/usr/lib/epiphany/plugins
# https://bugzilla.gnome.org/show_bug.cgi?id=655517
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
package() {
cd $pkgname
make DESTDIR="$pkgdir" install
# Must exist; FS#37412
mkdir "$pkgdir/usr/share/gnome-shell/modes"
}

View file

@ -0,0 +1,12 @@
diff -u -Nr gnome-shell-3.6.3.1/js/ui/components/networkAgent.js gnome-shell-3.6.3.1-nmlibexecdir/js/ui/components/networkAgent.js
--- gnome-shell-3.6.3.1/js/ui/components/networkAgent.js 2013-02-20 20:31:03.000000000 +0100
+++ gnome-shell-3.6.3.1-nmlibexecdir/js/ui/components/networkAgent.js 2013-03-10 17:13:46.120907065 +0100
@@ -686,7 +686,7 @@
} catch(e) { } // ignore errors if key does not exist
let path = binary;
if (!GLib.path_is_absolute(path)) {
- path = GLib.build_filenamev([Config.LIBEXECDIR, path]);
+ path = GLib.build_filenamev(["/usr/lib/networkmanager", path]);
}
if (GLib.file_test(path, GLib.FileTest.IS_EXECUTABLE))