mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/java8-openjdk to 8.u312-1
This commit is contained in:
parent
ffe0892f20
commit
916e175dbe
2 changed files with 92 additions and 13 deletions
|
@ -14,11 +14,11 @@ buildarch=22
|
|||
pkgname=('jre8-openjdk-headless' 'jre8-openjdk' 'jdk8-openjdk' 'openjdk8-src')
|
||||
pkgbase=java8-openjdk
|
||||
_java_ver=8
|
||||
_jdk_update=292
|
||||
_jdk_update=312
|
||||
_jdk_build=10
|
||||
pkgver=${_java_ver}.u${_jdk_update}
|
||||
_repo_ver=jdk${_java_ver}u${_jdk_update}-b${_jdk_build}
|
||||
pkgrel=1.1
|
||||
_repo_ver=jdk${_java_ver}u${_jdk_update}-ga
|
||||
pkgrel=1
|
||||
arch=('x86_64')
|
||||
url='https://openjdk.java.net/'
|
||||
license=('custom')
|
||||
|
@ -34,16 +34,18 @@ source=(jdk8u-${_repo_ver}.tar.gz::${_url_src}/archive/${_repo_ver}.tar.gz
|
|||
jaxp-${_repo_ver}.tar.gz::${_url_src}/jaxp/archive/${_repo_ver}.tar.gz
|
||||
langtools-${_repo_ver}.tar.gz::${_url_src}/langtools/archive/${_repo_ver}.tar.gz
|
||||
nashorn-${_repo_ver}.tar.gz::${_url_src}/nashorn/archive/${_repo_ver}.tar.gz
|
||||
gcc11.patch
|
||||
8143245-pr3548.patch)
|
||||
|
||||
sha256sums=('aba46c3c758b5fdedc812ce7d8ac46b45c3dfc2c51e41f9b23683d3ea4119d2b'
|
||||
'55028874f71eda4bd170580885dd1bf707fd69c1e4a4af14175e6ac777ef5927'
|
||||
'6a6be1e9d69d0bc8ca98b356e1150baae9e112241e3392c2adb6b30ec82864af'
|
||||
'67f1c3a2c897c81bafb14327fcea249b9faac31a0b4d09321eae79847d4ea509'
|
||||
'749073e9ba943a6fc87239d808463b05c804a5855fbc8c99fe9a090ae8cd07ef'
|
||||
'ca954d02629c43a0b553df75c1c7fe9cea31c428d99a9718a3e6860d684fb8a1'
|
||||
'e742f778cbdcb76b4dc593b9fed4bee26af91972096a265c1edb6d8e6ddf6fa3'
|
||||
'1f335e8fb4ddff5786d1b65345daa4e525aa4ebcefe7e24bf5428b259e47c5d0'
|
||||
sha256sums=('c10d984ab561f9e9733c313432e0da88bed9cde5202b462bc73cfe488fc65328'
|
||||
'0a66933a2d7011eece138ca1e8d3db584335c711463092c79ada638c825c41d1'
|
||||
'1bef21655dae14e1964c14add6c23c6c2f555a79e269a3bfe06e8a8d2a23fd0a'
|
||||
'f06786055e3266913a0c3b647e877d6bcffea618503c5ac30f6e224d98013207'
|
||||
'8bf8a31a5bdf98ebc1b30163b952a86288ecb1d3411f4ac659eed6a020a4f9d7'
|
||||
'd394e6e3f7858ec16d9f32b147f30f01d37bf5fbc8428019171f6677bb511ef4'
|
||||
'684ed7650fba6e36272d85076cdeabf73c22917e1b9e5a37c9645a91918eeab3'
|
||||
'253d8ffa68f210d284c3344d5df94f2ef1279e5a4155a2a1b3d2436d552864b1'
|
||||
'e1e9452b2078c3e9b45aa73491f3f187e7a9abbc40b6a7fc9239d4e5e525569e'
|
||||
'cebae4e056c738d54833c086e9379d2054ff80887c1f4e4ad14496c7ec65f665')
|
||||
|
||||
case "${CARCH}" in
|
||||
|
@ -62,6 +64,9 @@ _nonheadless=(bin/policytool
|
|||
lib/${_JARCH}/libsplashscreen.so)
|
||||
|
||||
prepare() {
|
||||
# Fix build with C++17 (Fedora)
|
||||
patch -d hotspot-${_repo_ver} -p2 < gcc11.patch
|
||||
|
||||
cd jdk8u-${_repo_ver}
|
||||
for subrepo in corba hotspot jdk jaxws jaxp langtools nashorn; do
|
||||
ln -s ../${subrepo}-${_repo_ver} ${subrepo}
|
||||
|
@ -80,8 +85,8 @@ build() {
|
|||
export MAKEFLAGS=${MAKEFLAGS/-j*}
|
||||
|
||||
# Avoid optimization of HotSpot being lowered from O3 to O2
|
||||
export CFLAGS="${CFLAGS//-O2/-O3} ${CPPFLAGS} -Wno-error=deprecated-declarations -Wno-error=stringop-overflow= -Wno-error=return-type -Wno-error=cpp -fno-lifetime-dse -fno-delete-null-pointer-checks -fcommon -Wno-error=format-overflow="
|
||||
export CXXFLAGS="${CXXFLAGS} ${CPPFLAGS} -fcommon"
|
||||
export CFLAGS="${CFLAGS//-O2/-O3} -Wno-error=deprecated-declarations -Wno-error=stringop-overflow= -Wno-error=return-type -Wno-error=cpp -fno-lifetime-dse -fno-delete-null-pointer-checks -fcommon -Wno-error=format-overflow="
|
||||
export CXXFLAGS="${CXXFLAGS} -fcommon"
|
||||
|
||||
install -d -m 755 "${srcdir}/${_prefix}/"
|
||||
sh configure \
|
||||
|
|
74
extra/java8-openjdk/gcc11.patch
Normal file
74
extra/java8-openjdk/gcc11.patch
Normal file
|
@ -0,0 +1,74 @@
|
|||
diff --git a/openjdk/hotspot/src/share/vm/adlc/adlparse.cpp b/openjdk/hotspot/src/share/vm/adlc/adlparse.cpp
|
||||
index 31955ff7..6dcd90ac 100644
|
||||
--- openjdk/hotspot/src/share/vm/adlc/adlparse.cpp
|
||||
+++ openjdk/hotspot/src/share/vm/adlc/adlparse.cpp
|
||||
@@ -4564,7 +4564,7 @@ char *ADLParser::get_paren_expr(const char *description, bool include_location)
|
||||
// string(still inside the file buffer). Returns a pointer to the string or
|
||||
// NULL if some other token is found instead.
|
||||
char *ADLParser::get_ident_common(bool do_preproc) {
|
||||
- register char c;
|
||||
+ char c;
|
||||
char *start; // Pointer to start of token
|
||||
char *end; // Pointer to end of token
|
||||
|
||||
@@ -4762,7 +4762,7 @@ char *ADLParser::get_unique_ident(FormDict& dict, const char* nameDescription){
|
||||
// invokes a parse_err if the next token is not an integer.
|
||||
// This routine does not leave the integer null-terminated.
|
||||
int ADLParser::get_int(void) {
|
||||
- register char c;
|
||||
+ char c;
|
||||
char *start; // Pointer to start of token
|
||||
char *end; // Pointer to end of token
|
||||
int result; // Storage for integer result
|
||||
diff --git a/openjdk/hotspot/src/share/vm/adlc/arena.cpp b/openjdk/hotspot/src/share/vm/adlc/arena.cpp
|
||||
index d7e4fc6e..406187ae 100644
|
||||
--- openjdk/hotspot/src/share/vm/adlc/arena.cpp
|
||||
+++ openjdk/hotspot/src/share/vm/adlc/arena.cpp
|
||||
@@ -79,7 +79,7 @@ Arena::Arena( Arena *a )
|
||||
// Total of all Chunks in arena
|
||||
size_t Arena::used() const {
|
||||
size_t sum = _chunk->_len - (_max-_hwm); // Size leftover in this Chunk
|
||||
- register Chunk *k = _first;
|
||||
+ Chunk *k = _first;
|
||||
while( k != _chunk) { // Whilst have Chunks in a row
|
||||
sum += k->_len; // Total size of this Chunk
|
||||
k = k->_next; // Bump along to next Chunk
|
||||
@@ -93,7 +93,7 @@ void* Arena::grow( size_t x ) {
|
||||
// Get minimal required size. Either real big, or even bigger for giant objs
|
||||
size_t len = max(x, Chunk::size);
|
||||
|
||||
- register Chunk *k = _chunk; // Get filled-up chunk address
|
||||
+ Chunk *k = _chunk; // Get filled-up chunk address
|
||||
_chunk = new (len) Chunk(len);
|
||||
|
||||
if( k ) k->_next = _chunk; // Append new chunk to end of linked list
|
||||
diff --git a/openjdk/hotspot/src/share/vm/adlc/dict2.cpp b/openjdk/hotspot/src/share/vm/adlc/dict2.cpp
|
||||
index f341a2b6..2dc60b25 100644
|
||||
--- openjdk/hotspot/src/share/vm/adlc/dict2.cpp
|
||||
+++ openjdk/hotspot/src/share/vm/adlc/dict2.cpp
|
||||
@@ -283,9 +283,9 @@ void Dict::print(PrintKeyOrValue print_key, PrintKeyOrValue print_value) {
|
||||
// limited to MAXID characters in length. Experimental evidence on 150K of
|
||||
// C text shows excellent spreading of values for any size hash table.
|
||||
int hashstr(const void *t) {
|
||||
- register char c, k = 0;
|
||||
- register int sum = 0;
|
||||
- register const char *s = (const char *)t;
|
||||
+ char c, k = 0;
|
||||
+ int sum = 0;
|
||||
+ const char *s = (const char *)t;
|
||||
|
||||
while (((c = s[k]) != '\0') && (k < MAXID-1)) { // Get characters till nul
|
||||
c = (char) ((c << 1) + 1); // Characters are always odd!
|
||||
diff --git a/openjdk/hotspot/src/share/vm/adlc/main.cpp b/openjdk/hotspot/src/share/vm/adlc/main.cpp
|
||||
index 52044f12..40bcda74 100644
|
||||
--- openjdk/hotspot/src/share/vm/adlc/main.cpp
|
||||
+++ openjdk/hotspot/src/share/vm/adlc/main.cpp
|
||||
@@ -58,7 +58,7 @@ int main(int argc, char *argv[])
|
||||
|
||||
// Read command line arguments and file names
|
||||
for( int i = 1; i < argc; i++ ) { // For all arguments
|
||||
- register char *s = argv[i]; // Get option/filename
|
||||
+ char *s = argv[i]; // Get option/filename
|
||||
|
||||
if( *s++ == '-' ) { // It's a flag? (not a filename)
|
||||
if( !*s ) { // Stand-alone `-' means stdin
|
Loading…
Reference in a new issue