core/file to 5.38-3

This commit is contained in:
Kevin Mihelich 2020-01-31 19:07:36 +00:00
parent 6524ad8d95
commit 91a506d8a8
3 changed files with 65 additions and 3 deletions

View file

@ -0,0 +1,30 @@
From 84221b0370a8b49e0fa2dbd88c89fb6e87ec95bd Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?S=C3=A9bastien=20Luttringer?= <seblu@seblu.net>
Date: Fri, 24 Jan 2020 17:07:11 +0100
Subject: [PATCH] Revert "Don't depend on the execute bit to determine pie
executable or shared object."
This reverts commit d653309de04ed10fdeda79f2c6ca7a7e96e122f1.
---
magic/Magdir/elf | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/magic/Magdir/elf b/magic/Magdir/elf
index b5a2e00b..a35b615d 100644
--- a/magic/Magdir/elf
+++ b/magic/Magdir/elf
@@ -50,8 +50,9 @@
!:mime application/x-object
>16 leshort 2 executable,
!:mime application/x-executable
->16 leshort 3 shared object,
-!:mime application/x-sharedlib
+>16 leshort 3 ${x?pie executable:shared object},
+
+!:mime application/x-${x?pie-executable:sharedlib}
>16 leshort 4 core file,
!:mime application/x-coredump
# OS-specific
--
2.25.0

View file

@ -8,7 +8,7 @@
pkgname=file
pkgver=5.38
pkgrel=1.1
pkgrel=3
pkgdesc='File type identification utility'
arch=('x86_64')
license=('custom')
@ -16,10 +16,14 @@ groups=('base-devel')
url='https://www.darwinsys.com/file/'
depends=('glibc' 'zlib' 'xz' 'bzip2')
provides=('libmagic.so')
source=("ftp://ftp.astron.com/pub/$pkgname/$pkgname-$pkgver.tar.gz"{,.asc})
source=("ftp://ftp.astron.com/pub/$pkgname/$pkgname-$pkgver.tar.gz"{,.asc}
file-5.38-seccomp-tcgets.patch
0001-Revert-Don-t-depend-on-the-execute-bit-to-determine-.patch)
validpgpkeys=('BE04995BA8F90ED0C0C176C471112AB16CB33B3A') # Christos Zoulas
sha256sums=('593c2ffc2ab349c5aea0f55fedfe4d681737b6b62376a9b3ad1e77b2cc19fa34'
'SKIP')
'SKIP'
'da6197e89ca53bd4f0d9009fa3a18c6fdb66dc07eb92e6bd77207eadb4548cfe'
'5636b444d147d6598c3defd0ce0a9b28056f2f64b09ef7f032337ed0308b8490')
prepare() {
cd $pkgname-$pkgver

View file

@ -0,0 +1,28 @@
From 78573ec1c43346064661169c5c8df32e7c3bd6d6 Mon Sep 17 00:00:00 2001
From: Christos Zoulas <christos@zoulas.com>
Date: Fri, 17 Jan 2020 17:12:58 +0000
Subject: [PATCH] PR/130: tobias: adjust seccomp for ioctl on hardwired
terminal
---
src/seccomp.c | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)
diff --git a/src/seccomp.c b/src/seccomp.c
index ebf3ea1cb..0ba17233b 100644
--- a/src/seccomp.c
+++ b/src/seccomp.c
@@ -186,8 +186,12 @@ enable_sandbox_full(void)
ALLOW_IOCTL_RULE(FIONREAD);
#endif
#ifdef TIOCGWINSZ
- // musl libc may call ioctl TIOCGWINSZ when calling stdout
+ // musl libc may call ioctl TIOCGWINSZ on stdout
ALLOW_IOCTL_RULE(TIOCGWINSZ);
+#endif
+#ifdef TCGETS
+ // glibc may call ioctl TCGETS on stdout on physical terminal
+ ALLOW_IOCTL_RULE(TCGETS);
#endif
ALLOW_RULE(lseek);
ALLOW_RULE(_llseek);