mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
core/linux-am33x: bump to -alarm4, turns on a few debugging features and a handful of other small changes
This commit is contained in:
parent
30dd25ac7a
commit
91bfded3b8
5 changed files with 303 additions and 73 deletions
|
@ -0,0 +1,73 @@
|
|||
From dd3f24640c209d8186010dbf2bbabe11f3eb52ce Mon Sep 17 00:00:00 2001
|
||||
From: Matt Porter <mporter@ti.com>
|
||||
Date: Mon, 21 Nov 2011 12:56:52 -0500
|
||||
Subject: [PATCH 2/3] beaglebone: hack in support for the WIP st7735fb driver
|
||||
|
||||
Signed-off-by: Matt Porter <mporter@ti.com>
|
||||
---
|
||||
arch/arm/mach-omap2/board-am335xevm.c | 28 ++++++++++++++++++++++++++++
|
||||
1 files changed, 28 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/arch/arm/mach-omap2/board-am335xevm.c b/arch/arm/mach-omap2/board-am335xevm.c
|
||||
index b27fb97..f049aad 100644
|
||||
--- arch.orig/arm/mach-omap2/board-am335xevm.c
|
||||
+++ arch/arm/mach-omap2/board-am335xevm.c
|
||||
@@ -51,6 +51,7 @@
|
||||
|
||||
/* LCD controller is similar to DA850 */
|
||||
#include <video/da8xx-fb.h>
|
||||
+#include <video/st7735fb.h>
|
||||
|
||||
#include "control.h"
|
||||
#include "board-flash.h"
|
||||
@@ -1094,6 +1095,23 @@ static struct spi_board_info am335x_spi1_slave_info[] = {
|
||||
},
|
||||
};
|
||||
|
||||
+static const struct st7735fb_platform_data bone_st7735fb_data = {
|
||||
+ .rst_gpio = GPIO_TO_PIN(3, 19),
|
||||
+ .dc_gpio = GPIO_TO_PIN(3, 21),
|
||||
+};
|
||||
+
|
||||
+static struct spi_board_info bone_spi1_slave_info[] = {
|
||||
+ {
|
||||
+ .modalias = "adafruit_tft18",
|
||||
+ .platform_data = &bone_st7735fb_data,
|
||||
+ .irq = -1,
|
||||
+ .max_speed_hz = 8000000,
|
||||
+ .bus_num = 2,
|
||||
+ .chip_select = 0,
|
||||
+ .mode = SPI_MODE_3,
|
||||
+ },
|
||||
+};
|
||||
+
|
||||
static void evm_nand_init(int evm_id, int profile)
|
||||
{
|
||||
setup_pin_mux(nand_pin_mux);
|
||||
@@ -1410,6 +1428,14 @@ static void spi1_init(int evm_id, int profile)
|
||||
return;
|
||||
}
|
||||
|
||||
+/* setup bone spi1 */
|
||||
+static void bone_spi1_init(int evm_id, int profile)
|
||||
+{
|
||||
+ setup_pin_mux(spi1_pin_mux);
|
||||
+ spi_register_board_info(bone_spi1_slave_info,
|
||||
+ ARRAY_SIZE(bone_spi1_slave_info));
|
||||
+ return;
|
||||
+}
|
||||
|
||||
static int beaglebone_phy_fixup(struct phy_device *phydev)
|
||||
{
|
||||
@@ -1567,6 +1593,8 @@ static struct evm_dev_cfg beaglebone_dev_cfg[] = {
|
||||
{i2c2_init, DEV_ON_BASEBOARD, PROFILE_NONE},
|
||||
{mmc0_init, DEV_ON_BASEBOARD, PROFILE_NONE},
|
||||
{boneleds_init, DEV_ON_BASEBOARD, PROFILE_ALL},
|
||||
+ /* HACK ALERT */
|
||||
+ {bone_spi1_init, DEV_ON_BASEBOARD, PROFILE_NONE},
|
||||
{NULL, 0, 0},
|
||||
};
|
||||
|
||||
--
|
||||
1.7.2.5
|
||||
|
|
@ -0,0 +1,97 @@
|
|||
From 9c2332f1376f5fb7c87f16dff77e9270eb7c91c8 Mon Sep 17 00:00:00 2001
|
||||
From: Matt Porter <mporter@ti.com>
|
||||
Date: Tue, 22 Nov 2011 10:48:32 -0500
|
||||
Subject: [PATCH 3/3] st7735fb: Make FB native endian on little endian platforms
|
||||
|
||||
This is a quick unoptimized implementation of a shadow swap buffer
|
||||
which is engaged on little endian platforms. It's not DMA safe
|
||||
at this point nor is it particularly optimized during updates.
|
||||
This is ok atm since the point is to be compatible with all the
|
||||
user space code out there that assumes that all FBdevs are native
|
||||
endian.
|
||||
|
||||
Now things like "cat foo.rgb565 > /dev/fb0" work as well as standard
|
||||
apps like fbv with no byte swapping mods.
|
||||
|
||||
Signed-off-by: Matt Porter <mporter@ti.com>
|
||||
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
|
||||
---
|
||||
drivers/video/st7735fb.c | 26 ++++++++++++++++++++------
|
||||
include/video/st7735fb.h | 1 +
|
||||
2 files changed, 21 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/drivers/video/st7735fb.c b/drivers/video/st7735fb.c
|
||||
index 500cc88..69ad3d0 100644
|
||||
--- drivers.old/video/st7735fb.c
|
||||
+++ drivers/video/st7735fb.c
|
||||
@@ -244,7 +244,14 @@ static void st7735fb_update_display(struct st7735fb_par *par)
|
||||
{
|
||||
int ret = 0;
|
||||
u8 *vmem = par->info->screen_base;
|
||||
+#ifdef __LITTLE_ENDIAN
|
||||
+ int i;
|
||||
+ u16 *vmem16 = (u16 *)vmem;
|
||||
+ u16 *ssbuf = par->ssbuf;
|
||||
|
||||
+ for (i=0; i<WIDTH*HEIGHT*BPP/8/2; i++)
|
||||
+ ssbuf[i] = swab16(vmem16[i]);
|
||||
+#endif
|
||||
/*
|
||||
TODO:
|
||||
Allow a subset of pages to be passed in
|
||||
@@ -261,7 +268,11 @@ static void st7735fb_update_display(struct st7735fb_par *par)
|
||||
st7735_write_cmd(par, ST7735_RAMWR);
|
||||
|
||||
/* Blast framebuffer to ST7735 internal display RAM */
|
||||
+#ifdef __LITTLE_ENDIAN
|
||||
+ ret = st7735_write_data_buf(par, (u8 *)ssbuf, WIDTH*HEIGHT*BPP/8);
|
||||
+#else
|
||||
ret = st7735_write_data_buf(par, vmem, WIDTH*HEIGHT*BPP/8);
|
||||
+#endif
|
||||
if (ret < 0)
|
||||
pr_err("%s: spi_write failed to update display buffer\n",
|
||||
par->info->fix.id);
|
||||
@@ -417,12 +428,7 @@ static int __devinit st7735fb_probe (struct spi_device *spi)
|
||||
info->var.blue.length = 5;
|
||||
info->var.transp.offset = 0;
|
||||
info->var.transp.length = 0;
|
||||
- info->flags = FBINFO_FLAG_DEFAULT |
|
||||
-#ifdef __LITTLE_ENDIAN
|
||||
- FBINFO_FOREIGN_ENDIAN |
|
||||
-#endif
|
||||
- FBINFO_VIRTFB;
|
||||
-
|
||||
+ info->flags = FBINFO_FLAG_DEFAULT | FBINFO_VIRTFB;
|
||||
info->fbdefio = &st7735fb_defio;
|
||||
fb_deferred_io_init(info);
|
||||
|
||||
@@ -432,6 +438,14 @@ static int __devinit st7735fb_probe (struct spi_device *spi)
|
||||
par->rst = pdata->rst_gpio;
|
||||
par->dc = pdata->dc_gpio;
|
||||
|
||||
+#ifdef __LITTLE_ENDIAN
|
||||
+ /* Allocate swapped shadow buffer */
|
||||
+ vmem = vzalloc(vmem_size);
|
||||
+ if (!vmem)
|
||||
+ return retval;
|
||||
+ par->ssbuf = vmem;
|
||||
+#endif
|
||||
+
|
||||
retval = register_framebuffer(info);
|
||||
if (retval < 0)
|
||||
goto fbreg_fail;
|
||||
diff --git a/include/video/st7735fb.h b/include/video/st7735fb.h
|
||||
index 250f036..52f5182 100644
|
||||
--- include.orig/video/st7735fb.h
|
||||
+++ include/video/st7735fb.h
|
||||
@@ -34,6 +34,7 @@ enum st7735_cmd {
|
||||
struct st7735fb_par {
|
||||
struct spi_device *spi;
|
||||
struct fb_info *info;
|
||||
+ u16 *ssbuf;
|
||||
int rst;
|
||||
int dc;
|
||||
};
|
||||
--
|
||||
1.7.2.5
|
||||
|
|
@ -12,7 +12,7 @@ pkgname=('linux-am33x' 'linux-headers-am33x')
|
|||
_kernelname=${pkgname#linux}
|
||||
_basekernel="am33x"
|
||||
pkgver=3.2
|
||||
pkgrel=alarm3
|
||||
pkgrel=alarm4
|
||||
arch=('armv7h')
|
||||
url="http://www.kernel.org/"
|
||||
license=('GPL2')
|
||||
|
@ -20,12 +20,9 @@ makedepends=('xmlto' 'docbook-xsl' 'uboot-mkimage' 'git')
|
|||
options=('!strip')
|
||||
source=( "config"
|
||||
"https://github.com/koenkooi/linux/zipball/beaglebone-3.2"
|
||||
"ARM-omap-am33x-BeagleBone-userspace-SPI-support.patch")
|
||||
md5sums=('aaa1ddae7405b431948942d5b67c3869'
|
||||
'82e2e714e34cfc6ddbfc628cdc7a4b1e'
|
||||
'18f543164ad6a73c87ee599b961c201d')
|
||||
|
||||
|
||||
"ARM-omap-am33x-BeagleBone-userspace-SPI-support.patch"
|
||||
"0002-beaglebone-hack-in-support-for-the-WIP-st7735fb-driv.patch"
|
||||
"0003-st7735fb-Make-FB-native-endian-on-little-endian-plat.patch")
|
||||
|
||||
build() {
|
||||
|
||||
|
@ -38,7 +35,10 @@ build() {
|
|||
cd $srcdir/linux
|
||||
|
||||
patch -Np0 -i "${srcdir}/ARM-omap-am33x-BeagleBone-userspace-SPI-support.patch"
|
||||
|
||||
|
||||
# these are crude patches that hack in support for an SPI framebuffer, probably conflicts with spidev and cape configuration so they're disabled.
|
||||
#patch -Np0 -i "${srcdir}/0002-beaglebone-hack-in-support-for-the-WIP-st7735fb-driv.patch"
|
||||
#patch -Np0 -i "${srcdir}/0003-st7735fb-Make-FB-native-endian-on-little-endian-plat.patch"
|
||||
make prepare
|
||||
|
||||
make ${MAKEFLAGS} uImage modules
|
||||
|
|
|
@ -3,6 +3,7 @@
|
|||
# Linux/arm 3.2.0 Kernel Configuration
|
||||
#
|
||||
CONFIG_ARM=y
|
||||
CONFIG_HAVE_PWM=y
|
||||
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
|
||||
CONFIG_HAVE_SCHED_CLOCK=y
|
||||
CONFIG_GENERIC_GPIO=y
|
||||
|
@ -27,6 +28,7 @@ CONFIG_ARM_PATCH_PHYS_VIRT=y
|
|||
CONFIG_GENERIC_BUG=y
|
||||
CONFIG_DEFCONFIG_LIST="/lib/modules/$UNAME_RELEASE/.config"
|
||||
CONFIG_HAVE_IRQ_WORK=y
|
||||
CONFIG_IRQ_WORK=y
|
||||
|
||||
#
|
||||
# General setup
|
||||
|
@ -35,7 +37,7 @@ CONFIG_EXPERIMENTAL=y
|
|||
CONFIG_BROKEN_ON_SMP=y
|
||||
CONFIG_INIT_ENV_ARG_LIMIT=32
|
||||
CONFIG_CROSS_COMPILE=""
|
||||
CONFIG_LOCALVERSION="-alarm3"
|
||||
CONFIG_LOCALVERSION="-alarm4"
|
||||
CONFIG_LOCALVERSION_AUTO=y
|
||||
CONFIG_HAVE_KERNEL_GZIP=y
|
||||
CONFIG_HAVE_KERNEL_LZMA=y
|
||||
|
@ -100,6 +102,7 @@ CONFIG_ANON_INODES=y
|
|||
CONFIG_UID16=y
|
||||
# CONFIG_SYSCTL_SYSCALL is not set
|
||||
CONFIG_KALLSYMS=y
|
||||
CONFIG_KALLSYMS_ALL=y
|
||||
CONFIG_HOTPLUG=y
|
||||
CONFIG_PRINTK=y
|
||||
CONFIG_BUG=y
|
||||
|
@ -119,8 +122,9 @@ CONFIG_PERF_USE_VMALLOC=y
|
|||
#
|
||||
# Kernel Performance Events And Counters
|
||||
#
|
||||
# CONFIG_PERF_EVENTS is not set
|
||||
CONFIG_PERF_EVENTS=y
|
||||
# CONFIG_PERF_COUNTERS is not set
|
||||
# CONFIG_DEBUG_PERF_USE_VMALLOC is not set
|
||||
CONFIG_VM_EVENT_COUNTERS=y
|
||||
CONFIG_COMPAT_BRK=y
|
||||
CONFIG_SLAB=y
|
||||
|
@ -134,6 +138,7 @@ CONFIG_HAVE_KRETPROBES=y
|
|||
CONFIG_HAVE_REGS_AND_STACK_ACCESS_API=y
|
||||
CONFIG_HAVE_CLK=y
|
||||
CONFIG_HAVE_DMA_API_DEBUG=y
|
||||
CONFIG_HAVE_HW_BREAKPOINT=y
|
||||
|
||||
#
|
||||
# GCOV-based kernel profiling
|
||||
|
@ -171,27 +176,27 @@ CONFIG_DEFAULT_IOSCHED="cfq"
|
|||
# CONFIG_INLINE_SPIN_LOCK_BH is not set
|
||||
# CONFIG_INLINE_SPIN_LOCK_IRQ is not set
|
||||
# CONFIG_INLINE_SPIN_LOCK_IRQSAVE is not set
|
||||
CONFIG_INLINE_SPIN_UNLOCK=y
|
||||
# CONFIG_INLINE_SPIN_UNLOCK is not set
|
||||
# CONFIG_INLINE_SPIN_UNLOCK_BH is not set
|
||||
CONFIG_INLINE_SPIN_UNLOCK_IRQ=y
|
||||
# CONFIG_INLINE_SPIN_UNLOCK_IRQ is not set
|
||||
# CONFIG_INLINE_SPIN_UNLOCK_IRQRESTORE is not set
|
||||
# CONFIG_INLINE_READ_TRYLOCK is not set
|
||||
# CONFIG_INLINE_READ_LOCK is not set
|
||||
# CONFIG_INLINE_READ_LOCK_BH is not set
|
||||
# CONFIG_INLINE_READ_LOCK_IRQ is not set
|
||||
# CONFIG_INLINE_READ_LOCK_IRQSAVE is not set
|
||||
CONFIG_INLINE_READ_UNLOCK=y
|
||||
# CONFIG_INLINE_READ_UNLOCK is not set
|
||||
# CONFIG_INLINE_READ_UNLOCK_BH is not set
|
||||
CONFIG_INLINE_READ_UNLOCK_IRQ=y
|
||||
# CONFIG_INLINE_READ_UNLOCK_IRQ is not set
|
||||
# CONFIG_INLINE_READ_UNLOCK_IRQRESTORE is not set
|
||||
# CONFIG_INLINE_WRITE_TRYLOCK is not set
|
||||
# CONFIG_INLINE_WRITE_LOCK is not set
|
||||
# CONFIG_INLINE_WRITE_LOCK_BH is not set
|
||||
# CONFIG_INLINE_WRITE_LOCK_IRQ is not set
|
||||
# CONFIG_INLINE_WRITE_LOCK_IRQSAVE is not set
|
||||
CONFIG_INLINE_WRITE_UNLOCK=y
|
||||
# CONFIG_INLINE_WRITE_UNLOCK is not set
|
||||
# CONFIG_INLINE_WRITE_UNLOCK_BH is not set
|
||||
CONFIG_INLINE_WRITE_UNLOCK_IRQ=y
|
||||
# CONFIG_INLINE_WRITE_UNLOCK_IRQ is not set
|
||||
# CONFIG_INLINE_WRITE_UNLOCK_IRQRESTORE is not set
|
||||
# CONFIG_MUTEX_SPIN_ON_OWNER is not set
|
||||
# CONFIG_FREEZER is not set
|
||||
|
@ -405,7 +410,7 @@ CONFIG_FLATMEM=y
|
|||
CONFIG_FLAT_NODE_MEM_MAP=y
|
||||
CONFIG_HAVE_MEMBLOCK=y
|
||||
CONFIG_PAGEFLAGS_EXTENDED=y
|
||||
CONFIG_SPLIT_PTLOCK_CPUS=4
|
||||
CONFIG_SPLIT_PTLOCK_CPUS=999999
|
||||
# CONFIG_COMPACTION is not set
|
||||
# CONFIG_PHYS_ADDR_T_64BIT is not set
|
||||
CONFIG_ZONE_DMA_FLAG=0
|
||||
|
@ -479,7 +484,8 @@ CONFIG_BINFMT_MISC=y
|
|||
# CONFIG_SUSPEND is not set
|
||||
CONFIG_PM_RUNTIME=y
|
||||
CONFIG_PM=y
|
||||
# CONFIG_PM_DEBUG is not set
|
||||
CONFIG_PM_DEBUG=y
|
||||
CONFIG_PM_ADVANCED_DEBUG=y
|
||||
# CONFIG_APM_EMULATION is not set
|
||||
CONFIG_ARCH_HAS_OPP=y
|
||||
CONFIG_PM_OPP=y
|
||||
|
@ -673,32 +679,7 @@ CONFIG_DNS_RESOLVER=y
|
|||
#
|
||||
# CONFIG_NET_PKTGEN is not set
|
||||
# CONFIG_HAMRADIO is not set
|
||||
CONFIG_CAN=y
|
||||
CONFIG_CAN_RAW=y
|
||||
CONFIG_CAN_BCM=y
|
||||
# CONFIG_CAN_GW is not set
|
||||
|
||||
#
|
||||
# CAN Device Drivers
|
||||
#
|
||||
# CONFIG_CAN_VCAN is not set
|
||||
# CONFIG_CAN_SLCAN is not set
|
||||
CONFIG_CAN_DEV=y
|
||||
CONFIG_CAN_CALC_BITTIMING=y
|
||||
# CONFIG_CAN_TI_HECC is not set
|
||||
# CONFIG_CAN_MCP251X is not set
|
||||
# CONFIG_CAN_SJA1000 is not set
|
||||
# CONFIG_CAN_C_CAN is not set
|
||||
CONFIG_CAN_D_CAN=y
|
||||
CONFIG_CAN_D_CAN_PLATFORM=y
|
||||
|
||||
#
|
||||
# CAN USB interfaces
|
||||
#
|
||||
# CONFIG_CAN_EMS_USB is not set
|
||||
# CONFIG_CAN_ESD_USB2 is not set
|
||||
# CONFIG_CAN_SOFTING is not set
|
||||
# CONFIG_CAN_DEBUG_DEVICES is not set
|
||||
# CONFIG_CAN is not set
|
||||
# CONFIG_IRDA is not set
|
||||
CONFIG_BT=m
|
||||
CONFIG_BT_L2CAP=y
|
||||
|
@ -740,15 +721,19 @@ CONFIG_WIRELESS_EXT_SYSFS=y
|
|||
# CFG80211 needs to be enabled for MAC80211
|
||||
#
|
||||
# CONFIG_WIMAX is not set
|
||||
CONFIG_RFKILL=y
|
||||
CONFIG_RFKILL_LEDS=y
|
||||
CONFIG_RFKILL_INPUT=y
|
||||
# CONFIG_RFKILL is not set
|
||||
# CONFIG_RFKILL_REGULATOR is not set
|
||||
# CONFIG_RFKILL_GPIO is not set
|
||||
# CONFIG_NET_9P is not set
|
||||
# CONFIG_CAIF is not set
|
||||
# CONFIG_CEPH_LIB is not set
|
||||
# CONFIG_NFC is not set
|
||||
CONFIG_NFC=m
|
||||
CONFIG_NFC_NCI=m
|
||||
|
||||
#
|
||||
# Near Field Communication (NFC) devices
|
||||
#
|
||||
CONFIG_PN544_NFC=m
|
||||
CONFIG_NFC_PN533=m
|
||||
|
||||
#
|
||||
# Device Drivers
|
||||
|
@ -765,6 +750,8 @@ CONFIG_PREVENT_FIRMWARE_BUILD=y
|
|||
CONFIG_FW_LOADER=y
|
||||
CONFIG_FIRMWARE_IN_KERNEL=y
|
||||
CONFIG_EXTRA_FIRMWARE=""
|
||||
# CONFIG_DEBUG_DRIVER is not set
|
||||
# CONFIG_DEBUG_DEVRES is not set
|
||||
# CONFIG_SYS_HYPERVISOR is not set
|
||||
CONFIG_REGMAP=y
|
||||
CONFIG_REGMAP_I2C=y
|
||||
|
@ -1109,7 +1096,6 @@ CONFIG_USB_NET_CDC_SUBSET=y
|
|||
# CONFIG_USB_NET_ZAURUS is not set
|
||||
# CONFIG_USB_NET_CX82310_ETH is not set
|
||||
# CONFIG_USB_NET_KALMIA is not set
|
||||
# CONFIG_USB_HSO is not set
|
||||
# CONFIG_USB_NET_INT51X1 is not set
|
||||
CONFIG_USB_IPHETH=m
|
||||
# CONFIG_USB_SIERRA_NET is not set
|
||||
|
@ -1232,6 +1218,7 @@ CONFIG_INPUT_MISC=y
|
|||
# CONFIG_INPUT_TWL6040_VIBRA is not set
|
||||
# CONFIG_INPUT_UINPUT is not set
|
||||
# CONFIG_INPUT_PCF8574 is not set
|
||||
# CONFIG_INPUT_PWM_BEEPER is not set
|
||||
# CONFIG_INPUT_GPIO_ROTARY_ENCODER is not set
|
||||
# CONFIG_INPUT_ADXL34X is not set
|
||||
# CONFIG_INPUT_CMA3000 is not set
|
||||
|
@ -1340,6 +1327,7 @@ CONFIG_I2C_OMAP=y
|
|||
# CONFIG_I2C_DEBUG_ALGO is not set
|
||||
# CONFIG_I2C_DEBUG_BUS is not set
|
||||
CONFIG_SPI=y
|
||||
CONFIG_SPI_DEBUG=y
|
||||
CONFIG_SPI_MASTER=y
|
||||
|
||||
#
|
||||
|
@ -1378,6 +1366,7 @@ CONFIG_SPI_SPIDEV=y
|
|||
#
|
||||
CONFIG_ARCH_REQUIRE_GPIOLIB=y
|
||||
CONFIG_GPIOLIB=y
|
||||
# CONFIG_DEBUG_GPIO is not set
|
||||
CONFIG_GPIO_SYSFS=y
|
||||
CONFIG_GPIO_GENERIC=y
|
||||
|
||||
|
@ -1416,8 +1405,32 @@ CONFIG_GPIO_GENERIC_PLATFORM=y
|
|||
#
|
||||
# MODULbus GPIO expanders:
|
||||
#
|
||||
# CONFIG_GENERIC_PWM is not set
|
||||
# CONFIG_W1 is not set
|
||||
CONFIG_GENERIC_PWM=m
|
||||
CONFIG_DAVINCI_EHRPWM=y
|
||||
CONFIG_ECAP_PWM=m
|
||||
CONFIG_W1=m
|
||||
|
||||
#
|
||||
# 1-wire Bus Masters
|
||||
#
|
||||
# CONFIG_W1_MASTER_DS2490 is not set
|
||||
# CONFIG_W1_MASTER_DS2482 is not set
|
||||
# CONFIG_W1_MASTER_DS1WM is not set
|
||||
CONFIG_W1_MASTER_GPIO=m
|
||||
# CONFIG_HDQ_MASTER_OMAP is not set
|
||||
|
||||
#
|
||||
# 1-wire Slaves
|
||||
#
|
||||
# CONFIG_W1_SLAVE_THERM is not set
|
||||
# CONFIG_W1_SLAVE_SMEM is not set
|
||||
# CONFIG_W1_SLAVE_DS2408 is not set
|
||||
# CONFIG_W1_SLAVE_DS2423 is not set
|
||||
# CONFIG_W1_SLAVE_DS2431 is not set
|
||||
# CONFIG_W1_SLAVE_DS2433 is not set
|
||||
# CONFIG_W1_SLAVE_DS2760 is not set
|
||||
# CONFIG_W1_SLAVE_DS2780 is not set
|
||||
# CONFIG_W1_SLAVE_BQ27000 is not set
|
||||
# CONFIG_POWER_SUPPLY is not set
|
||||
CONFIG_HWMON=y
|
||||
# CONFIG_HWMON_VID is not set
|
||||
|
@ -1621,7 +1634,7 @@ CONFIG_REGULATOR_FIXED_VOLTAGE=y
|
|||
CONFIG_DRM=m
|
||||
# CONFIG_VGASTATE is not set
|
||||
CONFIG_VIDEO_OUTPUT_CONTROL=m
|
||||
CONFIG_FB=y
|
||||
CONFIG_FB=m
|
||||
CONFIG_FIRMWARE_EDID=y
|
||||
# CONFIG_FB_DDC is not set
|
||||
# CONFIG_FB_BOOT_VESA_SUPPORT is not set
|
||||
|
@ -1629,14 +1642,14 @@ CONFIG_FB_CFB_FILLRECT=m
|
|||
CONFIG_FB_CFB_COPYAREA=m
|
||||
CONFIG_FB_CFB_IMAGEBLIT=m
|
||||
# CONFIG_FB_CFB_REV_PIXELS_IN_BYTE is not set
|
||||
CONFIG_FB_SYS_FILLRECT=y
|
||||
CONFIG_FB_SYS_COPYAREA=y
|
||||
CONFIG_FB_SYS_IMAGEBLIT=y
|
||||
CONFIG_FB_SYS_FILLRECT=m
|
||||
CONFIG_FB_SYS_COPYAREA=m
|
||||
CONFIG_FB_SYS_IMAGEBLIT=m
|
||||
CONFIG_FB_FOREIGN_ENDIAN=y
|
||||
CONFIG_FB_BOTH_ENDIAN=y
|
||||
# CONFIG_FB_BIG_ENDIAN is not set
|
||||
# CONFIG_FB_LITTLE_ENDIAN is not set
|
||||
CONFIG_FB_SYS_FOPS=y
|
||||
CONFIG_FB_SYS_FOPS=m
|
||||
# CONFIG_FB_WMT_GE_ROPS is not set
|
||||
CONFIG_FB_DEFERRED_IO=y
|
||||
# CONFIG_FB_SVGALIB is not set
|
||||
|
@ -1656,7 +1669,7 @@ CONFIG_FB_DA8XX_CONSISTENT_DMA_SIZE=4
|
|||
CONFIG_FB_VIRTUAL=m
|
||||
CONFIG_FB_METRONOME=m
|
||||
CONFIG_FB_BROADSHEET=m
|
||||
CONFIG_FB_ST7735=y
|
||||
CONFIG_FB_ST7735=m
|
||||
CONFIG_FB_OMAP_BOOTLOADER_INIT=y
|
||||
CONFIG_OMAP2_VRAM=y
|
||||
CONFIG_OMAP2_VRFB=y
|
||||
|
@ -1699,6 +1712,7 @@ CONFIG_LCD_PLATFORM=y
|
|||
# CONFIG_LCD_AMS369FG06 is not set
|
||||
CONFIG_BACKLIGHT_CLASS_DEVICE=y
|
||||
# CONFIG_BACKLIGHT_GENERIC is not set
|
||||
# CONFIG_BACKLIGHT_PWM is not set
|
||||
# CONFIG_BACKLIGHT_ADP8860 is not set
|
||||
# CONFIG_BACKLIGHT_ADP8870 is not set
|
||||
CONFIG_BACKLIGHT_TLC59108=y
|
||||
|
@ -1716,8 +1730,8 @@ CONFIG_DISPLAY_SUPPORT=y
|
|||
# Console display driver support
|
||||
#
|
||||
CONFIG_DUMMY_CONSOLE=y
|
||||
CONFIG_FRAMEBUFFER_CONSOLE=y
|
||||
# CONFIG_FRAMEBUFFER_CONSOLE_DETECT_PRIMARY is not set
|
||||
CONFIG_FRAMEBUFFER_CONSOLE=m
|
||||
CONFIG_FRAMEBUFFER_CONSOLE_DETECT_PRIMARY=y
|
||||
CONFIG_FRAMEBUFFER_CONSOLE_ROTATION=y
|
||||
CONFIG_FONTS=y
|
||||
CONFIG_FONT_8x8=y
|
||||
|
@ -1766,13 +1780,13 @@ CONFIG_SND_USB_AUDIO=y
|
|||
# CONFIG_SND_USB_6FIRE is not set
|
||||
CONFIG_SND_SOC=y
|
||||
# CONFIG_SND_SOC_CACHE_LZO is not set
|
||||
CONFIG_SND_AM33XX_SOC=y
|
||||
CONFIG_SND_DAVINCI_SOC_MCASP=y
|
||||
CONFIG_SND_AM335X_SOC_EVM=y
|
||||
CONFIG_SND_AM33XX_SOC=m
|
||||
CONFIG_SND_DAVINCI_SOC_MCASP=m
|
||||
CONFIG_SND_AM335X_SOC_EVM=m
|
||||
# CONFIG_SND_OMAP_SOC is not set
|
||||
CONFIG_SND_SOC_I2C_AND_SPI=y
|
||||
# CONFIG_SND_SOC_ALL_CODECS is not set
|
||||
CONFIG_SND_SOC_TLV320AIC3X=y
|
||||
CONFIG_SND_SOC_TLV320AIC3X=m
|
||||
# CONFIG_SOUND_PRIME is not set
|
||||
CONFIG_HID_SUPPORT=y
|
||||
CONFIG_HID=y
|
||||
|
@ -1782,7 +1796,7 @@ CONFIG_HID=y
|
|||
# USB Input Devices
|
||||
#
|
||||
CONFIG_USB_HID=y
|
||||
# CONFIG_HID_PID is not set
|
||||
CONFIG_HID_PID=y
|
||||
# CONFIG_USB_HIDDEV is not set
|
||||
|
||||
#
|
||||
|
@ -1801,7 +1815,7 @@ CONFIG_HID_CYPRESS=y
|
|||
# CONFIG_HID_ELECOM is not set
|
||||
CONFIG_HID_EZKEY=y
|
||||
# CONFIG_HID_HOLTEK is not set
|
||||
# CONFIG_HID_KEYTOUCH is not set
|
||||
CONFIG_HID_KEYTOUCH=m
|
||||
CONFIG_HID_KYE=y
|
||||
# CONFIG_HID_UCLOGIC is not set
|
||||
# CONFIG_HID_WALTOP is not set
|
||||
|
@ -1823,7 +1837,11 @@ CONFIG_HID_MONTEREY=y
|
|||
# CONFIG_HID_ORTEK is not set
|
||||
# CONFIG_HID_PANTHERLORD is not set
|
||||
# CONFIG_HID_PETALYNX is not set
|
||||
# CONFIG_HID_PICOLCD is not set
|
||||
CONFIG_HID_PICOLCD=m
|
||||
CONFIG_HID_PICOLCD_FB=y
|
||||
CONFIG_HID_PICOLCD_BACKLIGHT=y
|
||||
CONFIG_HID_PICOLCD_LCD=y
|
||||
CONFIG_HID_PICOLCD_LEDS=y
|
||||
# CONFIG_HID_PRIMAX is not set
|
||||
# CONFIG_HID_QUANTA is not set
|
||||
# CONFIG_HID_ROCCAT is not set
|
||||
|
@ -1968,6 +1986,7 @@ CONFIG_USB_STORAGE=y
|
|||
# CONFIG_USB_ISIGHTFW is not set
|
||||
# CONFIG_USB_YUREX is not set
|
||||
CONFIG_USB_GADGET=y
|
||||
# CONFIG_USB_GADGET_DEBUG is not set
|
||||
# CONFIG_USB_GADGET_DEBUG_FILES is not set
|
||||
# CONFIG_USB_GADGET_DEBUG_FS is not set
|
||||
CONFIG_USB_GADGET_VBUS_DRAW=2
|
||||
|
@ -2051,7 +2070,8 @@ CONFIG_LEDS_GPIO=y
|
|||
# CONFIG_LEDS_LP5523 is not set
|
||||
# CONFIG_LEDS_PCA955X is not set
|
||||
# CONFIG_LEDS_DAC124S085 is not set
|
||||
CONFIG_LEDS_REGULATOR=y
|
||||
# CONFIG_LEDS_PWM is not set
|
||||
# CONFIG_LEDS_REGULATOR is not set
|
||||
# CONFIG_LEDS_BD2802 is not set
|
||||
# CONFIG_LEDS_LT3593 is not set
|
||||
# CONFIG_LEDS_RENESAS_TPU is not set
|
||||
|
@ -2072,9 +2092,8 @@ CONFIG_LEDS_TRIGGER_DEFAULT_ON=y
|
|||
# CONFIG_ACCESSIBILITY is not set
|
||||
CONFIG_RTC_LIB=y
|
||||
CONFIG_RTC_CLASS=y
|
||||
CONFIG_RTC_HCTOSYS=y
|
||||
CONFIG_RTC_HCTOSYS_DEVICE="rtc0"
|
||||
# CONFIG_RTC_DEBUG is not set
|
||||
# CONFIG_RTC_HCTOSYS is not set
|
||||
CONFIG_RTC_DEBUG=y
|
||||
|
||||
#
|
||||
# RTC interfaces
|
||||
|
@ -2386,14 +2405,53 @@ CONFIG_FRAME_WARN=1024
|
|||
CONFIG_DEBUG_FS=y
|
||||
# CONFIG_HEADERS_CHECK is not set
|
||||
CONFIG_DEBUG_SECTION_MISMATCH=y
|
||||
# CONFIG_DEBUG_KERNEL is not set
|
||||
CONFIG_DEBUG_KERNEL=y
|
||||
# CONFIG_DEBUG_SHIRQ is not set
|
||||
# CONFIG_LOCKUP_DETECTOR is not set
|
||||
# CONFIG_HARDLOCKUP_DETECTOR is not set
|
||||
# CONFIG_DETECT_HUNG_TASK is not set
|
||||
CONFIG_SCHED_DEBUG=y
|
||||
# CONFIG_SCHEDSTATS is not set
|
||||
CONFIG_TIMER_STATS=y
|
||||
# CONFIG_DEBUG_OBJECTS is not set
|
||||
# CONFIG_DEBUG_SLAB is not set
|
||||
# CONFIG_DEBUG_KMEMLEAK is not set
|
||||
# CONFIG_DEBUG_RT_MUTEXES is not set
|
||||
# CONFIG_RT_MUTEX_TESTER is not set
|
||||
CONFIG_DEBUG_SPINLOCK=y
|
||||
CONFIG_DEBUG_MUTEXES=y
|
||||
CONFIG_DEBUG_LOCK_ALLOC=y
|
||||
# CONFIG_PROVE_LOCKING is not set
|
||||
# CONFIG_SPARSE_RCU_POINTER is not set
|
||||
CONFIG_LOCKDEP=y
|
||||
CONFIG_LOCK_STAT=y
|
||||
# CONFIG_DEBUG_LOCKDEP is not set
|
||||
# CONFIG_DEBUG_ATOMIC_SLEEP is not set
|
||||
# CONFIG_DEBUG_LOCKING_API_SELFTESTS is not set
|
||||
CONFIG_STACKTRACE=y
|
||||
# CONFIG_DEBUG_STACK_USAGE is not set
|
||||
# CONFIG_DEBUG_KOBJECT is not set
|
||||
CONFIG_DEBUG_BUGVERBOSE=y
|
||||
# CONFIG_DEBUG_INFO is not set
|
||||
# CONFIG_DEBUG_VM is not set
|
||||
# CONFIG_DEBUG_WRITECOUNT is not set
|
||||
CONFIG_DEBUG_MEMORY_INIT=y
|
||||
# CONFIG_DEBUG_LIST is not set
|
||||
# CONFIG_TEST_LIST_SORT is not set
|
||||
# CONFIG_DEBUG_SG is not set
|
||||
# CONFIG_DEBUG_NOTIFIERS is not set
|
||||
# CONFIG_DEBUG_CREDENTIALS is not set
|
||||
CONFIG_FRAME_POINTER=y
|
||||
# CONFIG_BOOT_PRINTK_DELAY is not set
|
||||
# CONFIG_RCU_TORTURE_TEST is not set
|
||||
# CONFIG_BACKTRACE_SELF_TEST is not set
|
||||
# CONFIG_DEBUG_BLOCK_EXT_DEVT is not set
|
||||
# CONFIG_DEBUG_FORCE_WEAK_PER_CPU is not set
|
||||
# CONFIG_LKDTM is not set
|
||||
# CONFIG_FAULT_INJECTION is not set
|
||||
# CONFIG_LATENCYTOP is not set
|
||||
# CONFIG_SYSCTL_SYSCALL_CHECK is not set
|
||||
# CONFIG_DEBUG_PAGEALLOC is not set
|
||||
CONFIG_HAVE_FUNCTION_TRACER=y
|
||||
CONFIG_HAVE_FUNCTION_GRAPH_TRACER=y
|
||||
CONFIG_HAVE_DYNAMIC_FTRACE=y
|
||||
|
@ -2408,10 +2466,12 @@ CONFIG_TRACING_SUPPORT=y
|
|||
# CONFIG_ATOMIC64_SELFTEST is not set
|
||||
# CONFIG_SAMPLES is not set
|
||||
CONFIG_HAVE_ARCH_KGDB=y
|
||||
# CONFIG_KGDB is not set
|
||||
# CONFIG_TEST_KSTRTOX is not set
|
||||
# CONFIG_STRICT_DEVMEM is not set
|
||||
# CONFIG_ARM_UNWIND is not set
|
||||
# CONFIG_DEBUG_USER is not set
|
||||
# CONFIG_DEBUG_LL is not set
|
||||
CONFIG_DEBUG_JTAG_ENABLE=y
|
||||
|
||||
#
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
# arg 2: the old package version
|
||||
|
||||
KERNEL_NAME=-am33x
|
||||
KERNEL_VERSION=3.2.0alarm3
|
||||
KERNEL_VERSION=3.2.0-alarm4
|
||||
|
||||
post_install () {
|
||||
# updating module dependencies
|
||||
|
|
Loading…
Reference in a new issue