mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
community/texstudio to 2.12.2-1
This commit is contained in:
parent
c85c802112
commit
91da858652
2 changed files with 2 additions and 25 deletions
|
@ -5,8 +5,8 @@
|
|||
# - ARM patch, use NO_CRASH_HANDLER=1 for AArch64
|
||||
|
||||
pkgname=texstudio
|
||||
pkgver=2.12.0
|
||||
pkgrel=2
|
||||
pkgver=2.12.2
|
||||
pkgrel=1
|
||||
pkgdesc="Integrated writing environment for creating LaTeX documents"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://texstudio.sourceforge.net/"
|
||||
|
@ -17,15 +17,12 @@ optdepends=('evince: pdf reader'
|
|||
'okular: alternate pdf reader')
|
||||
replaces=('texmakerx')
|
||||
source=("hg+http://hg.code.sf.net/p/texstudio/hg#tag=${pkgver}"
|
||||
"fs52529.patch"
|
||||
texstudio-debughelper-arm-fix.patch)
|
||||
sha512sums=('SKIP'
|
||||
'562f49ddab6e39ac0a05dd67a2eb14e6ce47af44cfbc7b850edb6e4189b8c2ddebb6c4c118b4e8faeb0b49c3180d8cc24f5eb45b421f6acac996fd332a58f8d7'
|
||||
'dcb5ce7cd3e83fc221903fa895e6c428c54ada7468e74bb0a3e6bfac01c9e9575e4780d300b67f44064f2d25e10dd1aef531b847cdee71fbfbe7337808a0c8f4')
|
||||
|
||||
prepare() {
|
||||
cd hg
|
||||
patch -Np1 < "$srcdir"/fs52529.patch
|
||||
patch -p1 -i ../texstudio-debughelper-arm-fix.patch
|
||||
}
|
||||
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
# HG changeset patch
|
||||
# User jsundermeyer@sf.net <jsundermeyer@sf.net>
|
||||
# Date 1484825587 -3600
|
||||
# Thu Jan 19 12:33:07 2017 +0100
|
||||
# Node ID 77c705b374b17a1d238edf89495a061442323776
|
||||
# Parent 89b651aae5cf74f66dc3a183679706841b9bc994
|
||||
fix command detection
|
||||
|
||||
diff -r 89b651aae5cf -r 77c705b374b1 buildmanager.cpp
|
||||
--- a/buildmanager.cpp Sat Jan 14 18:37:44 2017 +0100
|
||||
+++ b/buildmanager.cpp Thu Jan 19 12:33:07 2017 +0100
|
||||
@@ -592,7 +592,7 @@
|
||||
|
||||
QString addPathDelimeter(const QString &a)
|
||||
{
|
||||
- return ((a.endsWith("/") || a.endsWith("\\")) ? a : (a + "\\"));
|
||||
+ return ((a.endsWith("/") || a.endsWith("\\")) ? a : (a + QDir::separator()));
|
||||
}
|
||||
|
||||
QString BuildManager::findFileInPath(QString fileName)
|
Loading…
Reference in a new issue