From 92064671d09066d01fe85d0bcca73fc8e90e328c Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 12 Sep 2020 19:19:07 +0000
Subject: [PATCH] extra/qt5-webengine to 5.15.1-1

---
 extra/qt5-webengine/PKGBUILD                  | 36 +--------
 extra/qt5-webengine/qt5-webengine-gcc10.patch | 12 ---
 .../qt5-webengine-pipewire.patch              | 76 -------------------
 3 files changed, 3 insertions(+), 121 deletions(-)
 delete mode 100644 extra/qt5-webengine/qt5-webengine-gcc10.patch
 delete mode 100644 extra/qt5-webengine/qt5-webengine-pipewire.patch

diff --git a/extra/qt5-webengine/PKGBUILD b/extra/qt5-webengine/PKGBUILD
index 38225e796..b6da638f1 100644
--- a/extra/qt5-webengine/PKGBUILD
+++ b/extra/qt5-webengine/PKGBUILD
@@ -9,9 +9,9 @@ buildarch=12
 highmem=1
 
 pkgname=qt5-webengine
-_qtver=5.15.0
+_qtver=5.15.1
 pkgver=${_qtver/-/}
-pkgrel=5
+pkgrel=1
 arch=('x86_64')
 url='https://www.qt.io'
 license=('LGPL3' 'LGPL2.1' 'BSD')
@@ -23,45 +23,15 @@ optdepends=('libpipewire02: WebRTC desktop sharing under Wayland')
 groups=('qt' 'qt5')
 _pkgfqn="${pkgname/5-/}-everywhere-src-${_qtver}"
 source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
-        qt5-webengine-icu67.patch::"https://code.qt.io/cgit/qt/qtwebengine-chromium.git/patch/?id=e941f2bd"
-        qt5-webengine-gcc10.patch
-        dark-mode-crash.patch::"https://code.qt.io/cgit/qt/qtwebengine-chromium.git/patch/?id=4e8ca195"
-        qtbug-85119.patch::"https://code.qt.io/cgit/qt/qtwebengine-chromium.git/patch/?id=c91f4d20"
-        qtbug-85120.patch::"https://code.qt.io/cgit/qt/qtwebengine-chromium.git/patch/?id=242802ab"
-        qtbug-85118.patch::"https://code.qt.io/cgit/qt/qtwebengine.git/patch/?id=e42ccdad"
-        qtbug-62957.patch::"https://code.qt.io/cgit/qt/qtwebengine.git/patch/?id=f341988f"
-        qtbug-62957-pre.patch::"https://code.qt.io/cgit/qt/qtwebengine.git/patch?id=75412200"
-        qt5-webengine-pipewire.patch
         0001-ARM-toolchain-fixes.patch
         0002-Fix-ARM-skia-ICE.patch)
-sha256sums=('c38e2fda7ed1b7d5a90f26abf231ec0715d78a5bc39a94673d8e39d75f04c5df'
-            '22a2265c81bc73dba6843279407ccaec9f192d0987c54a0d9533be7c49b37f29'
-            '8a6e0c41f708d6a8f1febb751157642ab985b58c07ada1447b73b71cd31b4d99'
-            '7ea054a95045635fcee9ee50a6a28e9aedf182ca97a76cc6dd680fb1a91748e1'
-            '758561a5bd52feca16751c37def8e7cd3388073bf5bd072eb0862830c174decc'
-            '4bb12a72d40e69052946a6b66fff621f28e40c3d3c11ddeec155133a9204f352'
-            'fc976a6a7198121a4c1b6026318098de278412d73634db31b1815a3cc7502657'
-            '1a07ab59daa9552ad1a70abd03b00d40e542d9dd64fa6d7404d31c9a51e5eeba'
-            'd47ec2111c9713312158f800c01ca9358400b4e11273e470d57a53c36b7565c0'
-            '34cd6fdcdf7d20f9a32d4ad066535edad61735a83a895e9503edab247fee5542'
+sha256sums=('f903e98fe3cd717161252710125fce011cf882ced96c24968b0c38811fbefdf2'
             '6cd3f4877e239c83df5ede59c74db2b2e84b4adce66ef83d30b3b4a3f04677e8'
             'f389de929c6d27217a1c7e3e7118b06e4d15e17123c96ace2c7a791ecad6bcc7')
 
 prepare() {
   mkdir -p build
 
-  cd $_pkgfqn
-  patch -d src/3rdparty -p1 -i "$srcdir"/qt5-webengine-icu67.patch # Fix build with ICU 67
-  patch -d src/3rdparty -p1 -i "$srcdir"/qt5-webengine-gcc10.patch
-  patch -d src/3rdparty -p1 -i "$srcdir"/dark-mode-crash.patch # Fix crash in qutebrowser when using dark mode
-  patch -d src/3rdparty -p1 -i "$srcdir"/qtbug-85119.patch # Extend url library for WebEngine custom schemes
-  patch -d src/3rdparty -p1 -i "$srcdir"/qtbug-85120.patch # Make XScrnSaver optional
-
-  patch -p1 -i ../qtbug-85118.patch # Fix recentlyAudible signal
-  patch -p1 -i ../qtbug-62957-pre.patch # Avoid the network context reset during http cache clear
-  patch -p1 -i ../qtbug-62957.patch # Return valid path in Profile::GetPath() for incognito profiles
-  patch -p1 -i ../qt5-webengine-pipewire.patch # Add screen sharing support on wayland via pipewire
-
   cd "$srcdir/$_pkgfqn/src/3rdparty"
   patch -p1 -i ${srcdir}/0001-ARM-toolchain-fixes.patch
   patch -p1 -i ${srcdir}/0002-Fix-ARM-skia-ICE.patch
diff --git a/extra/qt5-webengine/qt5-webengine-gcc10.patch b/extra/qt5-webengine/qt5-webengine-gcc10.patch
deleted file mode 100644
index 6c10e5385..000000000
--- a/extra/qt5-webengine/qt5-webengine-gcc10.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/base/trace_event/trace_event_memory_overhead.h b/base/trace_event/trace_event_memory_overhead.h
-index 69468d4..3f5b786 100644
---- a/chromium/base/trace_event/trace_event_memory_overhead.h
-+++ b/chromium/base/trace_event/trace_event_memory_overhead.h
-@@ -9,6 +9,7 @@
- #include <stdint.h>
- 
- #include <unordered_map>
-+#include <string>
- 
- #include "base/base_export.h"
- #include "base/macros.h"
diff --git a/extra/qt5-webengine/qt5-webengine-pipewire.patch b/extra/qt5-webengine/qt5-webengine-pipewire.patch
deleted file mode 100644
index 5af522dcf..000000000
--- a/extra/qt5-webengine/qt5-webengine-pipewire.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-From e5b5fcb1a2c186f14ae35f4c48f593e6fa75dd87 Mon Sep 17 00:00:00 2001
-From: Allan Sandfeld Jensen <allan.jensen@qt.io>
-Date: Mon, 29 Jun 2020 17:04:53 +0200
-Subject: Add pipewire detection and support
-
-Used for screensharing on wayland
-
-Fixes: QTBUG-85309
-Change-Id: I7ec61611bb9e3f318a6a5bd3a43212f391766628
-Reviewed-by: Kirill Burtsev <kirill.burtsev@qt.io>
----
- src/buildtools/config/linux.pri |  2 ++
- src/core/configure.json   | 15 +++++++++++++++
- 2 files changed, 17 insertions(+)
-
-diff --git a/src/buildtools/config/linux.pri b/src/buildtools/config/linux.pri
-index e98524002..26d0dcf7d 100644
---- a/src/buildtools/config/linux.pri
-+++ b/src/buildtools/config/linux.pri
-@@ -29,6 +29,8 @@ qtConfig(webengine-embedded-build) {
-         qtConfig(webengine-webrtc): gn_args += rtc_use_x11=true
-     }
- 
-+    qtConfig(webengine-webrtc): qtConfig(webengine-webrtc-pipewire): gn_args += rtc_use_pipewire=true
-+
-     qtConfig(webengine-system-libevent): gn_args += use_system_libevent=true
-     qtConfig(webengine-system-libwebp):  gn_args += use_system_libwebp=true
-     qtConfig(webengine-system-libxml2):  gn_args += use_system_libxml=true use_system_libxslt=true
-diff --git a/src/core/configure.json b/src/core/configure.json
-index 1a2162723..7ba4a94c7 100644
---- a/src/core/configure.json
-+++ b/src/core/configure.json
-@@ -25,6 +25,7 @@
-             "webengine-native-spellchecker": "boolean",
-             "webengine-extensions": "boolean",
-             "webengine-webrtc": "boolean",
-+            "webengine-webrtc-pipewire": "boolean",
-             "webengine-geolocation": "boolean",
-             "webengine-webchannel": "boolean",
-             "webengine-kerberos": "boolean",
-@@ -67,6 +68,12 @@
-             "sources": [
-                 { "type": "pkgConfig", "args": "libpulse >= 0.9.10 libpulse-mainloop-glib" }
-             ]
-+        },
-+        "webengine-gio": {
-+            "label": "gio",
-+            "sources": [
-+                { "type": "pkgConfig", "args": "gio-2.0" }
-+            ]
-         }
-     },
-     "tests" : {
-@@ -183,6 +190,13 @@
-             "autoDetect": "!features.webengine-embedded-build",
-             "output": [ "privateFeature" ]
-         },
-+        "webengine-webrtc-pipewire": {
-+            "label": "PipeWire over GIO",
-+            "purpose": "Provides PipeWire support in WebRTC using GIO.",
-+            "condition": "features.webengine-webrtc && libs.webengine-gio",
-+            "autoDetect": "false",
-+            "output": [ "privateFeature" ]
-+        },
-         "webengine-ozone-x11" : {
-              "label": "Support qpa-xcb",
-              "condition": "features.webengine-ozone-x11",
-@@ -252,6 +266,7 @@
-                 "webengine-spellchecker",
-                 "webengine-native-spellchecker",
-                 "webengine-webrtc",
-+                "webengine-webrtc-pipewire",
-                 "webengine-geolocation",
-                 "webengine-webchannel",
-                 "webengine-kerberos",
---