mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/mysql-workbench to 8.0.40-5
This commit is contained in:
parent
c1f4f58df5
commit
92128e33de
3 changed files with 53 additions and 2 deletions
extra/mysql-workbench
|
@ -1,7 +1,7 @@
|
|||
pkgbase = mysql-workbench
|
||||
pkgdesc = A cross-platform, visual database design tool developed by MySQL
|
||||
pkgver = 8.0.40
|
||||
pkgrel = 4
|
||||
pkgrel = 5
|
||||
url = https://www.mysql.com/products/workbench/
|
||||
arch = x86_64
|
||||
license = GPL2
|
||||
|
@ -102,6 +102,7 @@ pkgbase = mysql-workbench
|
|||
source = https://downloads.sourceforge.net/project/boost/boost/1.77.0/boost_1_77_0.tar.bz2
|
||||
source = 0001-mysql-workbench-no-check-for-updates.patch
|
||||
source = 0002-disable-unsupported-operating-system-warning.patch
|
||||
source = 0003-swig-4-3.patch
|
||||
source = arch_linux_profile.xml
|
||||
validpgpkeys = BCA43417C3B485DD128EC6D4B7B3B788A8D3785C
|
||||
sha256sums = fc2ae31e067720516f501d48c5e51199ef19e81a19c746f4dcc5a4f1009ed128
|
||||
|
@ -113,6 +114,7 @@ pkgbase = mysql-workbench
|
|||
sha256sums = fc9f85fc030e233142908241af7a846e60630aa7388de9a5fafb1f3a26840854
|
||||
sha256sums = cdf687f23bc6e8d52dbee9fa02b23d755e80f88476f0fc2e7c4c71cdfed3792f
|
||||
sha256sums = 2d0f6dcf38f22e49ef7ab9de0230484f1ffac41b7ac40feaf5ef4538ae2f7a18
|
||||
sha256sums = fb0732919a15dc0b16f5ca104cac7be3edd92dc997fed879c23cd933a1f43367
|
||||
sha256sums = d816164098c90c432b4fe590708c14f95ab137abfe16ad1b7d498b2e83c0e265
|
||||
|
||||
pkgname = mysql-workbench
|
||||
|
|
44
extra/mysql-workbench/0003-swig-4-3.patch
Normal file
44
extra/mysql-workbench/0003-swig-4-3.patch
Normal file
|
@ -0,0 +1,44 @@
|
|||
diff --git a/library/forms/swig/cairo.i b/library/forms/swig/cairo.i
|
||||
index a02efdcd1..d9091fca0 100644
|
||||
--- a/library/forms/swig/cairo.i
|
||||
+++ b/library/forms/swig/cairo.i
|
||||
@@ -125,7 +125,7 @@
|
||||
|
||||
%typemap(argout) cairo_text_extents_t *extents {
|
||||
PyObject *o= SWIG_NewPointerObj(new cairo_text_extents_t(*$1), SWIGTYPE_p_cairo_text_extents_t, 0 | 0 );
|
||||
- $result= SWIG_Python_AppendOutput($result, o);
|
||||
+ $result= SWIG_Python_AppendOutput($result, o, 0);
|
||||
}
|
||||
|
||||
%typemap(in) const char* (std::string s) {
|
||||
diff --git a/library/forms/swig/mforms.i b/library/forms/swig/mforms.i
|
||||
index ac4c6e36a..e46459966 100644
|
||||
--- a/library/forms/swig/mforms.i
|
||||
+++ b/library/forms/swig/mforms.i
|
||||
@@ -722,7 +722,7 @@ inline boost::function<void (mforms::TextEntryAction)> pycall_void_entryaction_f
|
||||
|
||||
%typemap(argout) std::string &ret_password {
|
||||
PyObject *o= PyUnicode_DecodeUTF8(($1)->data(), ($1)->size(), NULL);
|
||||
- $result= SWIG_Python_AppendOutput($result, o);
|
||||
+ $result= SWIG_Python_AppendOutput($result, o, 0);
|
||||
}
|
||||
|
||||
%typemap(in,numinputs=0) std::string &ret_password(std::string temp) {
|
||||
@@ -731,7 +731,7 @@ inline boost::function<void (mforms::TextEntryAction)> pycall_void_entryaction_f
|
||||
|
||||
%typemap(argout) std::string &ret_value {
|
||||
PyObject *o= PyUnicode_DecodeUTF8(($1)->data(), ($1)->size(), NULL);
|
||||
- $result= SWIG_Python_AppendOutput($result, o);
|
||||
+ $result= SWIG_Python_AppendOutput($result, o, 0);
|
||||
}
|
||||
|
||||
%typemap(in,numinputs=0) std::string &ret_value(std::string temp) {
|
||||
@@ -741,7 +741,7 @@ inline boost::function<void (mforms::TextEntryAction)> pycall_void_entryaction_f
|
||||
|
||||
%typemap(argout) bool &ret_store {
|
||||
if (*$1) Py_INCREF(Py_True); else Py_INCREF(Py_False);
|
||||
- $result= SWIG_Python_AppendOutput($result, *$1 ? Py_True : Py_False);
|
||||
+ $result= SWIG_Python_AppendOutput($result, *$1 ? Py_True : Py_False, 0);
|
||||
}
|
||||
|
||||
%typemap(in,numinputs=0) bool &ret_store(bool temp) {
|
|
@ -12,7 +12,7 @@ buildarch=8
|
|||
|
||||
pkgname=mysql-workbench
|
||||
pkgver=8.0.40
|
||||
pkgrel=4
|
||||
pkgrel=5
|
||||
_mysql_version=8.4.3
|
||||
_connector_version=8.4.0
|
||||
_boost_version=1.77.0
|
||||
|
@ -74,6 +74,7 @@ source=("https://cdn.mysql.com/Downloads/MySQLGUITools/mysql-workbench-community
|
|||
"https://downloads.sourceforge.net/project/boost/boost/${_boost_version}/boost_${_boost_version//./_}.tar.bz2"
|
||||
'0001-mysql-workbench-no-check-for-updates.patch'
|
||||
'0002-disable-unsupported-operating-system-warning.patch'
|
||||
'0003-swig-4-3.patch'
|
||||
'arch_linux_profile.xml')
|
||||
sha256sums=('fc2ae31e067720516f501d48c5e51199ef19e81a19c746f4dcc5a4f1009ed128'
|
||||
'SKIP'
|
||||
|
@ -84,6 +85,7 @@ sha256sums=('fc2ae31e067720516f501d48c5e51199ef19e81a19c746f4dcc5a4f1009ed128'
|
|||
'fc9f85fc030e233142908241af7a846e60630aa7388de9a5fafb1f3a26840854'
|
||||
'cdf687f23bc6e8d52dbee9fa02b23d755e80f88476f0fc2e7c4c71cdfed3792f'
|
||||
'2d0f6dcf38f22e49ef7ab9de0230484f1ffac41b7ac40feaf5ef4538ae2f7a18'
|
||||
'fb0732919a15dc0b16f5ca104cac7be3edd92dc997fed879c23cd933a1f43367'
|
||||
'd816164098c90c432b4fe590708c14f95ab137abfe16ad1b7d498b2e83c0e265')
|
||||
|
||||
prepare() {
|
||||
|
@ -96,6 +98,9 @@ prepare() {
|
|||
# disable unsupported operating system warning
|
||||
patch -Np1 < "${srcdir}"/0002-disable-unsupported-operating-system-warning.patch
|
||||
|
||||
# fix build with swig 4.3.x - function SWIG_Python_AppendOutput has a 3rd parameter now
|
||||
patch -Np1 < "${srcdir}"/0003-swig-4-3.patch
|
||||
|
||||
# remove '-Werror'
|
||||
sed -i '/^\s*set/s| -Werror||' CMakeLists.txt
|
||||
|
||||
|
|
Loading…
Reference in a new issue