community/js185 to 1.0.0-5

This commit is contained in:
Kevin Mihelich 2019-01-01 15:16:12 +00:00
parent 17f7cdc4d4
commit 9216793a4d
4 changed files with 20 additions and 26 deletions

View file

@ -1,4 +1,3 @@
# $Id$
# Maintainer: Bruno Pagani <archange@archlinux.org> # Maintainer: Bruno Pagani <archange@archlinux.org>
# Contributor: Ionut Biru <ibiru@archlinux.org> # Contributor: Ionut Biru <ibiru@archlinux.org>
@ -9,7 +8,7 @@
pkgname=js185 pkgname=js185
pkgver=1.0.0 pkgver=1.0.0
pkgrel=4 pkgrel=5
pkgdesc="JavaScript interpreter and libraries (legacy)" pkgdesc="JavaScript interpreter and libraries (legacy)"
arch=(x86_64) arch=(x86_64)
url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey/Releases/1.8.5" url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey/Releases/1.8.5"
@ -17,25 +16,16 @@ license=(MPL)
depends=(nspr libffi) depends=(nspr libffi)
makedepends=(python2 zip) makedepends=(python2 zip)
source=("https://ftp.mozilla.org/pub/mozilla.org/js/${pkgname}-${pkgver}.tar.gz" source=("https://ftp.mozilla.org/pub/mozilla.org/js/${pkgname}-${pkgver}.tar.gz"
'fix-811665.patch' 'fix-gcc6.patch'
'destdir.patch' 'fix-install-symlinks.patch'
'autoconf.patch' 'system-libffi-autoconf.patch'
'allow-to-build-against-system-libffi.patch' 'allow-to-build-against-system-libffi.patch'
ihatemozilla.patch no-neon.patch ihatemozilla.patch no-neon.patch
Bug-638056-Avoid-The-cacheFlush-support-is-missing-o.patch Bug-638056-Avoid-The-cacheFlush-support-is-missing-o.patch
mozjs185-tag.patch) mozjs185-tag.patch)
md5sums=('a4574365938222adca0a6bd33329cb32'
'f810f575c855e136fe32302c1167344f'
'27d40e50d8dd25f30e1b71a1902fb7fc'
'2bcd0cc9b7eb268de31410bfd97c1282'
'd2b063b75f30fb4b9a2b1e8958cbeec4'
'9add35f52965e4643b9235307d0d6cc5'
'5d4817fadff71765c9b5d1f7b90f904f'
'31d3273a985b88938e229ded36271286'
'a6a40ac37ab66291c68ceeacc6e73a01')
sha256sums=('5d12f7e1f5b4a99436685d97b9b7b75f094d33580227aa998c406bbae6f2a687' sha256sums=('5d12f7e1f5b4a99436685d97b9b7b75f094d33580227aa998c406bbae6f2a687'
'2b298b8a693865b38e2b0d33277bb5ffe152c6ecf43648e85113fec586aa4752' '7d252ea688f3011360c3a370820e1a00c85ae785cdad37c6655d0d5ef996fb76'
'1319d729f382703b3a315c7a1bcc2dc14ed52f1111a194d3531a3503f0d0735e' 'b738dc60b6f9c4697aede30ca09a87ac0d5895fe5da6c9f277295531cbe8c215'
'524e11a66f0931dc1affcfcf47a87e086b6006ee9b747e2c7caae82334d6ba6b' '524e11a66f0931dc1affcfcf47a87e086b6006ee9b747e2c7caae82334d6ba6b'
'eea3f80f72cfde52745fbb24b9d3a3506dd2cdbb08fe53a529d7c9a14f0381a6' 'eea3f80f72cfde52745fbb24b9d3a3506dd2cdbb08fe53a529d7c9a14f0381a6'
'40d3f2778ff111bf75c736018a25c5d5cf02585a1981430d18dd2ec030414771' '40d3f2778ff111bf75c736018a25c5d5cf02585a1981430d18dd2ec030414771'
@ -48,9 +38,11 @@ find . -name config.sub -exec chmod +w {} \; -exec cp /usr/share/libtool/build-a
find . -name config.guess -exec chmod +w {} \; -exec cp /usr/share/libtool/build-aux/config.guess {} \; find . -name config.guess -exec chmod +w {} \; -exec cp /usr/share/libtool/build-aux/config.guess {} \;
cd js-1.8.5 cd js-1.8.5
patch -p1 -i ../fix-811665.patch # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=811665
patch -p1 -i ../destdir.patch patch -p1 -i ../fix-gcc6.patch
patch -p1 -i ../autoconf.patch # https://bugzilla.mozilla.org/show_bug.cgi?id=628723
patch -p1 -i ../fix-install-symlinks.patch
patch -p1 -i ../system-libffi-autoconf.patch
patch -p1 -i ../allow-to-build-against-system-libffi.patch patch -p1 -i ../allow-to-build-against-system-libffi.patch
patch -p1 -i ../ihatemozilla.patch patch -p1 -i ../ihatemozilla.patch
@ -64,14 +56,19 @@ find . -name config.guess -exec chmod +w {} \; -exec cp /usr/share/libtool/build
build() { build() {
cd js-1.8.5/js/src cd js-1.8.5/js/src
# _FORTIFY_SOURCE causes configure error # _FORTIFY_SOURCE causes the following configure error:
# checking for the alignment of void*... configure: error: No alignment found for void*
unset CPPFLAGS unset CPPFLAGS
./configure \ ./configure \
--prefix=/usr \ --prefix=/usr \
--with-system-nspr \ --with-system-nspr \
--disable-tests \ --disable-tests \
--disable-optimize \
--disable-profile-guided-optimization \
--enable-ctypes \ --enable-ctypes \
--enable-jemalloc \
--enable-readline \
--enable-threadsafe \ --enable-threadsafe \
--enable-system-ffi --enable-system-ffi
@ -90,5 +87,3 @@ package() {
# Remove static lib (!staticlibs does not work because name do not match) # Remove static lib (!staticlibs does not work because name do not match)
rm "${pkgdir}"/usr/lib/libmozjs185-1.0.a rm "${pkgdir}"/usr/lib/libmozjs185-1.0.a
} }
# vim:set ts=2 sw=2 et:

View file

@ -80,7 +80,7 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
} else { } else {
patstr = fm.patstr; patstr = fm.patstr;
} }
@@ -3408,7 +3408,7 @@ js_InitStringClass(JSContext *cx, JSObje @@ -3400,7 +3400,7 @@ js_InitStringClass(JSContext *cx, JSObje
UndefinedValue(), NULL, NULL, UndefinedValue(), NULL, NULL,
JSPROP_READONLY | JSPROP_PERMANENT | JSPROP_SHARED, 0, 0, JSPROP_READONLY | JSPROP_PERMANENT | JSPROP_SHARED, 0, 0,
NULL)) { NULL)) {

View file

@ -1,9 +1,8 @@
# See discussion in https://bugzilla.mozilla.org/show_bug.cgi?id=628723 https://bugzilla.mozilla.org/show_bug.cgi?id=628723#c43
# Patch created by Colin Walters <walters@verbum.org>
--- a/js/src/Makefile.in --- a/js/src/Makefile.in
+++ b/js/src/Makefile.in +++ b/js/src/Makefile.in
@@ -900,8 +900,8 @@ endif @@ -888,8 +888,8 @@ endif
ifeq (,$(HOST_BIN_SUFFIX)) ifeq (,$(HOST_BIN_SUFFIX))
mv -f $(SHLIB_ANY_VER) $(SHLIB_EXACT_VER) mv -f $(SHLIB_ANY_VER) $(SHLIB_EXACT_VER)
@[ ! -h $(SHLIB_ABI_VER) ] || rm -f $(SHLIB_ABI_VER) @[ ! -h $(SHLIB_ABI_VER) ] || rm -f $(SHLIB_ABI_VER)