core/linux to 3.1.1-1

This commit is contained in:
Kevin Mihelich 2011-11-16 21:26:13 -05:00
parent de9d23902a
commit 921e782fc1
3 changed files with 7 additions and 1546 deletions

View file

@ -9,15 +9,15 @@ pkgname=('linux' 'linux-headers')
# pkgname=linux-custom # Build kernel with a different name
_kernelname=${pkgname#linux}
_basekernel=3.1
pkgver=${_basekernel}
pkgrel=4
pkgver=${_basekernel}.1
pkgrel=1
arch=('arm')
url="http://www.kernel.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'uboot-mkimage')
options=('!strip')
source=("ftp://ftp.kernel.org/pub/linux/kernel/v3.x/linux-${_basekernel}.tar.bz2"
#"ftp://ftp.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.bz2"
"ftp://ftp.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.bz2"
'archlinuxarm.patch'
'aufs3-kbuild.patch'
'aufs3-base.patch'
@ -25,10 +25,9 @@ source=("ftp://ftp.kernel.org/pub/linux/kernel/v3.x/linux-${_basekernel}.tar.bz2
'aufs3-git-extras.patch'
'config'
'change-default-console-loglevel.patch'
'dib0700-fix.patch'
'usb-add-reset-resume-quirk-for-several-webcams.patch'
'md-raid10-fix-bug-when-activating-a-hot-spare.patch')
'usb-add-reset-resume-quirk-for-several-webcams.patch')
md5sums=('8d43453f8159b2332ad410b19d86a931'
'8eb92cc70e7f8d1d18a349ba8c029d7d'
'2b2b459c34e55e68fc53ac30766ed139'
'3f64ed9d71499fe9293dc671f4e4087e'
'29628745258df910abfb8cb24ca3ccd9'
@ -36,30 +35,18 @@ md5sums=('8d43453f8159b2332ad410b19d86a931'
'55b04499a4578e586cf5a4d0b69fc5aa'
'e1720c5ca9bbdc4e0b0760b05d66ef74'
'9d3c56a4b999c8bfbd4018089a62f662'
'abcd7b4b5676deed0114684e555f7c0f'
'd00814b57448895e65fbbc800e8a58ba'
'5967b6e2c3bc61b9718716d95ccfdc22')
'd00814b57448895e65fbbc800e8a58ba')
build() {
cd "${srcdir}/linux-${_basekernel}"
# add upstream patch
#patch -p1 -i "${srcdir}/patch-${pkgver}"
# Fix dib0700 driver
# http://git.linuxtv.org/pb/media_tree.git/shortlog/refs/heads/for_v3.0
# FS#25939
patch -Np1 -i "${srcdir}/dib0700-fix.patch"
patch -p1 -i "${srcdir}/patch-${pkgver}"
# Add the USB_QUIRK_RESET_RESUME for several webcams
# FS#26528
patch -Np1 -i "${srcdir}/usb-add-reset-resume-quirk-for-several-webcams.patch"
# Fix RAID10 hot spare activation (critical)
# https://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git;a=blob_plain;f=queue-3.1/md-raid10-fix-bug-when-activating-a-hot-spare.patch;h=880849db5b7089b523f72c4d67a473e5330037fc;hb=HEAD
# FS#26767
patch -Np1 -i "${srcdir}/md-raid10-fix-bug-when-activating-a-hot-spare.patch"
# Add Arch Linux ARM patch for ARMv5te plug computers
patch -Np1 -i ${srcdir}/archlinuxarm.patch

File diff suppressed because it is too large Load diff

View file

@ -1,40 +0,0 @@
From 7fcc7c8acf0fba44d19a713207af7e58267c1179 Mon Sep 17 00:00:00 2001
From: NeilBrown <neilb@suse.de>
Date: Mon, 31 Oct 2011 12:59:44 +1100
Subject: md/raid10: Fix bug when activating a hot-spare.
From: NeilBrown <neilb@suse.de>
commit 7fcc7c8acf0fba44d19a713207af7e58267c1179 upstream.
This is a fairly serious bug in RAID10.
When a RAID10 array is degraded and a hot-spare is activated, the
spare does not take up the empty slot, but rather replaces the first
working device.
This is likely to make the array non-functional. It would normally
be possible to recover the data, but that would need care and is not
guaranteed.
This bug was introduced in commit
2bb77736ae5dca0a189829fbb7379d43364a9dac
which first appeared in 3.1.
Signed-off-by: NeilBrown <neilb@suse.de>
Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
---
drivers/md/raid10.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
--- a/drivers/md/raid10.c
+++ b/drivers/md/raid10.c
@@ -1337,7 +1337,7 @@ static int raid10_add_disk(mddev_t *mdde
mirror_info_t *p = &conf->mirrors[mirror];
if (p->recovery_disabled == mddev->recovery_disabled)
continue;
- if (!p->rdev)
+ if (p->rdev)
continue;
disk_stack_limits(mddev->gendisk, rdev->bdev,