extra/calligra to 3.1.0-13

This commit is contained in:
Kevin Mihelich 2018-12-18 01:24:30 +00:00
parent 6f5e83f055
commit 922f747b82
2 changed files with 35 additions and 2 deletions

View file

@ -10,7 +10,7 @@
pkgname=calligra
pkgdesc="A set of applications for productivity and creative usage"
pkgver=3.1.0
pkgrel=12
pkgrel=13
arch=(x86_64)
url='https://www.calligra-suite.org/'
license=(FDL1.2 GPL2 LGPL)
@ -43,12 +43,14 @@ source=("https://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.x
calligra-qt5.11.patch
calligra-poppler-0.69.patch::"https://cgit.kde.org/calligra.git/patch/?id=a6157182"
calligra-poppler-0.71.patch
calligra-poppler-0.72.patch
'calligra-2.9.11-gcc6_arm.patch')
sha256sums=('6818cd6e64136321be217eb57cc7d6ac7c7035191fdb1ee336ebe60bc114e870'
'SKIP'
'40ac9fabed8e13c31f6f243bd7e9083c3ec322568991ba84987106b982ffc10a'
'b6b3dc44606aa4243cd0da23819f3bad9953d0542b87d3b4e04113f431f2598c'
'127cc5e0946fbf741279306b4e9d592f5f901a7fab09039fcfc6c7e60193fa80'
'052adc4ea812d7667812ff7867e703327dbe7c1ecad86094fd6772dc09782d87'
'87a09710b9e7e825a46344ddec08eb98b3454d6d067b0177d284733b2342cece'
'33d803c49abefc37f51f824543e889f9e369e86df9ce64d980e0a7dbca2ea27d')
validpgpkeys=(05D00A8B73A686789E0A156858B9596C722EA3BD # Boudewijn Rempt <foundation@krita.org>
42A60D06F449E895F40F09C01638B8A616108B8A) # Dag Andersen <danders@get2net.dk>
@ -63,6 +65,8 @@ prepare() {
patch -p1 -i ../calligra-poppler-0.69.patch
# Fix build with poppler 0.71
patch -p1 -i ../calligra-poppler-0.71.patch
# Fix build with poppler 0.72
patch -p1 -i ../calligra-poppler-0.72.patch
patch -p1 -i ../calligra-2.9.11-gcc6_arm.patch
}

View file

@ -0,0 +1,29 @@
diff --git a/filters/karbon/pdf/SvgOutputDev.cpp b/filters/karbon/pdf/SvgOutputDev.cpp
index 80f01a5f76f..ea69228dbc1 100644
--- a/filters/karbon/pdf/SvgOutputDev.cpp
+++ b/filters/karbon/pdf/SvgOutputDev.cpp
@@ -407,7 +407,7 @@ void SvgOutputDev::drawString(GfxState * state, const GooString * s)
QString str;
- const char * p = s->getCString();
+ const char * p = s->c_str();
int len = s->getLength();
CharCode code;
Unicode *u = nullptr;
@@ -459,11 +459,11 @@ void SvgOutputDev::drawString(GfxState * state, const GooString * s)
*d->body << " y=\"" << y << "px\"";
if (font && font->getFamily()) {
- *d->body << " font-family=\"" << QString::fromLatin1(font->getFamily()->getCString()) << "\"";
- //debugPdf << "font family:" << QString::fromLatin1( font->getFamily()->getCString() );
+ *d->body << " font-family=\"" << QString::fromLatin1(font->getFamily()->c_str()) << "\"";
+ //debugPdf << "font family:" << QString::fromLatin1( font->getFamily()->c_str() );
} else if (font && font->getName()) {
- *d->body << " font-family=\"" << QString::fromLatin1(font->getName()->getCString()) << "\"";
- //debugPdf << "font name:" << QString::fromLatin1( font->getName()->getCString() );
+ *d->body << " font-family=\"" << QString::fromLatin1(font->getName()->c_str()) << "\"";
+ //debugPdf << "font name:" << QString::fromLatin1( font->getName()->c_str() );
}
*d->body << " font-size=\"" << qMax(state->getFontSize(), state->getTransformedFontSize()) << "px\"";