diff --git a/extra/mlt/PKGBUILD b/extra/mlt/PKGBUILD
deleted file mode 100644
index 099d896b0..000000000
--- a/extra/mlt/PKGBUILD
+++ /dev/null
@@ -1,82 +0,0 @@
-# Maintainer: Antonio Rojas <arojas@archlinux.org>
-# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
-# Contributor: Fabian Schoelzel <myfirstname.mylastname@googlemail.com>
-# Contributor: funkyou <spamopfer@nickname.berlin.de>
-# Contributor: tardo <tardo@nagi-fanboi.net>
-# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
-# Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
-
-# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
-#  - delete x86 file so that it's not picked up for the build
-
-pkgname=mlt
-pkgver=6.22.0
-pkgrel=2
-pkgdesc="An open source multimedia framework"
-arch=(x86_64)
-url="https://www.mltframework.org"
-license=(GPL)
-depends=(libebur128)
-optdepends=('sdl_image: SDL1 plugin'
-        'sdl2: SDL2 plugin'
-        'libsamplerate: libavresample plugin'
-        'sox: SOX (Audio Swiss Army Knife) plugin'
-        'ffmpeg: ffmpeg plugin'
-        'vid.stab: video stabilize plugin'
-        'qt5-svg: Qt5 plugins'
-        'jack: JACK sound output plugin'
-        'ladspa: LADSPA plugins'
-        'libexif: auto rotate plugin'
-        'frei0r-plugins: for additional effects'
-        'movit: opengl plugin'
-        'opencv: openCV plugin'
-        'rubberband: rubberband plugin'
-        'gdk-pixbuf2: gdk plugin'
-        'pango: gdk plugin'
-        'rtaudio: rtaudio plugin'
-        'python: python bindings')
-makedepends=(cmake ladspa frei0r-plugins libdv sdl_image libsamplerate sox ffmpeg vid.stab qt5-svg
-             jack libexif python swig movit eigen opencv rubberband gdk-pixbuf2 pango rtaudio imagemagick)
-conflicts=(python-mlt)
-provides=(python-mlt)
-replaces=(python-mlt)
-source=($pkgname-$pkgver.tar.gz::"https://github.com/mltframework/mlt/archive/v$pkgver.tar.gz"
-        mlt-cmake-fix-build.patch
-        mlt-cmake-fix-python-bindings.patch)
-sha256sums=('3392d70c528d7f32e78329232b1b93a5a36b058215f664953090315132b797e5'
-            '5871dee1c2153cf70d2a27782eba38eb694421dd089d83636b2a7f1d60938264'
-            'db0430533324ad65c1846e5391d012b97f856025ce661241f5584b681dfe0075')
-
-prepare() {
-  patch -d $pkgname-$pkgver -p1 -i ../mlt-cmake-fix-build.patch # Fix build with cmake
-  patch -d $pkgname-$pkgver -p1 -i ../mlt-cmake-fix-python-bindings.patch # Fix python bindings build with cmake
-
-  rm $pkgname-$pkgver/src/modules/core/composite_line_yuv_sse2_simple.c
-}
-
-build() {
-  cmake -B build -S $pkgname-$pkgver \
-    -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON
-  cmake --build build
-
-# python bindings
-  cd $pkgname-$pkgver/src/swig/python
-  ./build
-}
-
-package() {
-  DESTDIR="$pkgdir" cmake --install build
-
-# Install python bindings
-  _pythonpath=`python -c "from sysconfig import get_path; print(get_path('platlib'))"`
-  cd $pkgname-$pkgver/src/swig/python
-  mkdir -p "$pkgdir/$_pythonpath"
-  install -m755 mlt.py "$pkgdir/$_pythonpath" 
-  install -m755 _mlt.so "$pkgdir/$_pythonpath"
-
-# Compress lumas
-  for pgm in "$pkgdir"/usr/share/mlt/lumas/*/*.pgm; do
-    convert $pgm{,.png}
-    rm -f $pgm
-  done
-}
diff --git a/extra/mlt/mlt-cmake-fix-build.patch b/extra/mlt/mlt-cmake-fix-build.patch
deleted file mode 100644
index 69dd304f6..000000000
--- a/extra/mlt/mlt-cmake-fix-build.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/src/melt/CMakeLists.txt b/src/melt/CMakeLists.txt
-index b79afaf8..e8402276 100644
---- a/src/melt/CMakeLists.txt
-+++ b/src/melt/CMakeLists.txt
-@@ -1,11 +1,7 @@
- set(melt_lib mlt Threads::Threads)
- find_package(SDL2 QUIET)
- if(SDL2_FOUND)
--    add_library(sdl2 SHARED IMPORTED GLOBAL)
--    set_target_properties(sdl2 PROPERTIES
--        INTERFACE_INCLUDE_DIRECTORIES ${SDL2_INCLUDE_DIRS}
--        IMPORTED_LOCATION ${libdir}/libSDL2.so
--    )
-+    add_library(sdl2 ALIAS SDL2::SDL2)
- else()
-     pkg_check_modules(sdl2 IMPORTED_TARGET GLOBAL sdl2)
-     if(TARGET PkgConfig::sdl2)
diff --git a/extra/mlt/mlt-cmake-fix-python-bindings.patch b/extra/mlt/mlt-cmake-fix-python-bindings.patch
deleted file mode 100644
index 815e0a374..000000000
--- a/extra/mlt/mlt-cmake-fix-python-bindings.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/swig/python/build b/src/swig/python/build
-index 9b86703c..1c51399f 100755
---- a/src/swig/python/build
-+++ b/src/swig/python/build
-@@ -25,7 +25,7 @@ then
- 	${CXX} -fPIC -D_GNU_SOURCE ${CXXFLAGS} -c -I../.. $PYTHON_INCLUDE mlt_wrap.cxx || exit $?
- 
- 	# Create the module
--	${CXX} ${CXXFLAGS} -shared mlt_wrap.o -L../../mlt++ -lmlt++ -L../../framework -lmlt $("${PYTHON}-config" --ldflags) -o _mlt.so || exit $?
-+	${CXX} ${CXXFLAGS} -shared mlt_wrap.o -L../../../../build/src/mlt++ -lmlt++ -L../../../../build/src/framework -lmlt ${LDFLAGS} $("${PYTHON}-config" --ldflags) -o _mlt.so || exit $?
- else
- 	echo Python not installed.
- 	exit 1