core/linux-armv7 to 4.10.1-1

This commit is contained in:
Kevin Mihelich 2017-02-28 01:43:51 +00:00
parent 0ddc4b6544
commit 92cb7f420b
12 changed files with 77 additions and 45 deletions

View file

@ -1,7 +1,7 @@
From b9f6d275e5af76eb4e32beb66480e8f53a7d1685 Mon Sep 17 00:00:00 2001
From 2a2ab2b8ed60e043da32ddac674d7c58a63c1c8f Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:59:28 +0100
Subject: [PATCH 1/9] ARM: atags: add support for Marvell's u-boot
Subject: [PATCH 01/10] ARM: atags: add support for Marvell's u-boot
Marvell uses a specific atag in its u-boot which includes among other
information the MAC addresses for up to 4 network interfaces.
@ -47,5 +47,5 @@ index 979ff4016404..d1d0c1950fa4 100644
};
--
2.11.0
2.11.1

View file

@ -1,8 +1,8 @@
From 3573189a2857cd66d248fb79e48a45ae70399c0b Mon Sep 17 00:00:00 2001
From 2890deaac9ce485f0b20211872784b0071d82717 Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:56:58 +0100
Subject: [PATCH 2/9] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
loader
Subject: [PATCH 02/10] ARM: atags/fdt: retrieve MAC addresses from Marvell
boot loader
The atags are parsed and if a Marvell atag is found, up to 4 MAC
addresses are extracted there and assigned to node aliases eth0..3
@ -43,5 +43,5 @@ index 9448aa0c6686..ac7b6ae6c00f 100644
}
--
2.11.0
2.11.1

View file

@ -1,7 +1,7 @@
From 94679e069c9def09906a6b5f85c58ebd981ff615 Mon Sep 17 00:00:00 2001
From fcd4be4707777620a01f1b1097fdb8f93e4c1077 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:41:19 -0600
Subject: [PATCH 3/9] SMILE Plug device tree file
Subject: [PATCH 03/10] SMILE Plug device tree file
This adds a dts file for the SMILE Plug, which only differs from the Mirabox
dts with the LED definitions.
@ -14,7 +14,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
create mode 100644 arch/arm/boot/dts/armada-370-smileplug.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index f10fe8526239..f00e858de082 100644
index 01d178a2009f..85f6d6661443 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -935,6 +935,7 @@ dtb-$(CONFIG_MACH_ARMADA_370) += \
@ -205,5 +205,5 @@ index 000000000000..d01308ab848b
+ };
+};
--
2.11.0
2.11.1

View file

@ -1,7 +1,7 @@
From 4831d1d37e42c17f97ae238d6bbcfda7c8dac028 Mon Sep 17 00:00:00 2001
From 14c522e0476341f7684cef8b1ad0c03a3e4509e6 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:43:56 -0600
Subject: [PATCH 4/9] fix mvsdio eMMC timing
Subject: [PATCH 04/10] fix mvsdio eMMC timing
These changes from Globalscale change the MMC timing to allow the eMMC versions
of the Mirabox and SMILE Plug to work.
@ -34,5 +34,5 @@ index 42296e55b9de..e5ce6d27ec82 100644
host->clock = ios->clock;
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
--
2.11.0
2.11.1

View file

@ -1,7 +1,8 @@
From 079ecb4f368b983d08e7c19daaf64311b8814ee3 Mon Sep 17 00:00:00 2001
From 92ba4f4447bc5ed008f449e2d44ed339df3f4d0f Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 5/9] net/smsc95xx: Allow mac address to be set as a parameter
Subject: [PATCH 05/10] net/smsc95xx: Allow mac address to be set as a
parameter
---
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
@ -91,5 +92,5 @@ index 831aa33d078a..03625547d794 100644
/* maybe the boot loader passed the MAC address in devicetree */
--
2.11.0
2.11.1

View file

@ -1,7 +1,7 @@
From f8ed0685d6606fe27a3e8fc8aa3744f17f9e1956 Mon Sep 17 00:00:00 2001
From 73eeb8c53d5402e318c7414ca89197faacc82a7d Mon Sep 17 00:00:00 2001
From: dobatog <dobatog@gmail.com>
Date: Thu, 26 Feb 2015 12:32:27 +0100
Subject: [PATCH 6/9] ARM: TLV320AIC23 SoC Audio Codec: Fix errors reported
Subject: [PATCH 06/10] ARM: TLV320AIC23 SoC Audio Codec: Fix errors reported
related to input routing signals.
The following patch, based on stable v3.19, corrects the errors that are reported in the boot trace in reference to the Input Signals of the audio codec TLV320AIC23:
@ -45,5 +45,5 @@ index 410cae0f2060..0bb8e2602d8e 100644
/* input mux */
{"Capture Source", "Line", "Line Input"},
--
2.11.0
2.11.1

View file

@ -1,7 +1,7 @@
From 6a7d1d2fab44c1830903b7af1a8a844ce4925763 Mon Sep 17 00:00:00 2001
From ab716cec125455302c0e09ce6709033933b618df Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 14 Feb 2015 12:32:27 +0100
Subject: [PATCH 7/9] set default cubietruck led triggers
Subject: [PATCH 07/10] set default cubietruck led triggers
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
@ -29,5 +29,5 @@ index 83f39b0362cb..15e9626ea81b 100644
};
--
2.11.0
2.11.1

View file

@ -1,7 +1,7 @@
From 5bd43bf12a2258976be01fe1211de9ad4d8e9145 Mon Sep 17 00:00:00 2001
From 357aaf663585092fc717d6bb8397b6ef8764a660 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 11 Aug 2016 00:42:37 -0600
Subject: [PATCH 8/9] exynos4412-odroid: set higher minimum buck2 regulator
Subject: [PATCH 08/10] exynos4412-odroid: set higher minimum buck2 regulator
voltage
Set a higher minimum voltage to help reboot issue.
@ -26,5 +26,5 @@ index 8aa19ba14436..8e2d94e3af72 100644
regulator-always-on;
regulator-boot-on;
--
2.11.0
2.11.1

View file

@ -1,7 +1,7 @@
From 24b08faa09d097e432fe36817dce69335c63d412 Mon Sep 17 00:00:00 2001
From a5f7ae6a9dc41c26bcc0d4e66f18c352435ba4eb Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Mon, 26 Dec 2016 12:56:09 -0700
Subject: [PATCH 9/9] drm/armada tracing fix
Subject: [PATCH 09/10] drm/armada tracing fix
https://lists.freedesktop.org/archives/dri-devel/2016-December/126212.html
---
@ -19,5 +19,5 @@ index a18f156c8b66..64c0b4546fb2 100644
+
+CFLAGS_armada_trace.o := -I$(src)
--
2.11.0
2.11.1

View file

@ -0,0 +1,27 @@
From 891345676e0af18d5d809b8a810db56a363aaf3b Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 25 Feb 2017 19:39:51 -0700
Subject: [PATCH 10/10] disable USB3 port on ODROID-XU
Ports report over-current condition and are non-operable.
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
arch/arm/boot/dts/exynos5410-odroidxu.dts | 1 +
1 file changed, 1 insertion(+)
diff --git a/arch/arm/boot/dts/exynos5410-odroidxu.dts b/arch/arm/boot/dts/exynos5410-odroidxu.dts
index c4de1353e5df..f80fa58995c5 100644
--- a/arch/arm/boot/dts/exynos5410-odroidxu.dts
+++ b/arch/arm/boot/dts/exynos5410-odroidxu.dts
@@ -630,6 +630,7 @@
&usbdrd_dwc3_0 {
dr_mode = "host";
+ status = "disabled";
};
&usbdrd_dwc3_1 {
--
2.11.1

View file

@ -7,7 +7,7 @@ pkgbase=linux-armv7
_srcname=linux-4.10
_kernelname=${pkgbase#linux}
_desc="ARMv7 multi-platform"
pkgver=4.10.0
pkgver=4.10.1
pkgrel=1
rcnrel=armv7-x1
arch=('armv7h')
@ -16,7 +16,7 @@ license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git' 'uboot-tools' 'vboot-utils' 'dtc')
options=('!strip')
source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
#"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
"http://rcn-ee.com/deb/sid-armhf/v${pkgver}-${rcnrel}/patch-${pkgver%.0}-${rcnrel}.diff.gz"
'0001-ARM-atags-add-support-for-Marvell-s-u-boot.patch'
'0002-ARM-atags-fdt-retrieve-MAC-addresses-from-Marvell-bo.patch'
@ -27,6 +27,7 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'0007-set-default-cubietruck-led-triggers.patch'
'0008-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch'
'0009-drm-armada-tracing-fix.patch'
'0010-disable-USB3-port-on-ODROID-XU.patch'
'config'
'kernel.its'
'kernel.keyblock'
@ -34,17 +35,19 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'linux.preset'
'99-linux.hook')
md5sums=('b5e7f6b9b2fe1b6cc7bc56a3a0bfc090'
'4d5a9908ea800a6aa704a9cb31e4c86b'
'214847b73b9001db1362e8bb3f9aed87'
'82ffb2a8297f35e56f8827bd6cc89a32'
'70bc3d3d13f4e77728bbc324dc81a9d3'
'47eae7e2c1d8e41137c4214b3091aa99'
'cfa66bcafa51215e71be60c63e978e35'
'5f76b742e3d04056a6bb49c1bde4a190'
'a93178aff351099bdc1932b15c09e506'
'd9986312d2a15c29cf816a967d3447e1'
'62e75ec9b302e39ac51227ebb4243b76'
'b31f5c531af2b831e82977bee36d9420'
'd4ab54e17b686d1dbb1d28238fd0b081'
'5a8899a0771572d01257d93160a1e604'
'88ad590a43ebe285c4df6a1c5c298b97'
'56e0bd2354406b132cf904c3877506c5'
'34a723ffcbef63e9461193061b4461a1'
'28bf88b2ad58937d00d2240690e59973'
'23fe69ef9a0e3e016eea4529e0db4268'
'1204a4c65fe53025bb02042e7ee105cb'
'5c0086e99dcc1e84d70d6809d452c52c'
'2a92aab5348329756f65933f919bb9ef'
'0429d0ffa8ccda0d69ac69dcf7cc49f1'
'a6b0eb95998ae11416186728e855c289'
'df0368168ac1179a70b0c3a28b35ae8f'
'4f2379ed84258050edb858ee8d281678'
'61c5ff73c136ed07a7aadbf58db3d96a'
'584777ae88bce2c5659960151b64c7d8'
@ -55,7 +58,7 @@ prepare() {
cd "${srcdir}/${_srcname}"
# add upstream patch
#git apply --whitespace=nowarn ../patch-${pkgver}
git apply --whitespace=nowarn ../patch-${pkgver}
# RCN patch
git apply ../patch-${pkgver%.0}-${rcnrel}.diff
@ -70,6 +73,7 @@ prepare() {
git apply ../0007-set-default-cubietruck-led-triggers.patch
git apply ../0008-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch
git apply ../0009-drm-armada-tracing-fix.patch
git apply ../0010-disable-USB3-port-on-ODROID-XU.patch
cat "${srcdir}/config" > ./.config

View file

@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
# Linux/arm 4.10.0-rc7-1 Kernel Configuration
# Linux/arm 4.10.1-1 Kernel Configuration
#
CONFIG_ARM=y
CONFIG_ARM_HAS_SG_CHAIN=y
@ -3855,7 +3855,7 @@ CONFIG_GPIOLIB=y
CONFIG_OF_GPIO=y
CONFIG_GPIOLIB_IRQCHIP=y
# CONFIG_DEBUG_GPIO is not set
# CONFIG_GPIO_SYSFS is not set
CONFIG_GPIO_SYSFS=y
# CONFIG_GPIO_OF_HELPER is not set
CONFIG_GPIO_GENERIC=y
CONFIG_GPIO_MAX730X=m