mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
community/ldc to 1.32.0-1
This commit is contained in:
parent
0d22362109
commit
92f0a4e409
2 changed files with 3 additions and 35 deletions
|
@ -10,9 +10,9 @@
|
|||
|
||||
pkgname=('ldc' 'liblphobos')
|
||||
groups=('dlang' 'dlang-ldc')
|
||||
pkgver=1.31.0
|
||||
_pkgcommit=91f28da37fa473a81aa550b74d7842b0122412f1
|
||||
_dversion=2.101.2
|
||||
pkgver=1.32.0
|
||||
_pkgcommit=c5cf0860300281a99f8908064e6a196e49950d1c
|
||||
_dversion=2.102.2
|
||||
_clangversion=15.0.7 # related to where ldc2 looks for compiler-rt sanitizers
|
||||
epoch=3
|
||||
pkgrel=1
|
||||
|
|
|
@ -1,32 +0,0 @@
|
|||
From 7e80c26eded0326e18aad2c9f906844eb0f46dc0 Mon Sep 17 00:00:00 2001
|
||||
From: Martin Kinkelin <noone@nowhere.com>
|
||||
Date: Wed, 6 Oct 2021 18:47:28 +0200
|
||||
Subject: [PATCH] Keep default alignment for atomic instructions, for LLVM 13+
|
||||
too
|
||||
|
||||
---
|
||||
gen/tocall.cpp | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/gen/tocall.cpp b/gen/tocall.cpp
|
||||
index 385133015b..28967a64c3 100644
|
||||
--- a/gen/tocall.cpp
|
||||
+++ b/gen/tocall.cpp
|
||||
@@ -511,7 +511,7 @@ bool DtoLowerMagicIntrinsic(IRState *p, FuncDeclaration *fndecl, CallExp *e,
|
||||
auto ret =
|
||||
p->ir->CreateAtomicCmpXchg(ptr, cmp, val,
|
||||
#if LDC_LLVM_VER >= 1300
|
||||
- LLMaybeAlign(getABITypeAlign(val->getType())),
|
||||
+ llvm::MaybeAlign(), // default alignment
|
||||
#endif
|
||||
successOrdering, failureOrdering);
|
||||
ret->setWeak(isWeak);
|
||||
@@ -559,7 +559,7 @@ bool DtoLowerMagicIntrinsic(IRState *p, FuncDeclaration *fndecl, CallExp *e,
|
||||
LLValue *ret =
|
||||
p->ir->CreateAtomicRMW(llvm::AtomicRMWInst::BinOp(op), ptr, val,
|
||||
#if LDC_LLVM_VER >= 1300
|
||||
- LLMaybeAlign(getABITypeAlign(val->getType())),
|
||||
+ llvm::MaybeAlign(), // default alignment
|
||||
#endif
|
||||
llvm::AtomicOrdering(atomicOrdering));
|
||||
result = new DImValue(exp2->type, ret);
|
Loading…
Reference in a new issue