extra/mplayer to 37916-1

This commit is contained in:
Kevin Mihelich 2017-01-18 20:32:54 +00:00
parent 8aebd6ded8
commit 935172a826
4 changed files with 35 additions and 149 deletions

View file

@ -1,5 +1,5 @@
# $Id$
# Maintainer: Ionut Biru <ibiru@archlinux.org>
# Maintainer: Levente Polyak <anthraxx@archlinux.org>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: Hugo Doria <hugo@archlinux.org>
@ -9,51 +9,35 @@
pkgbase=mplayer
pkgname=('mplayer' 'mencoder')
pkgver=37857
pkgver=37916
pkgrel=1
arch=('i686' 'x86_64')
makedepends=(
'libxxf86dga' 'libxxf86vm' 'libmad' 'libxinerama' 'sdl' 'lame' 'libtheora'
'xvidcore' 'libmng' 'libxss' 'libgl' 'smbclient' 'aalib' 'jack' 'libcaca'
'faac' 'faad2' 'lirc' 'libxvmc' 'enca' 'libvdpau' 'opencore-amr'
'libdca' 'a52dec' 'schroedinger' 'libvpx' 'libpulse' 'fribidi' 'unzip' 'mesa'
'live-media' 'yasm' 'git' 'fontconfig' 'mpg123' 'ladspa' 'libass' 'libbluray'
'libcdio-paranoia' 'opus' 'subversion' 'x264' 'libx264' 'rtmpdump' 'gnutls'
'gsm' 'libdvdcss' 'libdvdread' 'libdvdnav' 'ffmpeg'
)
license=('GPL')
pkgdesc='Media player for Linux'
url='http://www.mplayerhq.hu/'
arch=('i686' 'x86_64')
license=('GPL')
makedepends=('libxxf86dga' 'libmad' 'libxinerama' 'libmng' 'libxss' 'smbclient' 'aalib' 'jack'
'libcaca' 'faac' 'faad2' 'lirc' 'libxvmc' 'enca' 'libdca' 'a52dec' 'libvpx' 'unzip'
'mesa' 'live-media' 'yasm' 'git' 'mpg123' 'ladspa' 'libcdio-paranoia' 'subversion'
'x264' 'libx264' 'rtmpdump' 'libdvdcss' 'libdvdread' 'libdvdnav' 'ffmpeg')
options=('!buildflags' '!emptydirs')
source=($pkgbase-$pkgver::svn://svn.mplayerhq.hu/mplayer/trunk#revision=$pkgver
source=(${pkgbase}-${pkgver}::svn://svn.mplayerhq.hu/mplayer/trunk#revision=${pkgver}
mplayer.desktop
include-samba-4.0.patch
ffmpeg-libvpxenc-remove-some-unused-ctrl-id-mappings.patch
revert-icl-fixes.patch)
md5sums=('SKIP'
'62f44a58f072b2b1a3c3d3e4976d64b3'
'868a92bdef148df7f38bfa992b26ce9d'
'71be9bcd297cb9ce833bbc5d425c0470'
'3579402002b7302fdf2d146639333efd')
#pkgver() {
# cd $pkgbase-$pkgver
# svnversion
#}
sha512sums=('SKIP'
'd3c5cbf0035279c6f307e4e225473d7b77f9b56566537a26aa694e68446b9e3240333296da627ad5af83b04cc8f476d1a3f8c05e4cf81cd6e77153feb4ed74bc'
'9debb8c58b996f6c716c22c86c720bf9dc49b4ee9b76c57519f791667ae1de2cc6f5add878fbf4ac02c6b6fd1865e1bcfa6105e75de4bf7ec596c338ed0cae99'
'0cae0b26d3d97fd4c962962c43a481de20335369cbca406cadfc9bda1a0608b32f5374e76c477cb9a85bda83a568a1ed17126df224ae61579d0a402c1824aea8')
prepare() {
cd $pkgbase-$pkgver
# mv ../ffmpeg-*/ ./ffmpeg
patch -Np1 -i ../include-samba-4.0.patch
patch -Np0 -i ../revert-icl-fixes.patch
# patch -d ffmpeg -Np1 <../ffmpeg-libvpxenc-remove-some-unused-ctrl-id-mappings.patch
cd ${pkgbase}-${pkgver}
patch -p1 < "../include-samba-4.0.patch"
patch -p0 < "../revert-icl-fixes.patch"
./version.sh
}
build() {
cd $pkgbase-$pkgver
cd ${pkgbase}-${pkgver}
./configure --prefix=/usr \
--enable-armv5te \
--disable-gui \
@ -74,47 +58,33 @@ build() {
--enable-smb \
--language=all \
--confdir=/etc/mplayer
[[ "$CARCH" = "i686" ]] && sed 's|-march=i486|-march=i686|g' -i config.mak
[[ "${CARCH}" = "i686" ]] && sed 's|-march=i486|-march=i686|g' -i config.mak
make
}
package_mplayer() {
pkgdesc='Media player for Linux'
backup=('etc/mplayer/codecs.conf' 'etc/mplayer/input.conf')
depends=(
'desktop-file-utils' 'ttf-font' 'enca' 'libxss' 'a52dec' 'libvpx'
'lirc' 'libx264' 'libmng' 'libdca' 'aalib' 'lame' 'fontconfig'
'libgl' 'libxinerama' 'libvdpau' 'libpulse' 'smbclient' 'xvidcore'
'opencore-amr' 'jack' 'libmad' 'sdl' 'libtheora' 'libcaca' 'libxxf86dga'
'fribidi' 'libjpeg' 'faac' 'faad2' 'libxvmc' 'schroedinger' 'mpg123'
'libass' 'libxxf86vm' 'libbluray' 'libcdio-paranoia' 'opus' 'rtmpdump'
'gsm' 'gnutls' 'libdvdnav' 'ffmpeg'
)
depends=('desktop-file-utils' 'ttf-font' 'enca' 'libxss' 'a52dec' 'libvpx'
'lirc' 'libx264' 'libmng' 'libdca' 'aalib' 'libxinerama' 'smbclient'
'jack' 'libmad' 'libcaca' 'libxxf86dga' 'faac' 'faad2' 'libxvmc' 'mpg123'
'libcdio-paranoia' 'rtmpdump' 'libdvdnav' 'ffmpeg')
cd $pkgbase-$pkgver
make DESTDIR="$pkgdir" install-mplayer install-mplayer-man
cd ${pkgbase}-${pkgver}
make DESTDIR="${pkgdir}" install-mplayer install-mplayer-man
install -Dm644 etc/{codecs.conf,input.conf,example.conf} \
"$pkgdir/etc/mplayer/"
# desktop file (FS#14770)
install -Dm644 ../mplayer.desktop \
"$pkgdir"/usr/share/applications/mplayer.desktop
install -Dm644 etc/mplayer256x256.png \
"$pkgdir"/usr/share/pixmaps/mplayer.png
install -Dm 644 etc/{codecs.conf,input.conf,example.conf} "${pkgdir}/etc/mplayer"
install -Dm 644 "${srcdir}/mplayer.desktop" -t "${pkgdir}/usr/share/applications"
install -Dm 644 etc/mplayer256x256.png "${pkgdir}/usr/share/pixmaps/mplayer.png"
}
package_mencoder() {
pkgdesc='Free command line video decoding, encoding and filtering tool'
depends=(
'enca' 'a52dec' 'libvpx' 'libx264' 'libmng' 'libdca' 'bzip2' 'lame'
'alsa-lib' 'fontconfig' 'giflib' 'libpng' 'smbclient' 'xvidcore'
'opencore-amr' 'libmad' 'libtheora' 'fribidi' 'libjpeg' 'faac' 'faad2'
'schroedinger' 'mpg123' 'libass' 'libbluray' 'libcdio-paranoia'
'libvorbis' 'opus' 'rtmpdump' 'gsm' 'libdvdnav' 'ffmpeg'
)
depends=('enca' 'a52dec' 'libvpx' 'libx264' 'libmng' 'libdca' 'smbclient' 'libmad'
'faac' 'faad2' 'mpg123' 'libcdio-paranoia' 'rtmpdump' 'libdvdnav' 'ffmpeg')
make -C $pkgbase-$pkgver DESTDIR="$pkgdir" install-mencoder install-mencoder-man
find "$pkgdir"/usr/share/man -name mplayer.1 -exec rename mplayer.1 mencoder.1 {} +
make -C ${pkgbase}-${pkgver} DESTDIR="${pkgdir}" install-mencoder install-mencoder-man
find "${pkgdir}/usr/share/man" -name mplayer.1 -exec rename mplayer.1 mencoder.1 {} +
}
# vim: ts=2 sw=2 et:

View file

@ -1,43 +0,0 @@
Index: configure
===================================================================
--- configure (revision 35421)
+++ configure (working copy)
@@ -5968,8 +5968,8 @@
cat > $TMPC << EOF
#include <stdio.h>
#include <cdio/version.h>
-#include <cdio/cdda.h>
-#include <cdio/paranoia.h>
+#include <cdio/paranoia/cdda.h>
+#include <cdio/paranoia/paranoia.h>
int main(void) {
void *test = cdda_verbose_set;
printf("%s\n", CDIO_VERSION);
Index: gui/win32/interface.c
===================================================================
--- gui/win32/interface.c (revision 35421)
+++ gui/win32/interface.c (working copy)
@@ -24,7 +24,7 @@
#include "config.h"
#if defined(CONFIG_LIBCDIO)
-#include <cdio/cdda.h>
+#include <cdio/paranoia/cdda.h>
#elif defined(CONFIG_CDDA)
#include <cdda_interface.h>
#endif
Index: stream/stream_cdda.c
===================================================================
--- stream/stream_cdda.c (revision 35421)
+++ stream/stream_cdda.c (working copy)
@@ -21,8 +21,8 @@
#include <cdda_interface.h>
#include <cdda_paranoia.h>
#else
-#include <cdio/cdda.h>
-#include <cdio/paranoia.h>
+#include <cdio/paranoia/cdda.h>
+#include <cdio/paranoia/paranoia.h>
#endif
#include <stdio.h>
#include <stdlib.h>

View file

@ -1,41 +0,0 @@
From 6540fe04a3f9a11ba7084a49b3ee5fa2fc5b32ab Mon Sep 17 00:00:00 2001
From: James Zern <jzern@google.com>
Date: Mon, 19 Oct 2015 22:44:11 -0700
Subject: [PATCH] libvpxenc: remove some unused ctrl id mappings
VP8E_UPD_ENTROPY, VP8E_UPD_REFERENCE, VP8E_USE_REFERENCE were removed
from libvpx and the remaining values were never used here
Reviewed-by: Michael Niedermayer <michael@niedermayer.cc>
Signed-off-by: James Zern <jzern@google.com>
---
libavcodec/libvpxenc.c | 8 --------
1 file changed, 8 deletions(-)
diff --git a/libavcodec/libvpxenc.c b/libavcodec/libvpxenc.c
index 5f39783..992122c 100644
--- a/libavcodec/libvpxenc.c
+++ b/libavcodec/libvpxenc.c
@@ -104,19 +104,11 @@ typedef struct VP8EncoderContext {
/** String mappings for enum vp8e_enc_control_id */
static const char *const ctlidstr[] = {
- [VP8E_UPD_ENTROPY] = "VP8E_UPD_ENTROPY",
- [VP8E_UPD_REFERENCE] = "VP8E_UPD_REFERENCE",
- [VP8E_USE_REFERENCE] = "VP8E_USE_REFERENCE",
- [VP8E_SET_ROI_MAP] = "VP8E_SET_ROI_MAP",
- [VP8E_SET_ACTIVEMAP] = "VP8E_SET_ACTIVEMAP",
- [VP8E_SET_SCALEMODE] = "VP8E_SET_SCALEMODE",
[VP8E_SET_CPUUSED] = "VP8E_SET_CPUUSED",
[VP8E_SET_ENABLEAUTOALTREF] = "VP8E_SET_ENABLEAUTOALTREF",
[VP8E_SET_NOISE_SENSITIVITY] = "VP8E_SET_NOISE_SENSITIVITY",
- [VP8E_SET_SHARPNESS] = "VP8E_SET_SHARPNESS",
[VP8E_SET_STATIC_THRESHOLD] = "VP8E_SET_STATIC_THRESHOLD",
[VP8E_SET_TOKEN_PARTITIONS] = "VP8E_SET_TOKEN_PARTITIONS",
- [VP8E_GET_LAST_QUANTIZER] = "VP8E_GET_LAST_QUANTIZER",
[VP8E_SET_ARNR_MAXFRAMES] = "VP8E_SET_ARNR_MAXFRAMES",
[VP8E_SET_ARNR_STRENGTH] = "VP8E_SET_ARNR_STRENGTH",
[VP8E_SET_ARNR_TYPE] = "VP8E_SET_ARNR_TYPE",
--
1.7.10.4

Binary file not shown.

Before

Width:  |  Height:  |  Size: 1.9 KiB