mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
removed community/sunpinyin
This commit is contained in:
parent
3c34667a14
commit
9396ca065f
2 changed files with 0 additions and 69 deletions
|
@ -1,45 +0,0 @@
|
||||||
# $Id: PKGBUILD 92609 2013-06-10 02:29:07Z fyan $
|
|
||||||
# Maintainer: Felix Yan <felixonmars@gmail.com>
|
|
||||||
# Contributor: Thomas Dziedzic < gostrc at gmail >
|
|
||||||
|
|
||||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
||||||
# - patch for AArch64
|
|
||||||
|
|
||||||
pkgname=sunpinyin
|
|
||||||
pkgver=2.0.3.20130307
|
|
||||||
_commit=64e26d9ed1f617e59ff37c2efc0be97727c799a1
|
|
||||||
pkgrel=1
|
|
||||||
arch=('i686' 'x86_64')
|
|
||||||
pkgdesc="Statistical Language Model based pinyin IME by Sun"
|
|
||||||
license=('LGPL')
|
|
||||||
url="http://sunpinyin.googlecode.com"
|
|
||||||
depends=('sqlite' 'make' 'gcc-libs')
|
|
||||||
optdepends=('sunpinyin-data: Statistical language model data from open-gram project for sunpinyin')
|
|
||||||
makedepends=('git' 'scons' 'intltool')
|
|
||||||
source=("git://github.com/sunpinyin/sunpinyin.git#commit=$_commit"
|
|
||||||
'sunpinyin-aarch64.patch')
|
|
||||||
md5sums=('SKIP'
|
|
||||||
'b6de843feb134e6bfbf0eb53e81df551')
|
|
||||||
|
|
||||||
prepare() {
|
|
||||||
cd "$srcdir/$pkgname"
|
|
||||||
patch -p1 -i ../sunpinyin-aarch64.patch
|
|
||||||
}
|
|
||||||
|
|
||||||
build() {
|
|
||||||
cd "$srcdir/$pkgname"
|
|
||||||
sed -i -e "1s|python|python2|" python/*.py python/importer/*.py
|
|
||||||
|
|
||||||
scons \
|
|
||||||
--prefix=/usr
|
|
||||||
}
|
|
||||||
|
|
||||||
package() {
|
|
||||||
cd "$srcdir/$pkgname"
|
|
||||||
|
|
||||||
scons \
|
|
||||||
--prefix=/usr \
|
|
||||||
--install-sandbox="$pkgdir" \
|
|
||||||
install
|
|
||||||
}
|
|
||||||
|
|
|
@ -1,24 +0,0 @@
|
||||||
Index: sunpinyin-20130710/SConstruct
|
|
||||||
===================================================================
|
|
||||||
--- sunpinyin-20130710.orig/SConstruct
|
|
||||||
+++ sunpinyin-20130710/SConstruct
|
|
||||||
@@ -313,7 +313,8 @@ def AppendEndianCheck(conf):
|
|
||||||
|| defined(_POWER) || defined(__powerpc__) \
|
|
||||||
|| defined(__ppc__) || defined(__hpux) || defined(__hppa) \
|
|
||||||
|| defined(_MIPSEB) || defined(_POWER) \
|
|
||||||
- || defined(__s390__) || (defined(__sh__) && defined(__BIG_ENDIAN__))
|
|
||||||
+ || defined(__s390__) || (defined(__sh__) && defined(__BIG_ENDIAN__)) \
|
|
||||||
+ || defined(__AARCH64EB__)
|
|
||||||
# define WORDS_BIGENDIAN 1
|
|
||||||
|
|
||||||
#elif defined(__i386__) || defined(__i386) \
|
|
||||||
@@ -324,7 +325,8 @@ def AppendEndianCheck(conf):
|
|
||||||
|| defined(__x86_64) || defined(__x86_64__) \
|
|
||||||
|| defined(_M_X64) || defined(__bfin__) \
|
|
||||||
|| defined(__alpha__) || defined(__ARMEL__) \
|
|
||||||
- || defined(_MIPSEL) || (defined(__sh__) && defined(__LITTLE_ENDIAN__))
|
|
||||||
+ || defined(_MIPSEL) || (defined(__sh__) && defined(__LITTLE_ENDIAN__)) \
|
|
||||||
+ || defined(__AARCH64EL__)
|
|
||||||
# undef WORDS_BIGENDIAN
|
|
||||||
|
|
||||||
#else
|
|
Loading…
Reference in a new issue