extra/qt5-webengine to 5.15.6-5

This commit is contained in:
Kevin Mihelich 2021-10-22 03:01:29 +00:00
parent 6e462a20fd
commit 9416d68b1c
2 changed files with 17 additions and 2 deletions

View file

@ -12,7 +12,7 @@ highmem=1
pkgname=qt5-webengine
_qtver=5.15.6
pkgver=${_qtver/-/}
pkgrel=4
pkgrel=5
arch=('x86_64')
url='https://www.qt.io'
license=('LGPL3' 'LGPL2.1' 'BSD')
@ -43,7 +43,7 @@ sha256sums=('SKIP'
'dae11dec5088eb1b14045d8c9862801a342609c15701d7c371e1caccf46e1ffd'
'2294e5390c869963fc58f7bf1ee0a254a3f7fce3ed00c04e34a5f03e2b31b624'
'45ccf4ff981a26656e5105259f71a3ce386d4a7112cbf09e41cb61615b355435'
'c15954ab938ec6235c5d9756753773896691a77ff6a5bf7ef183122f5d04f022'
'8d0327615c6b6a340122640a9ddeb56be185621297a4ead8da4211e37feeaa75'
'412c675fd60e78785e7dfedafa4982d999ea5797c65580d6465e53288ad3000e'
'64f50a097a69c37ea07ad5ddf01f8342a97a786174382907922d7d22c1d88fc6'
'56034f14437842e3182252cebbd824f7845affb4af9c2af41de2528ea8cfa02d'

View file

@ -1513,6 +1513,21 @@ index cb05c6c4315..bd5566b03e7 100644
{{symbol_export}}extern const blink::QualifiedName& {{attr|symbol}}Attr;
{% endfor %}
diff --git a/chromium/third_party/dawn/generator/generator_lib.py b/chromium/third_party/dawn/generator/generator_lib.py
index 5e3734d7833..e3d46bd194f 100644
--- a/chromium/third_party/dawn/generator/generator_lib.py
+++ b/chromium/third_party/dawn/generator/generator_lib.py
@@ -201,6 +201,10 @@ def _compute_python_dependencies(root_dir=None):
paths = set()
for path in module_paths:
+ # Builtin/namespaced modules may return None for the file path.
+ if not path:
+ continue
+
path = os.path.abspath(path)
if not path.startswith(root_dir):
diff --git a/chromium/third_party/devtools-frontend/src/BUILD.gn b/chromium/third_party/devtools-frontend/src/BUILD.gn
index cd488e88b60..ea1dc3d9a79 100644
--- a/chromium/third_party/devtools-frontend/src/BUILD.gn