mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/pulseaudio to 15.0-1.1
This commit is contained in:
parent
a7dcc17bc5
commit
943c90d8c4
2 changed files with 5 additions and 38 deletions
|
@ -1,24 +0,0 @@
|
|||
From 5e83594fa0f7e18747030684f4de512052f2df56 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 12 Sep 2019 05:44:39 -0600
|
||||
Subject: [PATCH] disable neon
|
||||
|
||||
---
|
||||
src/pulsecore/meson.build | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/src/pulsecore/meson.build b/src/pulsecore/meson.build
|
||||
index d7f9ef2cf..933d1de0e 100644
|
||||
--- a/src/pulsecore/meson.build
|
||||
+++ b/src/pulsecore/meson.build
|
||||
@@ -175,7 +175,6 @@ simd = import('unstable-simd')
|
||||
simd_variants = [
|
||||
{ 'mmx' : ['remap_mmx.c', 'svolume_mmx.c'] },
|
||||
{ 'sse' : ['remap_sse.c', 'sconv_sse.c', 'svolume_sse.c'] },
|
||||
- { 'neon' : ['remap_neon.c', 'sconv_neon.c', 'mix_neon.c'] },
|
||||
]
|
||||
|
||||
libpulsecore_simd_lib = []
|
||||
--
|
||||
2.30.0
|
||||
|
|
@ -1,26 +1,22 @@
|
|||
# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to remove meson NEON check
|
||||
# - remove makedepend on valgrind, meson with -D valgrind=disabled
|
||||
# remove when bumped upstream
|
||||
|
||||
pkgbase=pulseaudio
|
||||
pkgname=(pulseaudio libpulse pulseaudio-{zeroconf,lirc,jack,bluetooth,equalizer,rtp})
|
||||
pkgdesc="A featureful, general-purpose sound server"
|
||||
pkgver=15.0
|
||||
pkgrel=1
|
||||
pkgrel=1.1
|
||||
arch=(x86_64)
|
||||
url="https://www.freedesktop.org/wiki/Software/PulseAudio/"
|
||||
license=(GPL)
|
||||
makedepends=(libasyncns libcap attr libxtst libsm libsndfile rtkit libsoxr
|
||||
speexdsp tdb systemd dbus avahi bluez bluez-libs jack2 sbc
|
||||
lirc openssl fftw orc gtk3 webrtc-audio-processing check git meson
|
||||
xmltoman doxygen)
|
||||
xmltoman valgrind doxygen)
|
||||
_commit=6329a2498eb038f8a9537888280a62b00a93f68e # tags/v15.0^0
|
||||
source=("git+https://gitlab.freedesktop.org/pulseaudio/pulseaudio.git#commit=$_commit"
|
||||
'0001-disable-neon.patch')
|
||||
sha256sums=('SKIP'
|
||||
'a6fc3a127aa8523b9b88f53217aeae01fb1831f33e265b9e1e233c3db2a97cf2')
|
||||
source=("git+https://gitlab.freedesktop.org/pulseaudio/pulseaudio.git#commit=$_commit")
|
||||
sha256sums=('SKIP')
|
||||
|
||||
pkgver() {
|
||||
cd pulseaudio
|
||||
|
@ -32,10 +28,6 @@ prepare() {
|
|||
|
||||
# Freeze version before patching
|
||||
./git-version-gen doesnt-exist >.tarball-version
|
||||
|
||||
if [[ $CARCH != "aarch64" ]]; then
|
||||
patch -p1 -i ../0001-disable-neon.patch
|
||||
fi
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -46,7 +38,6 @@ build() {
|
|||
-D bluez5-gstreamer=disabled
|
||||
-D elogind=disabled
|
||||
-D tcpwrap=disabled
|
||||
-D valgrind=disabled
|
||||
)
|
||||
|
||||
arch-meson pulseaudio build "${meson_options[@]}"
|
||||
|
|
Loading…
Reference in a new issue