core/icu to 73.2-2

This commit is contained in:
Kevin Mihelich 2023-07-17 12:28:09 +00:00
parent 285a2065a7
commit 944e713f3a
2 changed files with 29 additions and 1 deletions

25
core/icu/ICU-22132.patch Normal file
View file

@ -0,0 +1,25 @@
diff -u a/i18n/vtzone.cpp a/i18n/vtzone.cpp
--- a/i18n/vtzone.cpp 2023-07-14 09:05:38.000000000 +0100
+++ b/i18n/vtzone.cpp 2023-07-14 09:05:38.000000000 +0100
@@ -1735,14 +1735,14 @@
}
}
} else {
- UnicodeString icutzprop;
- UVector customProps(nullptr, uhash_compareUnicodeString, status);
+ UVector customProps(uprv_deleteUObject, uhash_compareUnicodeString, status);
if (olsonzid.length() > 0 && icutzver.length() > 0) {
- icutzprop.append(olsonzid);
- icutzprop.append(u'[');
- icutzprop.append(icutzver);
- icutzprop.append(u']');
- customProps.addElement(&icutzprop, status);
+ LocalPointer<UnicodeString> icutzprop(new UnicodeString(ICU_TZINFO_PROP), status);
+ icutzprop->append(olsonzid);
+ icutzprop->append(u'[');
+ icutzprop->append(icutzver);
+ icutzprop->append(u']');
+ customProps.adoptElement(icutzprop.orphan(), status);
}
writeZone(writer, *tz, &customProps, status);
}

View file

@ -7,7 +7,7 @@
pkgname=icu
pkgver=73.2
pkgrel=1
pkgrel=2
pkgdesc="International Components for Unicode library"
arch=(x86_64)
url="https://icu.unicode.org"
@ -16,10 +16,12 @@ depends=('gcc-libs' 'glibc' 'sh')
makedepends=('python')
provides=(libicu{data,i18n,io,test,tu,uc}.so)
source=(https://github.com/unicode-org/icu/releases/download/release-${pkgver//./-}/${pkgname}4c-${pkgver//./_}-src.tgz{,.asc}
ICU-22132.patch
icudata-stdlibs.patch)
# https://github.com/unicode-org/icu/releases/download/release-73-2/SHASUM512.txt
sha512sums=('76dd782db6205833f289d7eb68b60860dddfa3f614f0ba03fe7ec13117077f82109f0dc1becabcdf4c8a9c628b94478ab0a46134bdb06f4302be55f74027ce62'
'SKIP'
'1178062ccfcf7ecc698c64132b3612e73f9c4b0bbfaa668ae2039f3eb4cb2722d0b08a9f45b057da10def7a308d5c8d14c0c644892e7f11092c9cc488c850ab7'
'8f13898c2b2d69ef516ee0831a73e5865676795716e7becac4457e208642bfdffb42f2a9280e99dcc10303ad721f5dc2e10ef83c633bd723044e98cc72c6bc7b')
#validpgpkeys=('BA90283A60D67BA0DD910A893932080F4FB419E3') # "Steven R. Loomis (filfla-signing) <srloomis@us.ibm.com>"
#validpgpkeys+=('9731166CD8E23A83BEE7C6D3ACA5DBE1FD8FABF1') # "Steven R. Loomis (ICU Project) <srl@icu-project.org>"
@ -32,6 +34,7 @@ validpgpkeys=('3DA35301A7C330257B8755754058F67406EAA6AB') # Craig Cornelius <cco
prepare() {
cd icu/source
patch -Np1 < "../../ICU-22132.patch"
patch -p2 -i ${srcdir}/icudata-stdlibs.patch
sed -r -i 's/(for ac_prog in )clang(\+\+)? /\1/g' configure
}