mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
extra/ncmpcpp to 0.9.2-15
This commit is contained in:
parent
ebf4af162b
commit
94546df1fd
3 changed files with 53 additions and 5 deletions
|
@ -1,7 +1,7 @@
|
|||
pkgbase = ncmpcpp
|
||||
pkgdesc = Almost exact clone of ncmpc with some new features
|
||||
pkgver = 0.9.2
|
||||
pkgrel = 14
|
||||
pkgrel = 15
|
||||
url = https://ncmpcpp.rybczak.net/
|
||||
arch = x86_64
|
||||
license = GPL
|
||||
|
@ -28,7 +28,10 @@ pkgbase = ncmpcpp
|
|||
depends = libreadline.so
|
||||
depends = taglib
|
||||
source = https://rybczak.net/ncmpcpp/stable/ncmpcpp-0.9.2.tar.bz2
|
||||
source = taglib-2.patch
|
||||
sha512sums = bbcb3b50233e363412af3c1cf1c0118122733dc376759cd35dee79950f42e098a0402ff670684df91847b990b26022630c9a71192e462bd46e70628e31489742
|
||||
sha512sums = fff2987f193bb0d0423b32d81d79dda4c8dd451f701b587a3456867387697736381e4e09489ea852f648449c8a0ec9fbb386f74b7207249abf12dfd4a8f54f36
|
||||
b2sums = 160597493b93bac790b8619881e8a1fcf0efce4a538e35f54f31b06f3ed66691f02b37198cca46b475b7296aebbc864cb62a4398c60bd1e43907f9907a9bc118
|
||||
b2sums = 7e45e21e493d3da4039ac27f1f3158cdc244b6df369d7a452f770ac068ae2635d60a9ea19f166f3f6eaa5a766f25a6ed76edd83c8700c0f53b492b170b806320
|
||||
|
||||
pkgname = ncmpcpp
|
||||
|
|
|
@ -11,7 +11,7 @@
|
|||
|
||||
pkgname=ncmpcpp
|
||||
pkgver=0.9.2
|
||||
pkgrel=14
|
||||
pkgrel=15
|
||||
pkgdesc='Almost exact clone of ncmpc with some new features'
|
||||
url='https://ncmpcpp.rybczak.net/'
|
||||
arch=('x86_64')
|
||||
|
@ -21,12 +21,16 @@ depends=('curl' 'libcurl.so' 'libmpdclient' 'libmpdclient.so' 'fftw' 'libfftw3.s
|
|||
'libboost_thread.so' 'icu' 'libicui18n.so' 'libicuuc.so'
|
||||
'glibc' 'gcc-libs' 'ncurses' 'libncursesw.so' 'readline' 'libreadline.so' 'taglib')
|
||||
makedepends=('boost')
|
||||
source=(https://rybczak.net/ncmpcpp/stable/${pkgname}-${pkgver}.tar.bz2)
|
||||
sha512sums=('bbcb3b50233e363412af3c1cf1c0118122733dc376759cd35dee79950f42e098a0402ff670684df91847b990b26022630c9a71192e462bd46e70628e31489742')
|
||||
b2sums=('160597493b93bac790b8619881e8a1fcf0efce4a538e35f54f31b06f3ed66691f02b37198cca46b475b7296aebbc864cb62a4398c60bd1e43907f9907a9bc118')
|
||||
source=(https://rybczak.net/ncmpcpp/stable/${pkgname}-${pkgver}.tar.bz2
|
||||
taglib-2.patch)
|
||||
sha512sums=('bbcb3b50233e363412af3c1cf1c0118122733dc376759cd35dee79950f42e098a0402ff670684df91847b990b26022630c9a71192e462bd46e70628e31489742'
|
||||
'fff2987f193bb0d0423b32d81d79dda4c8dd451f701b587a3456867387697736381e4e09489ea852f648449c8a0ec9fbb386f74b7207249abf12dfd4a8f54f36')
|
||||
b2sums=('160597493b93bac790b8619881e8a1fcf0efce4a538e35f54f31b06f3ed66691f02b37198cca46b475b7296aebbc864cb62a4398c60bd1e43907f9907a9bc118'
|
||||
'7e45e21e493d3da4039ac27f1f3158cdc244b6df369d7a452f770ac068ae2635d60a9ea19f166f3f6eaa5a766f25a6ed76edd83c8700c0f53b492b170b806320')
|
||||
|
||||
prepare() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
patch -p1 -i ../taglib-2.patch
|
||||
autoreconf -fiv
|
||||
sed -i 's/-march=native//' extras/Makefile
|
||||
sed -e 's/CXXFLAGS=/CXXFLAGS+=/' \
|
||||
|
|
41
extra/ncmpcpp/taglib-2.patch
Normal file
41
extra/ncmpcpp/taglib-2.patch
Normal file
|
@ -0,0 +1,41 @@
|
|||
diff --git a/extras/artist_to_albumartist.cpp b/extras/artist_to_albumartist.cpp
|
||||
index c3ddfee3..bf5aac29 100644
|
||||
--- a/extras/artist_to_albumartist.cpp
|
||||
+++ b/extras/artist_to_albumartist.cpp
|
||||
@@ -34,7 +34,7 @@ enum class CopyResult { Success, NoArtist, AlbumArtistAlreadyInPlace };
|
||||
bool is_framelist_empty(const TagLib::ID3v2::FrameList &list)
|
||||
{
|
||||
for (auto it = list.begin(); it != list.end(); ++it)
|
||||
- if ((*it)->toString() != TagLib::String::null)
|
||||
+ if ((*it)->toString() != TagLib::String())
|
||||
return false;
|
||||
return true;
|
||||
}
|
||||
diff --git a/src/tags.cpp b/src/tags.cpp
|
||||
index 6cd6a8c2..09731801 100644
|
||||
--- a/src/tags.cpp
|
||||
+++ b/src/tags.cpp
|
||||
@@ -123,12 +123,12 @@ void writeCommonTags(const MPD::MutableSong &s, TagLib::Tag *tag)
|
||||
tag->setArtist(ToWString(s.getArtist()));
|
||||
tag->setAlbum(ToWString(s.getAlbum()));
|
||||
try {
|
||||
- tag->setYear(boost::lexical_cast<TagLib::uint>(s.getDate()));
|
||||
+ tag->setYear(boost::lexical_cast<uint>(s.getDate()));
|
||||
} catch (boost::bad_lexical_cast &) {
|
||||
std::cerr << "writeCommonTags: couldn't write 'year' tag to '" << s.getURI() << "' as it's not a positive integer\n";
|
||||
}
|
||||
try {
|
||||
- tag->setTrack(boost::lexical_cast<TagLib::uint>(s.getTrack()));
|
||||
+ tag->setTrack(boost::lexical_cast<uint>(s.getTrack()));
|
||||
} catch (boost::bad_lexical_cast &) {
|
||||
std::cerr << "writeCommonTags: couldn't write 'track' tag to '" << s.getURI() << "' as it's not a positive integer\n";
|
||||
}
|
||||
@@ -306,7 +306,7 @@ bool write(MPD::MutableSong &s)
|
||||
{
|
||||
writeID3v2Tags(s, mpeg_file->ID3v2Tag(true));
|
||||
// write id3v2.4 tags only
|
||||
- if (!mpeg_file->save(TagLib::MPEG::File::ID3v2, true, 4, false))
|
||||
+ if (!mpeg_file->save(TagLib::MPEG::File::ID3v2, TagLib::File::StripTags::StripNone, TagLib::ID3v2::Version::v4, TagLib::File::DuplicateTags::DoNotDuplicate))
|
||||
return false;
|
||||
// do not call generic save() as it will duplicate tags
|
||||
saved = true;
|
Loading…
Reference in a new issue