mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
community/tigervnc to 1.3.1-5
This commit is contained in:
parent
c60facb575
commit
945f7cdd72
2 changed files with 29 additions and 7 deletions
|
@ -7,7 +7,7 @@
|
|||
|
||||
pkgname=tigervnc
|
||||
pkgver=1.3.1
|
||||
pkgrel=4
|
||||
pkgrel=5
|
||||
_xorgver=1.16.0
|
||||
pkgdesc="Suite of VNC servers and clients. Based on the VNC 4 branch of TightVNC."
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -37,7 +37,7 @@ md5sums=('e80b16aa74f1d8e89f284a6aef99955d'
|
|||
'22f1523a0eca56ad79cfabd0db6e2cf6'
|
||||
'e056a2502dfe0cb3b02e08cab689482f'
|
||||
'e212f9d268a62af0349183a495bc55a5'
|
||||
'8b735b553efedd34cdeafc600be50a2a')
|
||||
'948218a19eac135484267d9990502bf6')
|
||||
|
||||
prepare() {
|
||||
cd ${srcdir}/${pkgname}-${pkgver}
|
||||
|
@ -71,7 +71,7 @@ build() {
|
|||
--disable-xwin --disable-xephyr --disable-kdrive --disable-xwayland \
|
||||
--disable-config-hal --disable-config-udev --with-pic \
|
||||
--disable-unit-tests --disable-devel-docs --disable-selective-werror \
|
||||
--disable-dri --enable-dri2 --disable-dri3 --enable-glx --enable-glx-tls
|
||||
--disable-dri --enable-dri2 --enable-dri3 --enable-glx --enable-glx-tls
|
||||
make
|
||||
}
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
diff -ur xorg-server-1.16.0.orig/configure.ac xorg-server-1.16.0/configure.ac
|
||||
--- xorg-server-1.16.0.orig/configure.ac 2014-07-17 09:00:51.000000000 +0200
|
||||
+++ xorg-server-1.16.0/configure.ac 2014-07-19 00:46:53.492489158 +0200
|
||||
+++ xorg-server-1.16.0/configure.ac 2014-08-04 20:43:26.856687998 +0200
|
||||
@@ -74,6 +74,7 @@
|
||||
AC_CONFIG_HEADERS(include/version-config.h)
|
||||
|
||||
|
@ -47,7 +47,7 @@ diff -ur xorg-server-1.16.0.orig/configure.ac xorg-server-1.16.0/configure.ac
|
|||
hw/xwin/Makefile
|
||||
diff -ur xorg-server-1.16.0.orig/hw/Makefile.am xorg-server-1.16.0/hw/Makefile.am
|
||||
--- xorg-server-1.16.0.orig/hw/Makefile.am 2014-04-16 22:24:00.000000000 +0200
|
||||
+++ xorg-server-1.16.0/hw/Makefile.am 2014-07-19 00:46:53.492489158 +0200
|
||||
+++ xorg-server-1.16.0/hw/Makefile.am 2014-08-04 20:43:26.856687998 +0200
|
||||
@@ -38,7 +38,8 @@
|
||||
$(DMX_SUBDIRS) \
|
||||
$(KDRIVE_SUBDIRS) \
|
||||
|
@ -60,7 +60,7 @@ diff -ur xorg-server-1.16.0.orig/hw/Makefile.am xorg-server-1.16.0/hw/Makefile.a
|
|||
|
||||
diff -ur xorg-server-1.16.0.orig/mi/miinitext.c xorg-server-1.16.0/mi/miinitext.c
|
||||
--- xorg-server-1.16.0.orig/mi/miinitext.c 2014-04-16 22:24:00.000000000 +0200
|
||||
+++ xorg-server-1.16.0/mi/miinitext.c 2014-07-19 00:46:53.492489158 +0200
|
||||
+++ xorg-server-1.16.0/mi/miinitext.c 2014-08-04 20:43:26.856687998 +0200
|
||||
@@ -111,6 +111,10 @@
|
||||
#include "micmap.h"
|
||||
#include "globals.h"
|
||||
|
@ -84,7 +84,7 @@ diff -ur xorg-server-1.16.0.orig/mi/miinitext.c xorg-server-1.16.0/mi/miinitext.
|
|||
#ifdef MITSHM
|
||||
diff -ur xorg-server-1.16.0.orig/os/WaitFor.c xorg-server-1.16.0/os/WaitFor.c
|
||||
--- xorg-server-1.16.0.orig/os/WaitFor.c 2014-02-05 04:08:57.000000000 +0100
|
||||
+++ xorg-server-1.16.0/os/WaitFor.c 2014-07-19 00:46:53.493489158 +0200
|
||||
+++ xorg-server-1.16.0/os/WaitFor.c 2014-08-04 20:44:26.350690385 +0200
|
||||
@@ -125,6 +125,9 @@
|
||||
static void CheckAllTimers(void);
|
||||
static OsTimerPtr timers = NULL;
|
||||
|
@ -113,3 +113,25 @@ diff -ur xorg-server-1.16.0.orig/os/WaitFor.c xorg-server-1.16.0/os/WaitFor.c
|
|||
BlockHandler((void *) &wt, (void *) &LastSelectMask);
|
||||
if (NewOutputPending)
|
||||
FlushAllOutput();
|
||||
@@ -223,10 +230,20 @@
|
||||
i = Select(MaxClients, &LastSelectMask, &clientsWritable, NULL, wt);
|
||||
}
|
||||
else {
|
||||
- i = Select(MaxClients, &LastSelectMask, NULL, NULL, wt);
|
||||
+ if (AnyClientsWriteBlocked)
|
||||
+ XFD_ORSET(&socketsWritable, &ClientsWriteBlocked, &socketsWritable);
|
||||
+
|
||||
+ if (XFD_ANYSET(&socketsWritable)) {
|
||||
+ i = Select (MaxClients, &LastSelectMask, &socketsWritable, NULL, wt);
|
||||
+ if (AnyClientsWriteBlocked)
|
||||
+ XFD_ANDSET(&clientsWritable, &socketsWritable, &ClientsWriteBlocked);
|
||||
+ } else {
|
||||
+ i = Select (MaxClients, &LastSelectMask, NULL, NULL, wt);
|
||||
+ }
|
||||
}
|
||||
selecterr = GetErrno();
|
||||
WakeupHandler(i, (void *) &LastSelectMask);
|
||||
+ vncWriteWakeupHandler(i, &socketsWritable);
|
||||
if (i <= 0) { /* An error or timeout occurred */
|
||||
if (dispatchException)
|
||||
return 0;
|
||||
|
|
Loading…
Reference in a new issue