mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
alarm/devtools-alarm to 20190329-1
This commit is contained in:
parent
11734c841d
commit
9556cc3da5
8 changed files with 65 additions and 60 deletions
|
@ -1,4 +1,4 @@
|
||||||
From 13c5f51de8bb77778ce5104c689813320e81611d Mon Sep 17 00:00:00 2001
|
From c0ca6a67467d082996d1343dca2665d5eb3e585f Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Sun, 28 Dec 2014 22:25:58 -0700
|
Date: Sun, 28 Dec 2014 22:25:58 -0700
|
||||||
Subject: [PATCH 1/7] makechrootpkg: cache dir
|
Subject: [PATCH 1/7] makechrootpkg: cache dir
|
||||||
|
@ -8,7 +8,7 @@ Subject: [PATCH 1/7] makechrootpkg: cache dir
|
||||||
1 file changed, 8 insertions(+), 2 deletions(-)
|
1 file changed, 8 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/makechrootpkg.in b/makechrootpkg.in
|
diff --git a/makechrootpkg.in b/makechrootpkg.in
|
||||||
index d81be84..8e8e4f5 100644
|
index dc647b3..a73d494 100644
|
||||||
--- a/makechrootpkg.in
|
--- a/makechrootpkg.in
|
||||||
+++ b/makechrootpkg.in
|
+++ b/makechrootpkg.in
|
||||||
@@ -38,6 +38,7 @@ usage() {
|
@@ -38,6 +38,7 @@ usage() {
|
||||||
|
@ -19,7 +19,7 @@ index d81be84..8e8e4f5 100644
|
||||||
echo '-d <dir> Bind directory into build chroot as read-write'
|
echo '-d <dir> Bind directory into build chroot as read-write'
|
||||||
echo '-D <dir> Bind directory into build chroot as read-only'
|
echo '-D <dir> Bind directory into build chroot as read-only'
|
||||||
echo '-u Update the working copy of the chroot before building'
|
echo '-u Update the working copy of the chroot before building'
|
||||||
@@ -325,12 +326,13 @@ main() {
|
@@ -321,12 +322,13 @@ main() {
|
||||||
[[ -z "$copy" || $copy = root ]] && copy=copy
|
[[ -z "$copy" || $copy = root ]] && copy=copy
|
||||||
src_owner=${SUDO_USER:-$USER}
|
src_owner=${SUDO_USER:-$USER}
|
||||||
|
|
||||||
|
@ -34,7 +34,7 @@ index d81be84..8e8e4f5 100644
|
||||||
r) passeddir="$OPTARG" ;;
|
r) passeddir="$OPTARG" ;;
|
||||||
I) install_pkgs+=("$OPTARG") ;;
|
I) install_pkgs+=("$OPTARG") ;;
|
||||||
l) copy="$OPTARG" ;;
|
l) copy="$OPTARG" ;;
|
||||||
@@ -352,6 +354,10 @@ main() {
|
@@ -348,6 +350,10 @@ main() {
|
||||||
[[ ! -d $chrootdir ]] && die "No chroot dir defined, or invalid path '%s'" "$passeddir"
|
[[ ! -d $chrootdir ]] && die "No chroot dir defined, or invalid path '%s'" "$passeddir"
|
||||||
[[ ! -d $chrootdir/root ]] && die "Missing chroot dir root directory. Try using: mkarchroot %s/root base-devel" "$chrootdir"
|
[[ ! -d $chrootdir/root ]] && die "Missing chroot dir root directory. Try using: mkarchroot %s/root base-devel" "$chrootdir"
|
||||||
|
|
||||||
|
@ -45,7 +45,7 @@ index d81be84..8e8e4f5 100644
|
||||||
if [[ ${copy:0:1} = / ]]; then
|
if [[ ${copy:0:1} = / ]]; then
|
||||||
copydir=$copy
|
copydir=$copy
|
||||||
else
|
else
|
||||||
@@ -415,7 +421,7 @@ main() {
|
@@ -411,7 +417,7 @@ main() {
|
||||||
|
|
||||||
prepare_chroot "$copydir" "$USER_HOME" "$keepbuilddir" "$run_namcap"
|
prepare_chroot "$copydir" "$USER_HOME" "$keepbuilddir" "$run_namcap"
|
||||||
|
|
||||||
|
@ -55,5 +55,5 @@ index d81be84..8e8e4f5 100644
|
||||||
--bind="$SRCDEST:/srcdest" \
|
--bind="$SRCDEST:/srcdest" \
|
||||||
"${bindmounts_ro[@]}" "${bindmounts_rw[@]}" \
|
"${bindmounts_ro[@]}" "${bindmounts_rw[@]}" \
|
||||||
--
|
--
|
||||||
2.16.2
|
2.21.0
|
||||||
|
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
From 39083133c9aa4851fda8fb5619a8a6c9ef519e70 Mon Sep 17 00:00:00 2001
|
From af376ba138e5dd4a8e4905f6c9f3f891714124d3 Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Sun, 28 Dec 2014 22:27:34 -0700
|
Date: Sun, 28 Dec 2014 22:27:34 -0700
|
||||||
Subject: [PATCH 2/7] arch-nspawn: keep mirrorlist
|
Subject: [PATCH 2/7] arch-nspawn: keep mirrorlist
|
||||||
|
@ -8,18 +8,18 @@ Subject: [PATCH 2/7] arch-nspawn: keep mirrorlist
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/arch-nspawn.in b/arch-nspawn.in
|
diff --git a/arch-nspawn.in b/arch-nspawn.in
|
||||||
index b9c846e..1821836 100644
|
index e68e2e7..a371625 100644
|
||||||
--- a/arch-nspawn.in
|
--- a/arch-nspawn.in
|
||||||
+++ b/arch-nspawn.in
|
+++ b/arch-nspawn.in
|
||||||
@@ -81,7 +81,7 @@ build_mount_args() {
|
@@ -83,7 +83,7 @@ build_mount_args() {
|
||||||
|
|
||||||
copy_hostconf () {
|
copy_hostconf () {
|
||||||
cp -a /etc/pacman.d/gnupg "$working_dir/etc/pacman.d"
|
cp -a /etc/pacman.d/gnupg "$working_dir/etc/pacman.d"
|
||||||
- echo "Server = $host_mirror" >"$working_dir/etc/pacman.d/mirrorlist"
|
- printf 'Server = %s\n' "${host_mirrors[@]}" >"$working_dir/etc/pacman.d/mirrorlist"
|
||||||
+ #echo "Server = $host_mirror" >"$working_dir/etc/pacman.d/mirrorlist"
|
+ #printf 'Server = %s\n' "${host_mirrors[@]}" >"$working_dir/etc/pacman.d/mirrorlist"
|
||||||
|
|
||||||
[[ -n $pac_conf ]] && cp "$pac_conf" "$working_dir/etc/pacman.conf"
|
[[ -n $pac_conf ]] && cp "$pac_conf" "$working_dir/etc/pacman.conf"
|
||||||
[[ -n $makepkg_conf ]] && cp "$makepkg_conf" "$working_dir/etc/makepkg.conf"
|
[[ -n $makepkg_conf ]] && cp "$makepkg_conf" "$working_dir/etc/makepkg.conf"
|
||||||
--
|
--
|
||||||
2.16.2
|
2.21.0
|
||||||
|
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
From 71c1a2307f07d6ddb10c876c532e92827b7eae2c Mon Sep 17 00:00:00 2001
|
From 900a616a281604f2efe097a7b5289b4ba4f61ede Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Sun, 28 Dec 2014 22:32:15 -0700
|
Date: Sun, 28 Dec 2014 22:32:15 -0700
|
||||||
Subject: [PATCH 3/7] makechrootpkg: distcc
|
Subject: [PATCH 3/7] makechrootpkg: distcc
|
||||||
|
@ -8,7 +8,7 @@ Subject: [PATCH 3/7] makechrootpkg: distcc
|
||||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/makechrootpkg.in b/makechrootpkg.in
|
diff --git a/makechrootpkg.in b/makechrootpkg.in
|
||||||
index 8e8e4f5..a920c19 100644
|
index a73d494..94e69ae 100644
|
||||||
--- a/makechrootpkg.in
|
--- a/makechrootpkg.in
|
||||||
+++ b/makechrootpkg.in
|
+++ b/makechrootpkg.in
|
||||||
@@ -226,7 +226,9 @@ _chrootbuild() {
|
@@ -226,7 +226,9 @@ _chrootbuild() {
|
||||||
|
@ -23,5 +23,5 @@ index 8e8e4f5..a920c19 100644
|
||||||
case $ret in
|
case $ret in
|
||||||
0|14)
|
0|14)
|
||||||
--
|
--
|
||||||
2.16.2
|
2.21.0
|
||||||
|
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
From 3c6ea948758d5ffd92e2412c8a9aa398607c140f Mon Sep 17 00:00:00 2001
|
From bc7c660f7598efb4de58c859f69aebecef6c7fd1 Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Sun, 28 Dec 2014 22:33:00 -0700
|
Date: Sun, 28 Dec 2014 22:33:00 -0700
|
||||||
Subject: [PATCH 4/7] arch-nspawn: arm fix
|
Subject: [PATCH 4/7] arch-nspawn: arm fix
|
||||||
|
@ -9,10 +9,10 @@ Subject: [PATCH 4/7] arch-nspawn: arm fix
|
||||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/arch-nspawn.in b/arch-nspawn.in
|
diff --git a/arch-nspawn.in b/arch-nspawn.in
|
||||||
index 1821836..fded89f 100644
|
index a371625..70944c8 100644
|
||||||
--- a/arch-nspawn.in
|
--- a/arch-nspawn.in
|
||||||
+++ b/arch-nspawn.in
|
+++ b/arch-nspawn.in
|
||||||
@@ -112,7 +112,7 @@ eval "$(grep -a '^CARCH=' "$working_dir/etc/makepkg.conf")"
|
@@ -114,7 +114,7 @@ eval "$(grep -a '^CARCH=' "$working_dir/etc/makepkg.conf")"
|
||||||
|
|
||||||
[[ -z $nosetarch ]] || unset CARCH
|
[[ -z $nosetarch ]] || unset CARCH
|
||||||
|
|
||||||
|
@ -22,18 +22,18 @@ index 1821836..fded89f 100644
|
||||||
-E "PATH=/usr/local/sbin:/usr/local/bin:/usr/bin" \
|
-E "PATH=/usr/local/sbin:/usr/local/bin:/usr/bin" \
|
||||||
--register=no --keep-unit --as-pid2 \
|
--register=no --keep-unit --as-pid2 \
|
||||||
diff --git a/makechrootpkg.in b/makechrootpkg.in
|
diff --git a/makechrootpkg.in b/makechrootpkg.in
|
||||||
index a920c19..bb561ea 100644
|
index 94e69ae..8322ee4 100644
|
||||||
--- a/makechrootpkg.in
|
--- a/makechrootpkg.in
|
||||||
+++ b/makechrootpkg.in
|
+++ b/makechrootpkg.in
|
||||||
@@ -260,7 +260,7 @@ download_sources() {
|
@@ -259,7 +259,7 @@ download_sources() {
|
||||||
# Ensure sources are downloaded
|
# Ensure sources are downloaded
|
||||||
sudo -u "$makepkg_user" --preserve-env=GNUPGHOME \
|
sudo -u "$makepkg_user" --preserve-env=GNUPGHOME \
|
||||||
env SRCDEST="$SRCDEST" BUILDDIR="$builddir" \
|
env SRCDEST="$SRCDEST" BUILDDIR="$WORKDIR" \
|
||||||
- makepkg --config="$copydir/etc/makepkg.conf" --verifysource -o ||
|
- makepkg --config="$copydir/etc/makepkg.conf" --verifysource -o ||
|
||||||
+ makepkg -A --config="$copydir/etc/makepkg.conf" --verifysource -o ||
|
+ makepkg -A --config="$copydir/etc/makepkg.conf" --verifysource -o ||
|
||||||
die "Could not download sources."
|
die "Could not download sources."
|
||||||
|
}
|
||||||
|
|
||||||
# Clean up garbage from verifysource
|
|
||||||
--
|
--
|
||||||
2.16.2
|
2.21.0
|
||||||
|
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
From 44a2b161185fc8ea89bde621badfcc3c2fc82c64 Mon Sep 17 00:00:00 2001
|
From 8ccfd5b76db9a6b87d041b4c366904000cc638a2 Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Sun, 28 Dec 2014 22:33:41 -0700
|
Date: Sun, 28 Dec 2014 22:33:41 -0700
|
||||||
Subject: [PATCH 5/7] makechrootpkg: no default logging
|
Subject: [PATCH 5/7] makechrootpkg: no default logging
|
||||||
|
@ -8,10 +8,10 @@ Subject: [PATCH 5/7] makechrootpkg: no default logging
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/makechrootpkg.in b/makechrootpkg.in
|
diff --git a/makechrootpkg.in b/makechrootpkg.in
|
||||||
index bb561ea..3ff3673 100644
|
index 8322ee4..c13890b 100644
|
||||||
--- a/makechrootpkg.in
|
--- a/makechrootpkg.in
|
||||||
+++ b/makechrootpkg.in
|
+++ b/makechrootpkg.in
|
||||||
@@ -307,7 +307,7 @@ move_products() {
|
@@ -303,7 +303,7 @@ move_products() {
|
||||||
# }}}
|
# }}}
|
||||||
|
|
||||||
main() {
|
main() {
|
||||||
|
@ -21,5 +21,5 @@ index bb561ea..3ff3673 100644
|
||||||
keepbuilddir=false
|
keepbuilddir=false
|
||||||
update_first=false
|
update_first=false
|
||||||
--
|
--
|
||||||
2.16.2
|
2.21.0
|
||||||
|
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
From d6bb1126569810ed4bdb895ad26f7a6b8e63419e Mon Sep 17 00:00:00 2001
|
From d41ddd4693db3f2b201ef87521faf760e86c1dbf Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Sun, 28 Dec 2014 22:34:04 -0700
|
Date: Sun, 28 Dec 2014 22:34:04 -0700
|
||||||
Subject: [PATCH 6/7] archbuild: no setarch
|
Subject: [PATCH 6/7] archbuild: no setarch
|
||||||
|
@ -8,7 +8,7 @@ Subject: [PATCH 6/7] archbuild: no setarch
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/archbuild.in b/archbuild.in
|
diff --git a/archbuild.in b/archbuild.in
|
||||||
index 1e5b582..fbfe8e7 100644
|
index bd5706d..a3982fc 100644
|
||||||
--- a/archbuild.in
|
--- a/archbuild.in
|
||||||
+++ b/archbuild.in
|
+++ b/archbuild.in
|
||||||
@@ -60,7 +60,7 @@ if ${clean_first} || [[ ! -d "${chroots}/${repo}-${arch}" ]]; then
|
@@ -60,7 +60,7 @@ if ${clean_first} || [[ ! -d "${chroots}/${repo}-${arch}" ]]; then
|
||||||
|
@ -21,5 +21,5 @@ index 1e5b582..fbfe8e7 100644
|
||||||
-M "@pkgdatadir@/makepkg-${arch}.conf" \
|
-M "@pkgdatadir@/makepkg-${arch}.conf" \
|
||||||
"${chroots}/${repo}-${arch}/root" \
|
"${chroots}/${repo}-${arch}/root" \
|
||||||
--
|
--
|
||||||
2.16.2
|
2.21.0
|
||||||
|
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
From cfbf534257c461056f670e86896c1e7ffeafabde Mon Sep 17 00:00:00 2001
|
From ad93f852bc62ef7a10b60ec7cf56ee1174e959da Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Sun, 3 Jul 2016 21:32:15 -0600
|
Date: Sun, 3 Jul 2016 21:32:15 -0600
|
||||||
Subject: [PATCH 7/7] makechrootpkg: don't delete MAKEFLAGS and PACKAGER
|
Subject: [PATCH 7/7] makechrootpkg: don't delete MAKEFLAGS and PACKAGER
|
||||||
|
@ -8,7 +8,7 @@ Subject: [PATCH 7/7] makechrootpkg: don't delete MAKEFLAGS and PACKAGER
|
||||||
1 file changed, 1 insertion(+), 3 deletions(-)
|
1 file changed, 1 insertion(+), 3 deletions(-)
|
||||||
|
|
||||||
diff --git a/makechrootpkg.in b/makechrootpkg.in
|
diff --git a/makechrootpkg.in b/makechrootpkg.in
|
||||||
index 3ff3673..b1e96af 100644
|
index c13890b..6035971 100644
|
||||||
--- a/makechrootpkg.in
|
--- a/makechrootpkg.in
|
||||||
+++ b/makechrootpkg.in
|
+++ b/makechrootpkg.in
|
||||||
@@ -184,9 +184,7 @@ prepare_chroot() {
|
@@ -184,9 +184,7 @@ prepare_chroot() {
|
||||||
|
@ -23,5 +23,5 @@ index 3ff3673..b1e96af 100644
|
||||||
grep -q "^$x" "$copydir/etc/makepkg.conf" && continue
|
grep -q "^$x" "$copydir/etc/makepkg.conf" && continue
|
||||||
echo "$x" >>"$copydir/etc/makepkg.conf"
|
echo "$x" >>"$copydir/etc/makepkg.conf"
|
||||||
--
|
--
|
||||||
2.16.2
|
2.21.0
|
||||||
|
|
||||||
|
|
|
@ -1,3 +1,4 @@
|
||||||
|
# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
|
||||||
# Maintainer: Pierre Schmitz <pierre@archlinux.de>
|
# Maintainer: Pierre Schmitz <pierre@archlinux.de>
|
||||||
|
|
||||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
|
@ -5,18 +6,19 @@
|
||||||
|
|
||||||
pkgname=devtools-alarm
|
pkgname=devtools-alarm
|
||||||
_pkgname=devtools
|
_pkgname=devtools
|
||||||
pkgver=20180531
|
pkgver=20190329
|
||||||
pkgrel=4
|
pkgrel=1
|
||||||
pkgdesc='Tools for Arch Linux ARM package maintainers'
|
pkgdesc='Tools for Arch Linux ARM package maintainers'
|
||||||
arch=('any')
|
arch=('any')
|
||||||
license=('GPL')
|
license=('GPL')
|
||||||
url='https://git.archlinux.org/devtools.git/'
|
url='https://git.archlinux.org/devtools.git/'
|
||||||
conflicts=('devtools')
|
conflicts=('devtools')
|
||||||
provides=('devtools')
|
provides=('devtools')
|
||||||
depends=('namcap' 'openssh' 'subversion' 'rsync' 'arch-install-scripts'
|
depends=('openssh' 'subversion' 'rsync' 'arch-install-scripts'
|
||||||
'git' 'bzr' 'mercurial')
|
'git' 'bzr' 'mercurial' 'diffutils')
|
||||||
|
makedepends=('asciidoc')
|
||||||
optdepends=('btrfs-progs: btrfs support')
|
optdepends=('btrfs-progs: btrfs support')
|
||||||
source=("https://sources.archlinux.org/other/$_pkgname/$_pkgname-$pkgver.tar.gz"{,.sig}
|
source=(https://sources.archlinux.org/other/${_pkgname}/${_pkgname}-${pkgver}.tar.gz{,.sig}
|
||||||
'0001-makechrootpkg-cache-dir.patch'
|
'0001-makechrootpkg-cache-dir.patch'
|
||||||
'0002-arch-nspawn-keep-mirrorlist.patch'
|
'0002-arch-nspawn-keep-mirrorlist.patch'
|
||||||
'0003-makechrootpkg-distcc.patch'
|
'0003-makechrootpkg-distcc.patch'
|
||||||
|
@ -31,34 +33,37 @@ validpgpkeys=('487EACC08557AD082088DABA1EB2638FF56C0C53'
|
||||||
'8218F88849AAC522E94CF470A5E9288C4FA415FA'
|
'8218F88849AAC522E94CF470A5E9288C4FA415FA'
|
||||||
'B81B051F2D7FC867AAFF35A58DBD63B82072D77A'
|
'B81B051F2D7FC867AAFF35A58DBD63B82072D77A'
|
||||||
'F3691687D867B81B51CE07D9BBE43771487328A9'
|
'F3691687D867B81B51CE07D9BBE43771487328A9'
|
||||||
'6645B0A8C7005E78DB1D7864F99FFE0FEAE999BD')
|
'6645B0A8C7005E78DB1D7864F99FFE0FEAE999BD'
|
||||||
md5sums=('ed3c757184e633faeea09747a7b91bb1'
|
'E240B57E2C4630BA768E2F26FC1B547C8D8172C8')
|
||||||
'SKIP'
|
sha256sums=('22f657a2489139f6213752836881415460853fe6eb9d1a84022931e66f98c45f'
|
||||||
'5233b5e7572c58810e3392ca03aa2394'
|
'SKIP'
|
||||||
'5bebd338b48d76b87c46175e034e3518'
|
'24b051855944acc377ab9c74481c2c434241e8ea51942f843a1ef875d459b0ba'
|
||||||
'bfba8bb3677ec381e2356ff7e4a70f24'
|
'ba23180de0e0b66a5286d0ab272ee5d0ba29a7bb553beefa0d303a45550aff37'
|
||||||
'2a46eb18fc4bb549099e5eda321a8f0d'
|
'3d6ea42aab993b839d59c951d7096965428919d56eede6bfc71e97cbac3c4e71'
|
||||||
'154a0953d8f2fc6e226ad0302e9f318f'
|
'c0b62e423ff4ec9801a7251c7a04ac780c313e949cb66d9f9421a51a87e56e56'
|
||||||
'91b9152cfa71911d55e0fff0b18c7e5b'
|
'86ed7e593a3caffd781a1e618d0e191173f064851694e263cdf50a6e6b16f61a'
|
||||||
'd92b4828159222c8aef0940b4cf13eaa')
|
'57c42af2b8af7d9140bac0a772d47168d74fff52de40f6580913a65baf3e885c'
|
||||||
|
'148caa91d60505327ec2c8ca118e91a7f3b497d2b3251e2f3512094e8a48c73d')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd "${_pkgname}-${pkgver}"
|
cd "${_pkgname}-${pkgver}"
|
||||||
patch -p1 -i ../0001-makechrootpkg-cache-dir.patch
|
patch -p1 -i ../0001-makechrootpkg-cache-dir.patch
|
||||||
patch -p1 -i ../0002-arch-nspawn-keep-mirrorlist.patch
|
patch -p1 -i ../0002-arch-nspawn-keep-mirrorlist.patch
|
||||||
patch -p1 -i ../0003-makechrootpkg-distcc.patch
|
patch -p1 -i ../0003-makechrootpkg-distcc.patch
|
||||||
patch -p1 -i ../0004-arch-nspawn-arm-fix.patch
|
patch -p1 -i ../0004-arch-nspawn-arm-fix.patch
|
||||||
patch -p1 -i ../0005-makechrootpkg-no-default-logging.patch
|
patch -p1 -i ../0005-makechrootpkg-no-default-logging.patch
|
||||||
patch -p1 -i ../0006-archbuild-no-setarch.patch
|
patch -p1 -i ../0006-archbuild-no-setarch.patch
|
||||||
patch -p1 -i ../0007-makechrootpkg-don-t-delete-MAKEFLAGS-and-PACKAGER.patch
|
patch -p1 -i ../0007-makechrootpkg-don-t-delete-MAKEFLAGS-and-PACKAGER.patch
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd "${_pkgname}-${pkgver}"
|
cd ${_pkgname}-${pkgver}
|
||||||
make PREFIX=/usr
|
make PREFIX=/usr
|
||||||
}
|
}
|
||||||
|
|
||||||
package() {
|
package() {
|
||||||
cd "${_pkgname}-${pkgver}"
|
cd ${_pkgname}-${pkgver}
|
||||||
make PREFIX=/usr DESTDIR="${pkgdir}" install
|
make PREFIX=/usr DESTDIR="${pkgdir}" install
|
||||||
}
|
}
|
||||||
|
|
||||||
|
# vim: ts=2 sw=2 et:
|
||||||
|
|
Loading…
Reference in a new issue