extra/gnome-builder to 3.18.1-2

This commit is contained in:
Kevin Mihelich 2015-10-16 00:45:43 +00:00
parent c5a37303d7
commit 95611df535
3 changed files with 66 additions and 2 deletions

View file

@ -6,7 +6,7 @@
pkgname=gnome-builder
pkgver=3.18.1
pkgrel=1
pkgrel=2
pkgdesc="An IDE for writing GNOME-based software"
url="https://wiki.gnome.org/Apps/Builder"
arch=(i686 x86_64)
@ -17,19 +17,24 @@ makedepends=(intltool llvm gobject-introspection)
groups=(gnome-extra)
install=gnome-builder.install
source=(http://download.gnome.org/sources/$pkgname/${pkgver:0:4}/$pkgname-$pkgver.tar.xz
git1.patch git2.patch
arm.patch)
sha256sums=('501c95220dcf8ca44a5748e863492377fe2c3aee78a95973d6819b1836e5407c'
'b1a7361c668762a390b63359bf9733e348a2d93c25709669a5eaae178e7127a8'
'a06214efcac9b14e2633c3d69b8a75df1f39f15a13f844d213d04c98c40dcd6d'
'e56bb096be7b6fae0725efa5846e2376177e12b6b0495e04c21c13d771c38b34')
prepare() {
cd $pkgname-$pkgver
patch -Np1 -i ../git1.patch
patch -Np1 -i ../git2.patch
patch -p1 -i ../arm.patch
}
build() {
cd $pkgname-$pkgver
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
--libexecdir=/usr/lib
--libexecdir=/usr/lib --enable-gtk-doc
make
}

View file

@ -0,0 +1,24 @@
From 48eeb9f7826e3ec492262f9ddb5d2b60a429740b Mon Sep 17 00:00:00 2001
From: Christian Hergert <chergert@redhat.com>
Date: Thu, 15 Oct 2015 08:36:52 -0700
Subject: build: install libide-1.0.pc into private directory
---
Makefile.am | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile.am b/Makefile.am
index 48e783e..90267e6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
SUBDIRS = . build contrib data libide src plugins po tools tests doc
-pkgconfigdir = $(libdir)/pkgconfig
+pkgconfigdir = $(libdir)/gnome-builder/pkgconfig
pkgconfig_DATA = $(top_builddir)/data/libide-1.0.pc
INTLTOOL_FILES = \
--
cgit v0.11.2

View file

@ -0,0 +1,35 @@
From 5392b7bab3db0373ca81ee9c541291d7ce05d45d Mon Sep 17 00:00:00 2001
From: Christian Hergert <chergert@redhat.com>
Date: Thu, 15 Oct 2015 08:37:20 -0700
Subject: vala: remove in-tree hack for builder deps
---
plugins/vala-pack/ide-vala-index.vala | 11 ++---------
1 file changed, 2 insertions(+), 9 deletions(-)
diff --git a/plugins/vala-pack/ide-vala-index.vala b/plugins/vala-pack/ide-vala-index.vala
index 56f9b34..093b5e9 100644
--- a/plugins/vala-pack/ide-vala-index.vala
+++ b/plugins/vala-pack/ide-vala-index.vala
@@ -90,16 +90,9 @@ namespace Ide
this.code_context.add_external_package ("glib-2.0");
this.code_context.add_external_package ("gobject-2.0");
- /* TODO: find packages from build system
- * the following is just to help us while writing vala in builder
- * until the build system works.
- */
- this.code_context.vapi_directories = new string[] { "libide", "src" };
+ /* TODO: find packages from build system */
this.code_context.add_external_package ("gio-2.0");
- this.code_context.add_external_package ("libvala-0.30");
- this.code_context.add_external_package ("libide-1.0");
- this.code_context.add_external_package ("gtksourceview-3.0");
- this.code_context.add_external_package ("gnome-builder-1.0");
+ this.code_context.add_external_package ("gtk+-3.0");
this.report = new Ide.ValaDiagnostics ();
this.code_context.report = this.report;
--
cgit v0.11.2