mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
added extra/qt6-doc
This commit is contained in:
parent
1bba2105e8
commit
957cfb861b
2 changed files with 93 additions and 0 deletions
75
extra/qt6-doc/PKGBUILD
Normal file
75
extra/qt6-doc/PKGBUILD
Normal file
|
@ -0,0 +1,75 @@
|
|||
# Maintainer: Antonio Rojas <arojas@archlinux.org>
|
||||
# Maintainer: Felix Yan <felixonmars@archlinux.org>
|
||||
# Contributor: Andrea Scarpino <andrea@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - explicitly link v5/v6 with libatomic
|
||||
|
||||
pkgbase=qt6-doc
|
||||
pkgname=(qt6-doc qt6-examples)
|
||||
_qtver=6.0.0
|
||||
pkgver=${_qtver/-/}
|
||||
pkgrel=1
|
||||
arch=('any')
|
||||
url='https://www.qt.io'
|
||||
license=(GPL3 LGPL3 FDL custom)
|
||||
makedepends=(cmake mariadb-libs unixodbc postgresql alsa-lib gst-plugins-base-libs
|
||||
gtk3 libpulse cups freetds vulkan-headers clang python llvm qt6-tools)
|
||||
groups=(qt6)
|
||||
_pkgfn="qt-everywhere-src-${_qtver}"
|
||||
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/single/${_pkgfn}.tar.xz"
|
||||
qt6-doc-bindir.patch)
|
||||
sha256sums=('d39a1a557a0dc8dc5ea2eaaee0fa015c71dcbb79c25a6aea421c594227565296'
|
||||
'60eebdf88559fefdb2b7c65b5f4ec091942aa1ffa371bedb4080545383b46109')
|
||||
|
||||
prepare() {
|
||||
patch -d $_pkgfn/qtbase -p1 -i ../../qt6-doc-bindir.patch # Use installed tools
|
||||
}
|
||||
|
||||
build() {
|
||||
[[ $CARCH == "arm" || $CARCH == "armv6h" ]] && echo "target_link_libraries(Core PRIVATE atomic)" >> ${_pkgfn}/qtbase/src/corelib/CMakeLists.txt
|
||||
cmake -B build -S $_pkgfn \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DINSTALL_BINDIR=lib/qt6/bin \
|
||||
-DINSTALL_DOCDIR=share/doc/qt6 \
|
||||
-DINSTALL_ARCHDATADIR=lib/qt6 \
|
||||
-DINSTALL_DATADIR=share/qt6 \
|
||||
-DINSTALL_INCLUDEDIR=include/qt6 \
|
||||
-DINSTALL_MKSPECSDIR=lib/qt6/mkspecs \
|
||||
-DINSTALL_EXAMPLESDIR=share/doc/qt6/examples \
|
||||
-DQT_FEATURE_journald=ON \
|
||||
-DQT_FEATURE_openssl_linked=ON
|
||||
cmake --build build --target docs
|
||||
}
|
||||
|
||||
package_qt6-doc() {
|
||||
pkgdesc='A cross-platform application and UI framework (Documentation)'
|
||||
DESTDIR="$pkgdir" cmake --build build --target install_docs
|
||||
|
||||
install -Dm644 $_pkgfn/LICENSE* -t "$pkgdir"/usr/share/licenses/$pkgbase
|
||||
}
|
||||
|
||||
package_qt6-examples() {
|
||||
pkgdesc='Examples and demos from qt6 documentation'
|
||||
depends=('qt6-doc')
|
||||
|
||||
_base="$pkgdir"/usr/share/doc/qt6/examples
|
||||
|
||||
# The various example dirs have conflicting .pro files, but
|
||||
# QtCreator requires them to be in the same top-level directory.
|
||||
# Matching the Qt5 installer, only the qtbase project is kept.
|
||||
mkdir -p $_base
|
||||
cp ${_pkgfn}/qtbase/examples/examples.pro $_base
|
||||
|
||||
_fdirs=$(find "${_pkgfn}" -maxdepth 2 -type d -name examples)
|
||||
for _dir in $_fdirs; do
|
||||
_mod=$(basename ${_dir%/examples})
|
||||
|
||||
if [ -e "$_dir/README" ]; then
|
||||
cp $_dir/README $_dir/README.$_mod
|
||||
fi
|
||||
|
||||
# mkdir $_base/$_mod
|
||||
cp -rn $_dir/* $_base
|
||||
done
|
||||
}
|
18
extra/qt6-doc/qt6-doc-bindir.patch
Normal file
18
extra/qt6-doc/qt6-doc-bindir.patch
Normal file
|
@ -0,0 +1,18 @@
|
|||
diff --git a/cmake/QtDocsHelpers.cmake b/cmake/QtDocsHelpers.cmake
|
||||
index 8e4bd28918..963114e1ec 100644
|
||||
--- a/cmake/QtDocsHelpers.cmake
|
||||
+++ b/cmake/QtDocsHelpers.cmake
|
||||
@@ -31,12 +31,7 @@ function(qt_internal_add_docs)
|
||||
return()
|
||||
endif()
|
||||
|
||||
- if(QT_SUPERBUILD)
|
||||
- set(doc_tools_dir "${QtBase_BINARY_DIR}/${INSTALL_BINDIR}")
|
||||
- else()
|
||||
- set(doc_tools_dir "${QT_BUILD_INTERNALS_RELOCATABLE_INSTALL_PREFIX}/${INSTALL_BINDIR}")
|
||||
- endif()
|
||||
-
|
||||
+ set(doc_tools_dir "/usr/lib/qt6/bin")
|
||||
set(qdoc_bin "${doc_tools_dir}/qdoc${CMAKE_EXECUTABLE_SUFFIX}")
|
||||
set(qtattributionsscanner_bin "${doc_tools_dir}/qtattributionsscanner${CMAKE_EXECUTABLE_SUFFIX}")
|
||||
set(qhelpgenerator_bin "${doc_tools_dir}/qhelpgenerator${CMAKE_EXECUTABLE_SUFFIX}")
|
Loading…
Reference in a new issue