mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
extra/x264: v8 fix
This commit is contained in:
parent
3919498c66
commit
96374bd203
2 changed files with 24 additions and 5 deletions
|
@ -5,7 +5,7 @@
|
|||
# Contributor: Paul Mattal <paul@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - configure needs --disable-asm to build on ARM
|
||||
# - configure needs --disable-asm to build on non-AArch64
|
||||
|
||||
pkgname=('x264' 'libx264' 'libx264-10bit')
|
||||
pkgver=144.20150223
|
||||
|
@ -16,8 +16,10 @@ url='http://www.videolan.org/developers/x264.html'
|
|||
license=('GPL')
|
||||
depends=('glibc')
|
||||
makedepends=('yasm' 'git' 'ffmpeg')
|
||||
source=(git://git.videolan.org/x264.git#commit=c8a773ebf)
|
||||
md5sums=('SKIP')
|
||||
source=(git://git.videolan.org/x264.git#commit=c8a773ebf
|
||||
'aarch64.patch')
|
||||
md5sums=('SKIP'
|
||||
'cfea784ff527edab0972a540660f4000')
|
||||
|
||||
pkgver() {
|
||||
cd $pkgname
|
||||
|
@ -28,19 +30,24 @@ pkgver() {
|
|||
}
|
||||
|
||||
prepare() {
|
||||
cd $pkgname
|
||||
patch -p1 -i ../aarch64.patch
|
||||
cd ..
|
||||
cp -r $pkgname $pkgname-10bit
|
||||
}
|
||||
|
||||
build() {
|
||||
[[ $CARCH != "aarch64" ]] && CONFIG="--disable-asm"
|
||||
|
||||
cd $pkgname
|
||||
./configure --prefix=/usr \
|
||||
--enable-shared --enable-pic --disable-asm
|
||||
--enable-shared --enable-pic $CONFIG
|
||||
make
|
||||
|
||||
cd ../$pkgname-10bit
|
||||
./configure --prefix=/usr \
|
||||
--enable-shared --enable-pic \
|
||||
--bit-depth=10 --disable-asm
|
||||
--bit-depth=10 $CONFIG
|
||||
make
|
||||
}
|
||||
|
||||
|
|
12
extra/x264/aarch64.patch
Normal file
12
extra/x264/aarch64.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -urN a/configure b/configure
|
||||
--- a/configure 2015-07-15 23:13:53.689889673 -0600
|
||||
+++ b/configure 2015-07-15 23:15:02.609508868 -0600
|
||||
@@ -789,7 +789,7 @@
|
||||
|
||||
if [ $asm = auto -a $ARCH = AARCH64 ] ; then
|
||||
# set flags so neon is built by default
|
||||
- echo $CFLAGS | grep -Eq '(-mcpu|-march|-mfpu|-arch)' || CFLAGS="$CFLAGS -arch arm64 -mfpu=neon"
|
||||
+ echo $CFLAGS | grep -Eq '(-mcpu|-march|-mfpu|-arch)' || CFLAGS="$CFLAGS"
|
||||
|
||||
if cc_check '' '' '__asm__("cmeq v0.8h, v0.8h, #0");' ; then define HAVE_NEON
|
||||
ASFLAGS="$ASFLAGS -c"
|
Loading…
Reference in a new issue