mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/pyqt5 to 5.10.1-3
This commit is contained in:
parent
1a091b93fb
commit
963e5eec43
3 changed files with 26 additions and 7 deletions
|
@ -11,7 +11,7 @@
|
|||
pkgbase=pyqt5
|
||||
pkgname=('pyqt5-common' 'python-pyqt5' 'python2-pyqt5')
|
||||
pkgver=5.10.1
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
arch=('x86_64')
|
||||
url="http://riverbankcomputing.co.uk/software/pyqt/intro"
|
||||
license=('GPL')
|
||||
|
@ -20,16 +20,18 @@ makedepends=('python-sip' 'python2-sip' 'python-opengl' 'python2-opengl'
|
|||
'qt5-multimedia' 'qt5-tools' 'qt5-serialport' 'qt5-svg'
|
||||
'qt5-webkit' 'qt5-websockets' 'qt5-x11extras' 'qt5-networkauth')
|
||||
source=("http://sourceforge.net/projects/pyqt/files/PyQt5/PyQt-$pkgver/PyQt5_gpl-$pkgver.tar.gz" pyqt-support-new-qt.patch
|
||||
pyqt5-cura-crash.patch)
|
||||
pyqt5-cura-crash.patch pyqt-qt5.11.patch)
|
||||
sha512sums=('04cd0292f7a088f9c0d088d7c73ec96cfc40253f771dfdf194eb92be7635e6fcaf04863fa24215e9c34a096658549bb2feeb8d8fdca1e39ed87f0256ef0f790b'
|
||||
'9e4184291c0ece0bf375da3e0cf6e3f22df33eea1ee2b981fe9e2a0ba7d625583dd513c029c49562189986c0145262ac2aa8e5aa85701a981b3ed4061f4acf36'
|
||||
'3f6e1c0dcd95d3ff39c03f59d7c09cbf2e42431bf9cb6dc7a63da10b7a387e5977992e57ef0ff1dea495f29dfbf4db2568b4588e801cca966a0136fe98d1ed45')
|
||||
'a9c45534d540cd4eff732a92e66f98eb313b0734e64a2289fbc703fdb208265a610ccc3c4f54f43d0813afa3a7003ec7956e6029904cc56992a5e8cc2efb280c'
|
||||
'3f6e1c0dcd95d3ff39c03f59d7c09cbf2e42431bf9cb6dc7a63da10b7a387e5977992e57ef0ff1dea495f29dfbf4db2568b4588e801cca966a0136fe98d1ed45'
|
||||
'bae60dd592701929acf403514d8be87d53330dccff74267efb615005d82f5710ce13636a99b2a75beb04fd93a4ade34486c3c2aa190efd334d01c78b34f1bcc0')
|
||||
|
||||
prepare() {
|
||||
# Support new versions of Qt - don't remove, needs to be reapplied after every new Qt release
|
||||
pushd PyQt5_gpl-$pkgver
|
||||
# patch -p1 -i ../pyqt-support-new-qt.patch
|
||||
patch -p1 -i ../pyqt-support-new-qt.patch
|
||||
patch -p1 -i ../pyqt5-cura-crash.patch # Fix crash in Cura
|
||||
patch -p1 -i ../pyqt-qt5.11.patch # Fix build with Qt 5.11 (opensuse)
|
||||
popd
|
||||
|
||||
# The additional include path was removed due to this line, I don't really know why they are doing this...
|
||||
|
|
17
extra/pyqt5/pyqt-qt5.11.patch
Normal file
17
extra/pyqt5/pyqt-qt5.11.patch
Normal file
|
@ -0,0 +1,17 @@
|
|||
From: Fabian Vogt <fabian@ritter-vogt.de>
|
||||
Subject: QTest::waitForEvents() is internal only
|
||||
|
||||
Must not be used, got removed with Qt 5.11.
|
||||
|
||||
Index: PyQt5_gpl-5.10.1/sip/QtTest/qtestmouse.sip
|
||||
===================================================================
|
||||
--- PyQt5_gpl-5.10.1.orig/sip/QtTest/qtestmouse.sip
|
||||
+++ PyQt5_gpl-5.10.1/sip/QtTest/qtestmouse.sip
|
||||
@@ -41,7 +41,6 @@ namespace QTest
|
||||
void mousePress(QWidget *widget, Qt::MouseButton button, Qt::KeyboardModifiers modifier = 0, QPoint pos = QPoint(), int delay = -1);
|
||||
void mouseRelease(QWidget *widget, Qt::MouseButton button, Qt::KeyboardModifiers modifier = 0, QPoint pos = QPoint(), int delay = -1);
|
||||
void mouseEvent(QTest::MouseAction action, QWidget *widget, Qt::MouseButton button, Qt::KeyboardModifiers modifier, QPoint pos, int delay = -1);
|
||||
- void waitForEvents() /ReleaseGIL/;
|
||||
void mouseEvent(QTest::MouseAction action, QWindow *window, Qt::MouseButton button, Qt::KeyboardModifiers modifier, QPoint pos, int delay = -1);
|
||||
void mousePress(QWindow *window, Qt::MouseButton button, Qt::KeyboardModifiers modifier = Qt::KeyboardModifiers(), QPoint pos = QPoint(), int delay = -1);
|
||||
void mouseRelease(QWindow *window, Qt::MouseButton button, Qt::KeyboardModifiers modifier = Qt::KeyboardModifiers(), QPoint pos = QPoint(), int delay = -1);
|
|
@ -5,8 +5,8 @@ diff -ru a/sip/QtCore/QtCoremod.sip b/sip/QtCore/QtCoremod.sip
|
|||
|
||||
%Module(name=PyQt5.QtCore, call_super_init=True, default_VirtualErrorHandler=PyQt5, keyword_arguments="Optional", use_limited_api=True)
|
||||
|
||||
-%Timeline {Qt_5_0_0 Qt_5_0_1 Qt_5_0_2 Qt_5_1_0 Qt_5_1_1 Qt_5_2_0 Qt_5_2_1 Qt_5_3_0 Qt_5_3_1 Qt_5_3_2 Qt_5_4_0 Qt_5_4_1 Qt_5_4_2 Qt_5_5_0 Qt_5_5_1 Qt_5_6_0 Qt_5_6_1 Qt_5_6_2 Qt_5_6_3 Qt_5_6_4 Qt_5_6_5 Qt_5_6_6 Qt_5_6_7 Qt_5_6_8 Qt_5_6_9 Qt_5_7_0 Qt_5_7_1 Qt_5_8_0 Qt_5_8_1 Qt_5_9_0 Qt_5_9_1 Qt_5_9_2 Qt_5_9_3 Qt_5_10_0}
|
||||
+%Timeline {Qt_5_0_0 Qt_5_0_1 Qt_5_0_2 Qt_5_1_0 Qt_5_1_1 Qt_5_2_0 Qt_5_2_1 Qt_5_3_0 Qt_5_3_1 Qt_5_3_2 Qt_5_4_0 Qt_5_4_1 Qt_5_4_2 Qt_5_5_0 Qt_5_5_1 Qt_5_6_0 Qt_5_6_1 Qt_5_6_2 Qt_5_6_3 Qt_5_6_4 Qt_5_6_5 Qt_5_6_6 Qt_5_6_7 Qt_5_6_8 Qt_5_6_9 Qt_5_7_0 Qt_5_7_1 Qt_5_8_0 Qt_5_8_1 Qt_5_9_0 Qt_5_9_1 Qt_5_9_2 Qt_5_9_3 Qt_5_10_0 Qt_5_10_1}
|
||||
-%Timeline {Qt_5_0_0 Qt_5_0_1 Qt_5_0_2 Qt_5_1_0 Qt_5_1_1 Qt_5_2_0 Qt_5_2_1 Qt_5_3_0 Qt_5_3_1 Qt_5_3_2 Qt_5_4_0 Qt_5_4_1 Qt_5_4_2 Qt_5_5_0 Qt_5_5_1 Qt_5_6_0 Qt_5_6_1 Qt_5_6_2 Qt_5_6_3 Qt_5_6_4 Qt_5_6_5 Qt_5_6_6 Qt_5_6_7 Qt_5_6_8 Qt_5_6_9 Qt_5_7_0 Qt_5_7_1 Qt_5_8_0 Qt_5_8_1 Qt_5_9_0 Qt_5_9_1 Qt_5_9_2 Qt_5_9_3 Qt_5_9_99 Qt_5_10_0 Qt_5_10_1}
|
||||
+%Timeline {Qt_5_0_0 Qt_5_0_1 Qt_5_0_2 Qt_5_1_0 Qt_5_1_1 Qt_5_2_0 Qt_5_2_1 Qt_5_3_0 Qt_5_3_1 Qt_5_3_2 Qt_5_4_0 Qt_5_4_1 Qt_5_4_2 Qt_5_5_0 Qt_5_5_1 Qt_5_6_0 Qt_5_6_1 Qt_5_6_2 Qt_5_6_3 Qt_5_6_4 Qt_5_6_5 Qt_5_6_6 Qt_5_6_7 Qt_5_6_8 Qt_5_6_9 Qt_5_7_0 Qt_5_7_1 Qt_5_8_0 Qt_5_8_1 Qt_5_9_0 Qt_5_9_1 Qt_5_9_2 Qt_5_9_3 Qt_5_9_99 Qt_5_10_0 Qt_5_10_1 Qt_5_11_0}
|
||||
|
||||
%Platforms {WS_X11 WS_WIN WS_MACX}
|
||||
|
||||
|
|
Loading…
Reference in a new issue