mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-06 23:47:10 +00:00
core/linux-veyron to 3.14.0-24
This commit is contained in:
parent
98fe4ad09a
commit
967974c274
7 changed files with 38 additions and 128 deletions
|
@ -1,7 +1,7 @@
|
|||
From c5a733c580e965955b293ecab06193461843f491 Mon Sep 17 00:00:00 2001
|
||||
From 478d6783c5483f4d2201bc0a91f92e7880df11cc Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 25 Jun 2015 20:35:06 -0600
|
||||
Subject: [PATCH 1/5] use chromiumos mwifiex drivers
|
||||
Subject: [PATCH 1/4] use chromiumos mwifiex drivers
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
|
@ -9,7 +9,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
|||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/drivers/net/wireless-3.8/mwifiex/sdio.h b/drivers/net/wireless-3.8/mwifiex/sdio.h
|
||||
index f9ee413..9686025 100644
|
||||
index f9ee413f6e71..9686025923c5 100644
|
||||
--- a/drivers/net/wireless-3.8/mwifiex/sdio.h
|
||||
+++ b/drivers/net/wireless-3.8/mwifiex/sdio.h
|
||||
@@ -30,9 +30,9 @@
|
||||
|
@ -26,5 +26,5 @@ index f9ee413..9686025 100644
|
|||
|
||||
#define BLOCK_MODE 1
|
||||
--
|
||||
2.10.2
|
||||
2.11.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From bde359ee42983c145ed4210c4d4ad0a95830da7c Mon Sep 17 00:00:00 2001
|
||||
From 4cc0eec56f57f137ac6ae3b91dbafa5541811644 Mon Sep 17 00:00:00 2001
|
||||
From: Bing Zhao <bzhao@marvell.com>
|
||||
Date: Mon, 19 Aug 2013 16:10:21 -0700
|
||||
Subject: [PATCH 2/5] mwifiex: do not create AP and P2P interfaces upon driver
|
||||
Subject: [PATCH 2/4] mwifiex: do not create AP and P2P interfaces upon driver
|
||||
loading
|
||||
|
||||
Bug 60747 - 1286:2044 [Microsoft Surface Pro]
|
||||
|
@ -35,7 +35,7 @@ Signed-off-by: Avinash Patil <patila@marvell.com>
|
|||
1 file changed, 16 deletions(-)
|
||||
|
||||
diff --git a/drivers/net/wireless-3.8/mwifiex/main.c b/drivers/net/wireless-3.8/mwifiex/main.c
|
||||
index e43afc1..587f4ae 100644
|
||||
index e43afc127119..587f4ae4818d 100644
|
||||
--- a/drivers/net/wireless-3.8/mwifiex/main.c
|
||||
+++ b/drivers/net/wireless-3.8/mwifiex/main.c
|
||||
@@ -523,22 +523,6 @@ static void mwifiex_fw_dpc(const struct firmware *firmware, void *context)
|
||||
|
@ -62,5 +62,5 @@ index e43afc1..587f4ae 100644
|
|||
|
||||
mwifiex_drv_get_driver_version(adapter, fmt, sizeof(fmt) - 1);
|
||||
--
|
||||
2.10.2
|
||||
2.11.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From fc3adbec0da5402a6a40291592b87cb91bd09ca9 Mon Sep 17 00:00:00 2001
|
||||
From b4ba27c1b3ba7e1405b9e3a12ff29f01f2e6d4ff Mon Sep 17 00:00:00 2001
|
||||
From: Heiko Stuebner <heiko@sntech.de>
|
||||
Date: Mon, 25 May 2015 16:38:07 +0200
|
||||
Subject: [PATCH 3/5] UPSTREAM: soc/rockchip: add handler for usb-uart
|
||||
Subject: [PATCH 3/4] UPSTREAM: soc/rockchip: add handler for usb-uart
|
||||
functionality
|
||||
|
||||
Some Rockchip SoCs provide the possibility to use a usb-phy as passthru for
|
||||
|
@ -25,7 +25,7 @@ Signed-off-by: Alexandru M Stan <amstan@chromium.org>
|
|||
create mode 100644 drivers/soc/rockchip/rockchip_usb_uart.c
|
||||
|
||||
diff --git a/drivers/soc/Kconfig b/drivers/soc/Kconfig
|
||||
index 1ee0b57..ad2f71ab 100644
|
||||
index 1ee0b57a2657..ad2f71abb64b 100644
|
||||
--- a/drivers/soc/Kconfig
|
||||
+++ b/drivers/soc/Kconfig
|
||||
@@ -2,6 +2,7 @@ menu "SOC (System On Chip) specific Drivers"
|
||||
|
@ -37,7 +37,7 @@ index 1ee0b57..ad2f71ab 100644
|
|||
|
||||
endmenu
|
||||
diff --git a/drivers/soc/Makefile b/drivers/soc/Makefile
|
||||
index bc43b87..d80386c 100644
|
||||
index bc43b874eee9..d80386c7c1d0 100644
|
||||
--- a/drivers/soc/Makefile
|
||||
+++ b/drivers/soc/Makefile
|
||||
@@ -4,4 +4,5 @@
|
||||
|
@ -48,7 +48,7 @@ index bc43b87..d80386c 100644
|
|||
obj-$(CONFIG_ARCH_TEGRA) += tegra/
|
||||
diff --git a/drivers/soc/rockchip/Kconfig b/drivers/soc/rockchip/Kconfig
|
||||
new file mode 100644
|
||||
index 0000000..24d4e05
|
||||
index 000000000000..24d4e0502d3e
|
||||
--- /dev/null
|
||||
+++ b/drivers/soc/rockchip/Kconfig
|
||||
@@ -0,0 +1,13 @@
|
||||
|
@ -67,14 +67,14 @@ index 0000000..24d4e05
|
|||
+ to the kernel commandline.
|
||||
diff --git a/drivers/soc/rockchip/Makefile b/drivers/soc/rockchip/Makefile
|
||||
new file mode 100644
|
||||
index 0000000..b5dd6f8
|
||||
index 000000000000..b5dd6f8fc3d8
|
||||
--- /dev/null
|
||||
+++ b/drivers/soc/rockchip/Makefile
|
||||
@@ -0,0 +1 @@
|
||||
+obj-$(CONFIG_ROCKCHIP_USB_UART) += rockchip_usb_uart.o
|
||||
diff --git a/drivers/soc/rockchip/rockchip_usb_uart.c b/drivers/soc/rockchip/rockchip_usb_uart.c
|
||||
new file mode 100644
|
||||
index 0000000..97754f9
|
||||
index 000000000000..97754f9fc7f2
|
||||
--- /dev/null
|
||||
+++ b/drivers/soc/rockchip/rockchip_usb_uart.c
|
||||
@@ -0,0 +1,223 @@
|
||||
|
@ -302,5 +302,5 @@ index 0000000..97754f9
|
|||
+}
|
||||
+early_param("rockchip.usb_uart", rockchip_usb_uart);
|
||||
--
|
||||
2.10.2
|
||||
2.11.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 946a8583ff41dbafab2cd2447702bd3aa0df81af Mon Sep 17 00:00:00 2001
|
||||
From e9d25d3d9e86de0ff89e9d9f9d32f97205e2afab Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 2 Jul 2015 17:48:41 -0600
|
||||
Subject: [PATCH 4/5] fix brcmfmac oops and race condition
|
||||
Subject: [PATCH 4/4] fix brcmfmac oops and race condition
|
||||
|
||||
This fixes a potential null pointer dereference by checking if null before
|
||||
freeing the vif struct.
|
||||
|
@ -18,7 +18,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
|||
1 file changed, 30 insertions(+), 17 deletions(-)
|
||||
|
||||
diff --git a/drivers/net/wireless-3.8/brcm80211/brcmfmac/dhd_common.c b/drivers/net/wireless-3.8/brcm80211/brcmfmac/dhd_common.c
|
||||
index 05d4042..7006d19 100644
|
||||
index 05d40426b85b..7006d19fb8d1 100644
|
||||
--- a/drivers/net/wireless-3.8/brcm80211/brcmfmac/dhd_common.c
|
||||
+++ b/drivers/net/wireless-3.8/brcm80211/brcmfmac/dhd_common.c
|
||||
@@ -252,25 +252,34 @@ int brcmf_c_preinit_dcmds(struct brcmf_if *ifp)
|
||||
|
@ -89,5 +89,5 @@ index 05d4042..7006d19 100644
|
|||
|
||||
/*
|
||||
--
|
||||
2.10.2
|
||||
2.11.0
|
||||
|
||||
|
|
|
@ -1,92 +0,0 @@
|
|||
From 0cce8f784e9e13abfe1d4b2af0c217bed9529fd0 Mon Sep 17 00:00:00 2001
|
||||
From: Philip Pettersson <philip.pettersson@gmail.com>
|
||||
Date: Wed, 30 Nov 2016 14:55:36 -0800
|
||||
Subject: [PATCH 5/5] packet: fix race condition in packet_set_ring
|
||||
|
||||
When packet_set_ring creates a ring buffer it will initialize a
|
||||
struct timer_list if the packet version is TPACKET_V3. This value
|
||||
can then be raced by a different thread calling setsockopt to
|
||||
set the version to TPACKET_V1 before packet_set_ring has finished.
|
||||
|
||||
This leads to a use-after-free on a function pointer in the
|
||||
struct timer_list when the socket is closed as the previously
|
||||
initialized timer will not be deleted.
|
||||
|
||||
The bug is fixed by taking lock_sock(sk) in packet_setsockopt when
|
||||
changing the packet version while also taking the lock at the start
|
||||
of packet_set_ring.
|
||||
|
||||
Fixes: f6fb8f100b80 ("af-packet: TPACKET_V3 flexible buffer implementation.")
|
||||
Signed-off-by: Philip Pettersson <philip.pettersson@gmail.com>
|
||||
Signed-off-by: Eric Dumazet <edumazet@google.com>
|
||||
Signed-off-by: David S. Miller <davem@davemloft.net>
|
||||
---
|
||||
net/packet/af_packet.c | 18 ++++++++++++------
|
||||
1 file changed, 12 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/net/packet/af_packet.c b/net/packet/af_packet.c
|
||||
index c434589..5ea0bff 100644
|
||||
--- a/net/packet/af_packet.c
|
||||
+++ b/net/packet/af_packet.c
|
||||
@@ -3280,19 +3280,25 @@ packet_setsockopt(struct socket *sock, int level, int optname, char __user *optv
|
||||
|
||||
if (optlen != sizeof(val))
|
||||
return -EINVAL;
|
||||
- if (po->rx_ring.pg_vec || po->tx_ring.pg_vec)
|
||||
- return -EBUSY;
|
||||
if (copy_from_user(&val, optval, sizeof(val)))
|
||||
return -EFAULT;
|
||||
switch (val) {
|
||||
case TPACKET_V1:
|
||||
case TPACKET_V2:
|
||||
case TPACKET_V3:
|
||||
- po->tp_version = val;
|
||||
- return 0;
|
||||
+ break;
|
||||
default:
|
||||
return -EINVAL;
|
||||
}
|
||||
+ lock_sock(sk);
|
||||
+ if (po->rx_ring.pg_vec || po->tx_ring.pg_vec) {
|
||||
+ ret = -EBUSY;
|
||||
+ } else {
|
||||
+ po->tp_version = val;
|
||||
+ ret = 0;
|
||||
+ }
|
||||
+ release_sock(sk);
|
||||
+ return ret;
|
||||
}
|
||||
case PACKET_RESERVE:
|
||||
{
|
||||
@@ -3755,6 +3761,7 @@ static int packet_set_ring(struct sock *sk, union tpacket_req_u *req_u,
|
||||
/* Added to avoid minimal code churn */
|
||||
struct tpacket_req *req = &req_u->req;
|
||||
|
||||
+ lock_sock(sk);
|
||||
/* Opening a Tx-ring is NOT supported in TPACKET_V3 */
|
||||
if (!closing && tx_ring && (po->tp_version > TPACKET_V2)) {
|
||||
WARN(1, "Tx-ring is not supported.\n");
|
||||
@@ -3832,7 +3839,6 @@ static int packet_set_ring(struct sock *sk, union tpacket_req_u *req_u,
|
||||
goto out;
|
||||
}
|
||||
|
||||
- lock_sock(sk);
|
||||
|
||||
/* Detach socket from network */
|
||||
spin_lock(&po->bind_lock);
|
||||
@@ -3881,11 +3887,11 @@ static int packet_set_ring(struct sock *sk, union tpacket_req_u *req_u,
|
||||
if (!tx_ring)
|
||||
prb_shutdown_retire_blk_timer(po, tx_ring, rb_queue);
|
||||
}
|
||||
- release_sock(sk);
|
||||
|
||||
if (pg_vec)
|
||||
free_pg_vec(pg_vec, order, req->tp_block_nr);
|
||||
out:
|
||||
+ release_sock(sk);
|
||||
return err;
|
||||
}
|
||||
|
||||
--
|
||||
2.10.2
|
||||
|
|
@ -7,8 +7,8 @@ pkgbase=linux-veyron
|
|||
_kernelname=${pkgbase#linux}
|
||||
_desc="Veyron Chromebooks"
|
||||
pkgver=3.14.0
|
||||
pkgrel=23
|
||||
_commit=2086ef885b4c29d03ebe8a1836def9f966d41593
|
||||
pkgrel=24
|
||||
_commit=b093583dda7e0be315bbf9aea4a697d1e20cd58e
|
||||
arch=('armv7h')
|
||||
url="https://chromium.googlesource.com/chromiumos/third_party/kernel/+/chromeos-3.14"
|
||||
license=('GPL2')
|
||||
|
@ -21,7 +21,6 @@ source=("https://chromium.googlesource.com/chromiumos/third_party/kernel/+archiv
|
|||
'0002-mwifiex-do-not-create-AP-and-P2P-interfaces-upon-dri.patch'
|
||||
'0003-UPSTREAM-soc-rockchip-add-handler-for-usb-uart-funct.patch'
|
||||
'0004-fix-brcmfmac-oops-and-race-condition.patch'
|
||||
'0005-packet-fix-race-condition-in-packet_set_ring.patch'
|
||||
'config'
|
||||
'kernel.its'
|
||||
'kernel.keyblock'
|
||||
|
@ -29,17 +28,16 @@ source=("https://chromium.googlesource.com/chromiumos/third_party/kernel/+archiv
|
|||
'cmdline'
|
||||
'brcmfmac4354-sdio.txt'
|
||||
'99-veyron-brcm.rules')
|
||||
md5sums=('395ad52e3059997ebc87fa4427019e21'
|
||||
md5sums=('8f71593561163c049a487751fab6dc8e'
|
||||
'bda543cb5943eac34e16d12911f3ee99'
|
||||
'5e2d7cd74de07d13052de99411c13a2f'
|
||||
'1534c1dbfe5df35a5634072f7b912840'
|
||||
'20f8931f3795e5226829d48c3d470334'
|
||||
'16c6e2e181ff23623c1004951322b848'
|
||||
'4677e9178fe6d3b043d03929cca029be'
|
||||
'87e12764d5545b1fc0300f896ed4d368'
|
||||
'f716682a9992b3b88841854575c851fd'
|
||||
'8f03e6c72db84edb7b429a2a934f69c8'
|
||||
'2e57d5a525a9ec3ad0eb87178f0c4e9f'
|
||||
'3ac01cf94902936a732bf3f0df79eb43'
|
||||
'2e3d4a2634a76ff37f3dae94a7ced6a3'
|
||||
'8aaa2709e1c9466c71c6646643eb4edf'
|
||||
'40351745df5a762edd50a50386df71ee'
|
||||
'f1860967a80286449b23439ad51dc7b0'
|
||||
'761d2e8cef38584b9e2f478e8096e458'
|
||||
'61c5ff73c136ed07a7aadbf58db3d96a'
|
||||
'584777ae88bce2c5659960151b64c7d8'
|
||||
|
@ -52,7 +50,6 @@ prepare() {
|
|||
git apply 0002-mwifiex-do-not-create-AP-and-P2P-interfaces-upon-dri.patch
|
||||
git apply 0003-UPSTREAM-soc-rockchip-add-handler-for-usb-uart-funct.patch
|
||||
git apply 0004-fix-brcmfmac-oops-and-race-condition.patch
|
||||
git apply 0005-packet-fix-race-condition-in-packet_set_ring.patch
|
||||
|
||||
cp config .config
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
#
|
||||
# Automatically generated file; DO NOT EDIT.
|
||||
# Linux/arm 3.14.0-21 Kernel Configuration
|
||||
# Linux/arm 3.14.0-24 Kernel Configuration
|
||||
#
|
||||
CONFIG_ARM=y
|
||||
CONFIG_ARM_HAS_SG_CHAIN=y
|
||||
|
@ -221,6 +221,11 @@ CONFIG_HAVE_VIRT_CPU_ACCOUNTING_GEN=y
|
|||
CONFIG_HAVE_IRQ_TIME_ACCOUNTING=y
|
||||
CONFIG_HAVE_MOD_ARCH_SPECIFIC=y
|
||||
CONFIG_MODULES_USE_ELF_REL=y
|
||||
CONFIG_HAVE_ARCH_MMAP_RND_BITS=y
|
||||
CONFIG_ARCH_MMAP_RND_BITS_MIN=8
|
||||
CONFIG_ARCH_MMAP_RND_BITS_MAX=16
|
||||
CONFIG_ARCH_MMAP_RND_BITS=8
|
||||
CONFIG_ARCH_HAS_ELF_RANDOMIZE=y
|
||||
CONFIG_CLONE_BACKWARDS=y
|
||||
CONFIG_OLD_SIGSUSPEND3=y
|
||||
CONFIG_OLD_SIGACTION=y
|
||||
|
@ -283,9 +288,9 @@ CONFIG_IOSCHED_DEADLINE=y
|
|||
CONFIG_IOSCHED_CFQ=y
|
||||
CONFIG_CFQ_GROUP_IOSCHED=y
|
||||
# CONFIG_DEFAULT_DEADLINE is not set
|
||||
CONFIG_DEFAULT_CFQ=y
|
||||
# CONFIG_DEFAULT_NOOP is not set
|
||||
CONFIG_DEFAULT_IOSCHED="cfq"
|
||||
# CONFIG_DEFAULT_CFQ is not set
|
||||
CONFIG_DEFAULT_NOOP=y
|
||||
CONFIG_DEFAULT_IOSCHED="noop"
|
||||
CONFIG_PADATA=y
|
||||
CONFIG_UNINLINE_SPIN_UNLOCK=y
|
||||
CONFIG_MUTEX_SPIN_ON_OWNER=y
|
||||
|
@ -593,7 +598,6 @@ CONFIG_KERNEL_MODE_NEON=y
|
|||
# Userspace binary formats
|
||||
#
|
||||
CONFIG_BINFMT_ELF=y
|
||||
CONFIG_ARCH_BINFMT_ELF_RANDOMIZE_PIE=y
|
||||
CONFIG_CORE_DUMP_DEFAULT_ELF_HEADERS=y
|
||||
CONFIG_BINFMT_SCRIPT=y
|
||||
# CONFIG_HAVE_AOUT is not set
|
||||
|
@ -4296,6 +4300,7 @@ CONFIG_KEYS=y
|
|||
CONFIG_ENCRYPTED_KEYS=y
|
||||
CONFIG_KEYS_DEBUG_PROC_KEYS=y
|
||||
# CONFIG_SECURITY_DMESG_RESTRICT is not set
|
||||
# CONFIG_SECURITY_PERF_EVENTS_RESTRICT is not set
|
||||
CONFIG_SECURITY=y
|
||||
CONFIG_SECURITYFS=y
|
||||
CONFIG_SECURITY_NETWORK=y
|
||||
|
|
Loading…
Reference in a new issue