mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
community/supercollider to 3.6.6-2
This commit is contained in:
parent
8844c35e7f
commit
96808f0f88
2 changed files with 30 additions and 3 deletions
|
@ -8,7 +8,7 @@
|
|||
_name=SuperCollider
|
||||
pkgname=supercollider
|
||||
pkgver=3.6.6
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
pkgdesc="An environment and programming language for real time audio synthesis and algorithmic composition"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://supercollider.sourceforge.net/"
|
||||
|
@ -20,8 +20,15 @@ optdepends=('emacs: emacs interface'
|
|||
'vim: vim interface'
|
||||
'ruby: vim support')
|
||||
install="$pkgname.install"
|
||||
source=("http://download.sourceforge.net/project/$pkgname/Source/${pkgver%.*}/$_name-$pkgver-Source-linux.tar.bz2")
|
||||
md5sums=('14d6063933230c74e42f5923a811e7c6')
|
||||
source=("http://download.sourceforge.net/project/$pkgname/Source/${pkgver%.*}/$_name-$pkgver-Source-linux.tar.bz2"
|
||||
"ftbfs-gcc-4.9.patch")
|
||||
md5sums=('14d6063933230c74e42f5923a811e7c6'
|
||||
'257a9198e650638a9a43bad2812760f7')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/$_name-Source"
|
||||
patch -Np1 -i ../ftbfs-gcc-4.9.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$_name-Source"
|
||||
|
|
20
community/supercollider/ftbfs-gcc-4.9.patch
Normal file
20
community/supercollider/ftbfs-gcc-4.9.patch
Normal file
|
@ -0,0 +1,20 @@
|
|||
From: Felipe Sateler <fsateler@debian.org>
|
||||
Date: Fri, 6 Jun 2014 13:15:18 -0400
|
||||
Subject: Fix implementation of aligned_allocator::construct<U>.
|
||||
|
||||
Fixes a build failure with gcc >= 4.9, because it defines __cplusplus >= 201103L.
|
||||
|
||||
A typo, apparently. This patch can be dropped in the next upstream release.
|
||||
Index: supercollider/server/supernova/utilities/malloc_aligned.hpp
|
||||
===================================================================
|
||||
--- supercollider.orig/server/supernova/utilities/malloc_aligned.hpp 2014-09-11 09:15:20.399357542 +0100
|
||||
+++ supercollider/server/supernova/utilities/malloc_aligned.hpp 2014-09-11 09:15:20.399357542 +0100
|
||||
@@ -243,7 +243,7 @@
|
||||
template< class U, class... Args >
|
||||
void construct(U * p, Args&& ... args)
|
||||
{
|
||||
- ::new(p) T(std::forward<Args>(args)...);
|
||||
+ ::new(p) U(std::forward<Args>(args)...);
|
||||
}
|
||||
#endif
|
||||
|
Loading…
Reference in a new issue