mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/cups to 2.0.1-1
This commit is contained in:
parent
75fdd8dbaa
commit
9693c4bf2f
4 changed files with 6 additions and 111 deletions
|
@ -6,8 +6,8 @@
|
|||
|
||||
pkgbase="cups"
|
||||
pkgname=('libcups' 'cups')
|
||||
pkgver=2.0.0
|
||||
pkgrel=3
|
||||
pkgver=2.0.1
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
license=('GPL')
|
||||
url="http://www.cups.org/"
|
||||
|
@ -23,11 +23,8 @@ source=(http://www.cups.org/software/${pkgver}/cups-${pkgver}-source.tar.bz2{,.s
|
|||
cups-1.6.2-statedir.patch
|
||||
cups-1.6.0-fix-install-perms.patch
|
||||
# bugfixes
|
||||
str4497.patch
|
||||
str4495.patch
|
||||
str4500.patch # FC
|
||||
)
|
||||
md5sums=('2cdd81fea23e9e29555c24bdfd0d7c89'
|
||||
md5sums=('7f7c33071035fb20d0879929a42da711'
|
||||
'SKIP'
|
||||
'fc8286f185e2cc5f7e1f6843bf193e2b'
|
||||
'96f82c38f3f540b53f3e5144900acf17'
|
||||
|
@ -35,10 +32,7 @@ md5sums=('2cdd81fea23e9e29555c24bdfd0d7c89'
|
|||
'1beb4896f217bc241bc08a422274ec0c'
|
||||
'90c30380d4c8cd48a908cfdadae1ea24'
|
||||
'451609db34f95209d64c38474de27ce1'
|
||||
'5117f65342fcc69c6a506529e4daca9e'
|
||||
'5aab5a160482d89e5d2a4def1f83ef8f'
|
||||
'84da6459947d4fb62398e9bad7922a11'
|
||||
'8c0514e41c3b50b2b838b218f683e227')
|
||||
'5117f65342fcc69c6a506529e4daca9e')
|
||||
|
||||
prepare() {
|
||||
|
||||
|
@ -58,19 +52,6 @@ prepare() {
|
|||
|
||||
# bug fixes
|
||||
|
||||
# https://www.cups.org/str.php?L4497 + https://www.cups.org/str.php?L4491
|
||||
# "Port 631" binds to localhost only (systemd regression)
|
||||
patch -Np0 -i ${srcdir}/str4497.patch
|
||||
|
||||
# https://bugs.archlinux.org/task/40937 - https://www.cups.org/str.php?L4495
|
||||
# adds a warning to the config file and honors the FatalErrors directive
|
||||
patch -Np0 -i ${srcdir}/str4495.patch
|
||||
|
||||
# https://www.cups.org/str.php?L4500
|
||||
# /etc/cups/ppd/*.ppd not world-readable, cupsGetPPD() returns symlink
|
||||
patch -Np1 -i ${srcdir}/str4500.patch
|
||||
|
||||
|
||||
# set MaxLogSize to 0 to prevent using cups internal log rotation
|
||||
sed -i -e '5i\ ' conf/cupsd.conf.in
|
||||
sed -i -e '6i# Disable cups internal logging - use logrotate instead' conf/cupsd.conf.in
|
||||
|
@ -141,8 +122,7 @@ backup=(etc/cups/cupsd.conf
|
|||
etc/cups/subscriptions.conf
|
||||
etc/dbus-1/system.d/cups.conf
|
||||
etc/logrotate.d/cups
|
||||
etc/pam.d/cups
|
||||
etc/xinetd.d/cups-lpd)
|
||||
etc/pam.d/cups)
|
||||
depends=('acl' 'pam' "libcups>=${pkgver}" 'cups-filters' 'bc' 'colord'
|
||||
'dbus' 'systemd' 'libpaper' 'hicolor-icon-theme')
|
||||
optdepends=('xdg-utils: xdg .desktop file support')
|
||||
|
@ -189,6 +169,7 @@ optdepends=('xdg-utils: xdg .desktop file support')
|
|||
# comment out all conversion rules which use any of the removed filters
|
||||
perl -p -i -e 's:^(.*\s+bannertops\s*)$:#\1:' $pkgdir/usr/share/cups/mime/mime.convs
|
||||
|
||||
|
||||
# comment out unnecessary PageLogFormat entry
|
||||
sed -i -e 's:PageLogFormat:#PageLogFormat:' $pkgdir/etc/cups/cupsd.conf*
|
||||
}
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
Index: conf/cups-files.conf.in
|
||||
===================================================================
|
||||
--- conf/cups-files.conf.in (revision 12220)
|
||||
+++ conf/cups-files.conf.in (working copy)
|
||||
@@ -15,6 +15,7 @@
|
||||
#Group @CUPS_GROUP@
|
||||
|
||||
# Administrator user group, used to match @SYSTEM in cupsd.conf policy rules...
|
||||
+# This cannot contain the Group value for security reasons...
|
||||
SystemGroup @CUPS_SYSTEM_GROUPS@
|
||||
@CUPS_SYSTEM_AUTHKEY@
|
||||
|
||||
Index: scheduler/conf.c
|
||||
===================================================================
|
||||
--- scheduler/conf.c (revision 12220)
|
||||
+++ scheduler/conf.c (working copy)
|
||||
@@ -995,6 +995,9 @@
|
||||
|
||||
cupsdLogMessage(CUPSD_LOG_NOTICE,
|
||||
"Group and SystemGroup cannot use the same groups.");
|
||||
+ if (FatalErrors & (CUPSD_FATAL_CONFIG | CUPSD_FATAL_PERMISSIONS))
|
||||
+ return (0);
|
||||
+
|
||||
cupsdLogMessage(CUPSD_LOG_INFO, "Resetting Group to \"nobody\"...");
|
||||
|
||||
group = getgrnam("nobody");
|
|
@ -1,43 +0,0 @@
|
|||
Index: scheduler/main.c
|
||||
===================================================================
|
||||
--- scheduler/main.c (revision 12213)
|
||||
+++ scheduler/main.c (working copy)
|
||||
@@ -763,6 +763,9 @@
|
||||
|
||||
if (timeout == 86400 && OnDemand && IdleExitTimeout &&
|
||||
!cupsArrayCount(ActiveJobs) &&
|
||||
+# ifdef HAVE_SYSTEMD
|
||||
+ !WebInterface &&
|
||||
+# endif /* HAVE_SYSTEMD */
|
||||
(!Browsing || !BrowseLocalProtocols || !cupsArrayCount(Printers)))
|
||||
{
|
||||
timeout = IdleExitTimeout;
|
||||
@@ -2114,8 +2117,12 @@
|
||||
* jobs or shared printers to advertise...
|
||||
*/
|
||||
|
||||
- if (cupsArrayCount(ActiveJobs) ||
|
||||
+ if (cupsArrayCount(ActiveJobs) || /* Active jobs */
|
||||
+# ifdef HAVE_SYSTEMD
|
||||
+ WebInterface || /* Web interface enabled */
|
||||
+# endif /* HAVE_SYSTEMD */
|
||||
(Browsing && BrowseLocalProtocols && cupsArrayCount(Printers)))
|
||||
+ /* Printers being shared */
|
||||
{
|
||||
cupsdLogMessage(CUPSD_LOG_DEBUG, "Creating keep-alive file \"" CUPS_KEEPALIVE "\".");
|
||||
|
||||
Index: scheduler/org.cups.cupsd.socket.in
|
||||
===================================================================
|
||||
--- scheduler/org.cups.cupsd.socket.in (revision 12213)
|
||||
+++ scheduler/org.cups.cupsd.socket.in (working copy)
|
||||
@@ -3,10 +3,6 @@
|
||||
|
||||
[Socket]
|
||||
ListenStream=@CUPS_DEFAULT_DOMAINSOCKET@
|
||||
-ListenStream=[::1]:631
|
||||
-ListenStream=127.0.0.1:631
|
||||
-BindIPv6Only=ipv6-only
|
||||
-ReusePort=true
|
||||
|
||||
[Install]
|
||||
WantedBy=sockets.target
|
|
@ -1,17 +0,0 @@
|
|||
diff -up cups-2.0.0/cups/util.c.str4500 cups-2.0.0/cups/util.c
|
||||
--- cups-2.0.0/cups/util.c.str4500 2014-10-15 12:59:27.105942488 +0100
|
||||
+++ cups-2.0.0/cups/util.c 2014-10-15 13:03:38.618187112 +0100
|
||||
@@ -846,10 +846,10 @@ cupsGetPPD3(http_t *http, /* I - H
|
||||
|
||||
snprintf(ppdname, sizeof(ppdname), "%s/ppd/%s.ppd", cg->cups_serverroot,
|
||||
name);
|
||||
- if (!stat(ppdname, &ppdinfo))
|
||||
+ if (!stat(ppdname, &ppdinfo) && !access(ppdname, R_OK))
|
||||
{
|
||||
/*
|
||||
- * OK, the file exists, use it!
|
||||
+ * OK, the file exists and is readable, use it!
|
||||
*/
|
||||
|
||||
if (buffer[0])
|
||||
|
Loading…
Reference in a new issue