mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/webkitgtk fix
This commit is contained in:
parent
4c74c354a5
commit
96a75b8b63
2 changed files with 32 additions and 2 deletions
|
@ -5,6 +5,7 @@
|
|||
# - use --disable-jit to solve segfaults
|
||||
# - use --disable-gtk-doc to solve html docs breaking the build
|
||||
# - AArch64 fixes
|
||||
# - abs/fabs patch from Fedora
|
||||
|
||||
highmem=1
|
||||
|
||||
|
@ -23,8 +24,10 @@ optdepends=('gst-plugins-base: free media decoding'
|
|||
'gst-plugins-good: media decoding'
|
||||
'gst-libav: nonfree media decoding')
|
||||
options=(!emptydirs)
|
||||
source=(http://webkitgtk.org/releases/$pkgbase-${pkgver}.tar.xz)
|
||||
sha256sums=('588aea051bfbacced27fdfe0335a957dca839ebe36aa548df39c7bbafdb65bf7')
|
||||
source=(http://webkitgtk.org/releases/$pkgbase-${pkgver}.tar.xz
|
||||
webkitgtk-2.4.9-abs.patch)
|
||||
sha256sums=('588aea051bfbacced27fdfe0335a957dca839ebe36aa548df39c7bbafdb65bf7'
|
||||
'ec294bbb5588a1802a68e3615c6718486b22f922645c5fef686d3d103014bf70')
|
||||
|
||||
prepare() {
|
||||
mkdir build-gtk{,2} path
|
||||
|
@ -36,6 +39,7 @@ prepare() {
|
|||
CFLAGS+=" -DENABLE_YARR_JIT=0"
|
||||
CXXFLAGS+=" -DENABLE_YARR_JIT=0"
|
||||
fi
|
||||
patch -p1 -i ../webkitgtk-2.4.9-abs.patch
|
||||
}
|
||||
|
||||
_build() (
|
||||
|
|
26
extra/webkitgtk/webkitgtk-2.4.9-abs.patch
Normal file
26
extra/webkitgtk/webkitgtk-2.4.9-abs.patch
Normal file
|
@ -0,0 +1,26 @@
|
|||
diff -Nur webkitgtk-2.4.9.orig/Source/WebCore/platform/gtk/GtkClickCounter.cpp webkitgtk-2.4.9/Source/WebCore/platform/gtk/GtkClickCounter.cpp
|
||||
--- webkitgtk-2.4.9.orig/Source/WebCore/platform/gtk/GtkClickCounter.cpp 2015-05-20 03:03:24.000000000 -0600
|
||||
+++ webkitgtk-2.4.9/Source/WebCore/platform/gtk/GtkClickCounter.cpp 2016-02-07 11:30:42.392686308 -0700
|
||||
@@ -85,8 +85,8 @@
|
||||
guint32 eventTime = getEventTime(event);
|
||||
|
||||
if ((event->type == GDK_2BUTTON_PRESS || event->type == GDK_3BUTTON_PRESS)
|
||||
- || ((abs(buttonEvent->x - m_previousClickPoint.x()) < doubleClickDistance)
|
||||
- && (abs(buttonEvent->y - m_previousClickPoint.y()) < doubleClickDistance)
|
||||
+ || ((fabs(buttonEvent->x - m_previousClickPoint.x()) < doubleClickDistance)
|
||||
+ && (fabs(buttonEvent->y - m_previousClickPoint.y()) < doubleClickDistance)
|
||||
&& (eventTime - m_previousClickTime < static_cast<guint>(doubleClickTime))
|
||||
&& (buttonEvent->button == m_previousClickButton)))
|
||||
m_currentClickCount++;
|
||||
diff -Nur webkitgtk-2.4.9.orig/Source/WebCore/platform/gtk/LocalizedStringsGtk.cpp webkitgtk-2.4.9/Source/WebCore/platform/gtk/LocalizedStringsGtk.cpp
|
||||
--- webkitgtk-2.4.9.orig/Source/WebCore/platform/gtk/LocalizedStringsGtk.cpp 2015-05-20 03:03:24.000000000 -0600
|
||||
+++ webkitgtk-2.4.9/Source/WebCore/platform/gtk/LocalizedStringsGtk.cpp 2016-02-07 11:49:36.384691005 -0700
|
||||
@@ -659,7 +659,7 @@
|
||||
if (!std::isfinite(time))
|
||||
return String::fromUTF8(_("indefinite time"));
|
||||
|
||||
- int seconds = static_cast<int>(abs(time));
|
||||
+ int seconds = static_cast<int>(fabs(time));
|
||||
int days = seconds / (60 * 60 * 24);
|
||||
int hours = seconds / (60 * 60);
|
||||
int minutes = (seconds / 60) % 60;
|
Loading…
Reference in a new issue