mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/chromium to 47.0.2526.73-1
This commit is contained in:
parent
ee98b90f2b
commit
96c68e29c4
2 changed files with 28 additions and 3 deletions
|
@ -18,7 +18,7 @@
|
|||
buildarch=4
|
||||
|
||||
pkgname=chromium
|
||||
pkgver=46.0.2490.86
|
||||
pkgver=47.0.2526.73
|
||||
pkgrel=1
|
||||
_launcher_ver=3
|
||||
pkgdesc="The open-source project behind Google Chrome, an attempt at creating a safer, faster, and more stable browser"
|
||||
|
@ -33,20 +33,22 @@ depends=('gtk2' 'nss' 'alsa-lib' 'xdg-utils' 'bzip2' 'libevent' 'libxss' 'icu'
|
|||
makedepends=('python2' 'gperf' 'yasm' 'mesa' 'ninja')
|
||||
optdepends=('kdebase-kdialog: needed for file dialogs in KDE'
|
||||
'gnome-keyring: for storing passwords in GNOME keyring'
|
||||
'kdeutils-kwalletmanager: for storing passwords in KWallet')
|
||||
'kwallet: for storing passwords in KWallet')
|
||||
provides=('chromium-browser')
|
||||
conflicts=('chromium-browser')
|
||||
install=chromium.install
|
||||
source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgname-$pkgver.tar.xz
|
||||
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
|
||||
chromium.desktop
|
||||
chromium-fix-print-preview-on-en_GB-locale.patch
|
||||
0001-Add-FPDFAPIJPEG_-prefix-to-more-libjpeg-functions.patch
|
||||
arm-webrtc-fix.patch
|
||||
chromium-arm-r0.patch
|
||||
chromium-widevine.patch)
|
||||
sha256sums=('ee18d28ac80ff958e8a6c770bfc0d7d770b55452ed91a87f731e1b432a7d1d92'
|
||||
sha256sums=('6d66d01c8ddff6562ff13d30ed65ef0cdc2888d9e4924be615d576b7eb15f4f5'
|
||||
'8b01fb4efe58146279858a754d90b49e5a38c9a0b36a1f84cbb7d12f92b84c28'
|
||||
'028a748a5c275de9b8f776f97909f999a8583a4b77fd1cd600b4fc5c0c3e91e9'
|
||||
'6fff45aafa31fb35a032b4e2175a341e08f9d2a9b37c5cf080c318180f558378'
|
||||
'd114def156d60d5f4c9e42f2955ba19bdebe38037a330ef947af24ace25db39d'
|
||||
'9db0f01517c52e3236ff52e8a664840542a19144a54923ae6aabea3dcfa92c52'
|
||||
'df4be49770d508b772f98eda9fc5f37fa71d4c0459437e12f7f3db5892aa1611'
|
||||
|
@ -67,6 +69,12 @@ prepare() {
|
|||
# https://groups.google.com/a/chromium.org/d/topic/chromium-packagers/9JX1N2nf4PU/discussion
|
||||
touch chrome/test/data/webui/i18n_process_css_test.html
|
||||
|
||||
# https://code.google.com/p/chromium/issues/detail?id=541273
|
||||
sed -i "/'target_name': 'libvpx'/s/libvpx/&_new/" build/linux/unbundle/libvpx.gyp
|
||||
|
||||
# https://code.google.com/p/chromium/issues/detail?id=480415
|
||||
patch -Np1 -i ../chromium-fix-print-preview-on-en_GB-locale.patch
|
||||
|
||||
# https://code.google.com/p/chromium/issues/detail?id=505226
|
||||
patch -d third_party/pdfium -Np1 <../0001-Add-FPDFAPIJPEG_-prefix-to-more-libjpeg-functions.patch
|
||||
|
||||
|
|
|
@ -0,0 +1,17 @@
|
|||
Index: chrome/browser/ui/webui/print_preview/print_preview_handler.cc
|
||||
diff --git a/chrome/browser/ui/webui/print_preview/print_preview_handler.cc b/chrome/browser/ui/webui/print_preview/print_preview_handler.cc
|
||||
index 6cfd861387c9f8b145fb33472b10025537986213..c936a9c1dadb13c00418e8ae79a8a1987c1d36cd 100644
|
||||
--- a/chrome/browser/ui/webui/print_preview/print_preview_handler.cc
|
||||
+++ b/chrome/browser/ui/webui/print_preview/print_preview_handler.cc
|
||||
@@ -1222,7 +1222,10 @@ void PrintPreviewHandler::GetNumberFormatAndMeasurementSystem(
|
||||
UErrorCode errorCode = U_ZERO_ERROR;
|
||||
const char* locale = g_browser_process->GetApplicationLocale().c_str();
|
||||
UMeasurementSystem system = ulocdata_getMeasurementSystem(locale, &errorCode);
|
||||
- if (errorCode > U_ZERO_ERROR || system == UMS_LIMIT)
|
||||
+ // On error, assume the units are SI.
|
||||
+ // Since the only measurement units print preview's WebUI cares about are
|
||||
+ // those for measuring distance, assume anything non-US is SI.
|
||||
+ if (errorCode > U_ZERO_ERROR || system != UMS_US)
|
||||
system = UMS_SI;
|
||||
|
||||
// Getting the number formatting based on the locale and writing to
|
Loading…
Reference in a new issue