core/linux-armv7 to 5.16.1-1

This commit is contained in:
Kevin Mihelich 2022-01-18 00:12:17 +00:00
parent 856891d241
commit 96d0a0a8ab
12 changed files with 656 additions and 357 deletions

View file

@ -1,4 +1,4 @@
From 42e09fd36133dd064fac728d0b8d80ddbb219ffb Mon Sep 17 00:00:00 2001
From 8b3dbe06077cbeeeccc6688dfc966e1fd316fc04 Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:59:28 +0100
Subject: [PATCH 1/9] ARM: atags: add support for Marvell's u-boot
@ -47,5 +47,5 @@ index 25ceda63b284..83578c54975b 100644
};
--
2.30.0
2.33.1

View file

@ -1,4 +1,4 @@
From c36f74ab5103410009e01d6de01be70958c721a7 Mon Sep 17 00:00:00 2001
From 9e301403964f656bf91c97a1aeeddc5ceae7e66a Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:56:58 +0100
Subject: [PATCH 2/9] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
@ -17,10 +17,10 @@ Signed-off-by: Willy Tarreau <w@xxxxxx>
1 file changed, 6 insertions(+)
diff --git a/arch/arm/boot/compressed/atags_to_fdt.c b/arch/arm/boot/compressed/atags_to_fdt.c
index 8452753efebe..3393a10741bb 100644
index 1feb6b0f7a1f..5e5cb3094b6a 100644
--- a/arch/arm/boot/compressed/atags_to_fdt.c
+++ b/arch/arm/boot/compressed/atags_to_fdt.c
@@ -204,6 +204,12 @@ int atags_to_fdt(void *atag_list, void *fdt, int total_space)
@@ -205,6 +205,12 @@ int atags_to_fdt(void *atag_list, void *fdt, int total_space)
hex_str(serno, atag->u.serialnr.high);
hex_str(serno+8, atag->u.serialnr.low);
setprop_string(fdt, "/", "serial-number", serno);
@ -34,5 +34,5 @@ index 8452753efebe..3393a10741bb 100644
}
--
2.30.0
2.33.1

View file

@ -1,4 +1,4 @@
From 1cc898e76d009e4b381bef9ccbe8822f1ad4c179 Mon Sep 17 00:00:00 2001
From 6cf4510eca989d7bb3b237d14fa7d31e4c0db380 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:41:19 -0600
Subject: [PATCH 3/9] SMILE Plug device tree file
@ -14,10 +14,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
create mode 100644 arch/arm/boot/dts/armada-370-smileplug.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index ce66ffd5a1bb..8f4062d549e2 100644
index 0de64f237cd8..f11b3fec4d38 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -1308,6 +1308,7 @@ dtb-$(CONFIG_MACH_ARMADA_370) += \
@@ -1395,6 +1395,7 @@ dtb-$(CONFIG_MACH_ARMADA_370) += \
armada-370-db.dtb \
armada-370-dlink-dns327l.dtb \
armada-370-mirabox.dtb \
@ -205,5 +205,5 @@ index 000000000000..d01308ab848b
+ };
+};
--
2.30.0
2.33.1

View file

@ -1,4 +1,4 @@
From 35bff27d14f5c3f29e42bf0bcde31dfc820f67a9 Mon Sep 17 00:00:00 2001
From 3ffc06ce8614aa105ad50d721226da264ea42892 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:43:56 -0600
Subject: [PATCH 4/9] fix mvsdio eMMC timing
@ -34,5 +34,5 @@ index 629efbe639c4..c507c064736c 100644
host->clock = ios->clock;
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
--
2.30.0
2.33.1

View file

@ -1,4 +1,4 @@
From 5387243844440a0d05f4b75216588a68526aa4c9 Mon Sep 17 00:00:00 2001
From f5119a41d1190c2b54badcc14b4d2d3401487bf8 Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 5/9] net/smsc95xx: Allow mac address to be set as a parameter
@ -8,7 +8,7 @@ Subject: [PATCH 5/9] net/smsc95xx: Allow mac address to be set as a parameter
1 file changed, 56 insertions(+)
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
index ea0d5f04dc3a..88ebceb84193 100644
index abe0149ed917..e62e96352b6e 100644
--- a/drivers/net/usb/smsc95xx.c
+++ b/drivers/net/usb/smsc95xx.c
@@ -50,6 +50,7 @@
@ -87,9 +87,9 @@ index ea0d5f04dc3a..88ebceb84193 100644
+ if (smsc95xx_is_macaddr_param(dev, dev->net->dev_addr))
+ return;
+
u8 addr[ETH_ALEN];
/* maybe the boot loader passed the MAC address in devicetree */
if (!eth_platform_get_mac_address(&dev->udev->dev,
dev->net->dev_addr)) {
--
2.30.0
2.33.1

View file

@ -1,4 +1,4 @@
From c22b09283934f39b059b42e3c29985ba81bc8af7 Mon Sep 17 00:00:00 2001
From 32846568153775ef11ecdf99be710f4135ad2c21 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 14 Feb 2015 12:32:27 +0100
Subject: [PATCH 6/9] set default cubietruck led triggers
@ -9,19 +9,19 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
1 file changed, 2 insertions(+)
diff --git a/arch/arm/boot/dts/sun7i-a20-cubietruck.dts b/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
index 9109ca0919ad..43460add4609 100644
index 52160e368304..21c8ef94c756 100644
--- a/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
+++ b/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
@@ -78,6 +78,7 @@ leds {
blue {
led-0 {
label = "cubietruck:blue:usr";
gpios = <&pio 7 21 GPIO_ACTIVE_HIGH>;
+ linux,default-trigger = "heartbeat";
};
orange {
@@ -93,6 +94,7 @@ white {
green {
led-1 {
@@ -93,6 +94,7 @@ led-2 {
led-3 {
label = "cubietruck:green:usr";
gpios = <&pio 7 7 GPIO_ACTIVE_HIGH>;
+ linux,default-trigger = "mmc0";
@ -29,5 +29,5 @@ index 9109ca0919ad..43460add4609 100644
};
--
2.30.0
2.33.1

View file

@ -1,4 +1,4 @@
From d020dc63065a58f4be4817cba4a36da8334ddafb Mon Sep 17 00:00:00 2001
From 479d3c776de70a21563bb50ec249b0c142e3c865 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 11 Aug 2016 00:42:37 -0600
Subject: [PATCH 7/9] exynos4412-odroid: set higher minimum buck2 regulator
@ -13,10 +13,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm/boot/dts/exynos4412-odroid-common.dtsi b/arch/arm/boot/dts/exynos4412-odroid-common.dtsi
index 2983e91bc7dd..fbf6c172becf 100644
index 5b1d4591b35c..8a8d2c6add10 100644
--- a/arch/arm/boot/dts/exynos4412-odroid-common.dtsi
+++ b/arch/arm/boot/dts/exynos4412-odroid-common.dtsi
@@ -435,7 +435,7 @@ buck1_reg: BUCK1 {
@@ -436,7 +436,7 @@ buck1_reg: BUCK1 {
buck2_reg: BUCK2 {
regulator-name = "VDD_ARM";
@ -26,5 +26,5 @@ index 2983e91bc7dd..fbf6c172becf 100644
regulator-always-on;
regulator-boot-on;
--
2.30.0
2.33.1

View file

@ -1,4 +1,4 @@
From de507dbe4db754f09905800e4d1629bd933d16f5 Mon Sep 17 00:00:00 2001
From 384a035086207bb0edad12a1c24444497c2ce686 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 7 May 2017 13:32:25 -0600
Subject: [PATCH 8/9] ARM: dove: enable ethernet on D3Plug
@ -27,5 +27,5 @@ index 826026c28f90..a4c9963e1261 100644
/* Samsung M8G2F eMMC */
&sdio0 {
--
2.30.0
2.33.1

View file

@ -1,4 +1,4 @@
From d174311bd7469ddf9c292ab41f2bca0a21b12ab2 Mon Sep 17 00:00:00 2001
From 4bbf6e11852b0bae53c30e0a533432fa6121bc23 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 11 Aug 2019 12:34:17 -0600
Subject: [PATCH 9/9] USB Armory MkII support
@ -12,23 +12,25 @@ Subject: [PATCH 9/9] USB Armory MkII support
create mode 100644 arch/arm/boot/dts/imx6ull-usbarmory.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index 8f4062d549e2..9af811420ae6 100644
index f11b3fec4d38..8215f6987632 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -626,11 +626,13 @@ dtb-$(CONFIG_SOC_IMX6UL) += \
@@ -684,6 +684,7 @@ dtb-$(CONFIG_SOC_IMX6UL) += \
imx6ul-tx6ul-0010.dtb \
imx6ul-tx6ul-0011.dtb \
imx6ul-tx6ul-mainboard.dtb \
+ imx6ul-usbarmory.dtb \
imx6ull-14x14-evk.dtb \
imx6ull-colibri-emmc-eval-v3.dtb \
imx6ull-colibri-eval-v3.dtb \
imx6ull-colibri-wifi-eval-v3.dtb \
imx6ull-myir-mys-6ulx-eval.dtb \
imx6ull-opos6uldev.dtb \
+ imx6ull-usbarmory.dtb \
@@ -693,6 +694,7 @@ dtb-$(CONFIG_SOC_IMX6UL) += \
imx6ull-phytec-segin-ff-rdk-nand.dtb \
imx6ull-phytec-segin-ff-rdk-emmc.dtb \
imx6ull-phytec-segin-lc-rdk-nand.dtb \
+ imx6ull-usbarmory.dtb \
imx6ulz-14x14-evk.dtb
dtb-$(CONFIG_SOC_IMX7D) += \
imx7d-cl-som-imx7.dtb \
diff --git a/arch/arm/boot/dts/imx6ul-usbarmory.dts b/arch/arm/boot/dts/imx6ul-usbarmory.dts
new file mode 100644
index 000000000000..1fdcd6f611d5
@ -555,5 +557,5 @@ index 000000000000..f74d0296d5f6
+ status = "okay";
+};
--
2.30.0
2.33.1

View file

@ -4,21 +4,21 @@
buildarch=4
pkgbase=linux-armv7
_srcname=linux-5.11
_srcname=linux-5.16
_kernelname=${pkgbase#linux}
_desc="ARMv7 multi-platform"
pkgver=5.11.2
pkgver=5.16.1
pkgrel=1
rcnver=5.11.0
rcnver=5.16.0
rcnrel=armv7-x10
arch=('armv7h')
url="http://www.kernel.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git' 'uboot-tools' 'vboot-utils' 'dtc')
options=('!strip')
source=("http://www.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.xz"
"http://www.kernel.org/pub/linux/kernel/v5.x/patch-${pkgver}.xz"
"http://rcn-ee.com/deb/stretch-armhf/v${rcnver}-${rcnrel}/patch-${rcnver%.0}-${rcnrel}.diff.xz"
source=("https://www.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.xz"
"https://www.kernel.org/pub/linux/kernel/v5.x/patch-${pkgver}.xz"
"https://rcn-ee.com/deb/sid-armhf/v${rcnver}-${rcnrel}/patch-${rcnver%.0}-${rcnrel}.diff.gz"
'0001-ARM-atags-add-support-for-Marvell-s-u-boot.patch'
'0002-ARM-atags-fdt-retrieve-MAC-addresses-from-Marvell-bo.patch'
'0003-SMILE-Plug-device-tree-file.patch'
@ -35,20 +35,20 @@ source=("http://www.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.xz"
'linux.preset'
'60-linux.hook'
'90-linux.hook')
md5sums=('d2985a3f16ef1ea3405c04c406e29dcc'
'4f2437097d20455c71d1b1866469d6be'
'fe141ac54d974f1082bc1e5399c71447'
'6c3c583d8fa165315791216c5dce9fe4'
'0b1fac542a49c8756c4c66d55df7a609'
'5b303c16f3957d0c79285bcddae34218'
'85501c220fbb3c80b5a2836e4764dbe0'
'6e791015c502e6931ca1d27a4dde006a'
'f704f034ac86b058c58ef82499a0cd0e'
'eef2303908ced1604187ae76cdf2b9d0'
'56f2d15c883be64c182073744540a7c6'
'0e76e8e7d3d6c5961cd7276a4df9f3a3'
'5102e6401a360fce96c502adf026eff5'
'4f2379ed84258050edb858ee8d281678'
md5sums=('e6680ce7c989a3efe58b51e3f3f0bf93'
'd571392436365678b420e4dece216514'
'ca7d6c6442f49b48a6c7de7e04721d89'
'b81c2379a8d11aa94c7362cc2e4dc025'
'9924e5e533a18f45b5f404e97e24758f'
'85fe4d7b5ff10099367b784fb25cd180'
'1fa1ac149480430d1cc598154dc7bf30'
'0e0ab9b6a483178208e86b2910160729'
'fa4095e155e7f5d5ba7c7ebfb03324ff'
'd23f935b23d571cb8895fac5bd3c713b'
'7a8781dc078b105aeaf725a7a2e4c385'
'892ad2ffda3f3fe02a3108ed7767f542'
'acaa2fca13599c0b43b4f0a0088957ca'
'0963ff6490be16935370812fc75fa065'
'61c5ff73c136ed07a7aadbf58db3d96a'
'584777ae88bce2c5659960151b64c7d8'
'86d4a35722b5410e3b29fc92dae15d4b'

File diff suppressed because it is too large Load diff

View file

@ -4,7 +4,7 @@
description = "Chrome OS kernel image with one or more FDT blobs";
#address-cells = <1>;
images {
kernel@1 {
kernel {
description = "kernel";
data = /incbin/("arch/arm/boot/zImage");
type = "kernel_noload";
@ -14,204 +14,204 @@
load = <0>;
entry = <0>;
};
fdt@1 {
fdt-snow {
description = "exynos5250-snow.dtb";
data = /incbin/("arch/arm/boot/dts/exynos5250-snow.dtb");
type = "flat_dt";
arch = "arm";
compression = "none";
hash@1 {
hash {
algo = "sha1";
};
};
fdt@2 {
fdt-snow-rev5 {
description = "exynos5250-snow-rev5.dtb";
data = /incbin/("arch/arm/boot/dts/exynos5250-snow-rev5.dtb");
type = "flat_dt";
arch = "arm";
compression = "none";
hash@1 {
hash {
algo = "sha1";
};
};
fdt@3 {
fdt-spring {
description = "exynos5250-spring.dtb";
data = /incbin/("arch/arm/boot/dts/exynos5250-spring.dtb");
type = "flat_dt";
arch = "arm";
compression = "none";
hash@1 {
hash {
algo = "sha1";
};
};
fdt@4 {
fdt-peach-pi {
description = "exynos5800-peach-pi.dtb";
data = /incbin/("arch/arm/boot/dts/exynos5800-peach-pi.dtb");
type = "flat_dt";
arch = "arm";
compression = "none";
hash@1{
hash {
algo = "sha1";
};
};
fdt@5 {
fdt-peach-pit {
description = "exynos5420-peach-pit.dtb";
data = /incbin/("arch/arm/boot/dts/exynos5420-peach-pit.dtb");
type = "flat_dt";
arch = "arm";
compression = "none";
hash@1 {
hash {
algo = "sha1";
};
};
fdt@6 {
fdt-veyron-brain {
description = "rk3288-veyron-brain.dtb";
data = /incbin/("arch/arm/boot/dts/rk3288-veyron-brain.dtb");
type = "flat_dt";
arch = "arm";
compression = "none";
hash@1 {
hash {
algo = "sha1";
};
};
fdt@7 {
fdt-veyron-jaq {
description = "rk3288-veyron-jaq.dtb";
data = /incbin/("arch/arm/boot/dts/rk3288-veyron-jaq.dtb");
type = "flat_dt";
arch = "arm";
compression = "none";
hash@1 {
hash {
algo = "sha1";
};
};
fdt@8 {
fdt-veyron-jerry {
description = "rk3288-veyron-jerry.dtb";
data = /incbin/("arch/arm/boot/dts/rk3288-veyron-jerry.dtb");
type = "flat_dt";
arch = "arm";
compression = "none";
hash@1 {
hash {
algo = "sha1";
};
};
fdt@9 {
fdt-veyron-mickey {
description = "rk3288-veyron-mickey.dtb";
data = /incbin/("arch/arm/boot/dts/rk3288-veyron-mickey.dtb");
type = "flat_dt";
arch = "arm";
compression = "none";
hash@1 {
hash {
algo = "sha1";
};
};
fdt@10 {
fdt-veyron-minnie {
description = "rk3288-veyron-minnie.dtb";
data = /incbin/("arch/arm/boot/dts/rk3288-veyron-minnie.dtb");
type = "flat_dt";
arch = "arm";
compression = "none";
hash@1 {
hash {
algo = "sha1";
};
};
fdt@11 {
fdt-veyron-pinky {
description = "rk3288-veyron-pinky.dtb";
data = /incbin/("arch/arm/boot/dts/rk3288-veyron-pinky.dtb");
type = "flat_dt";
arch = "arm";
compression = "none";
hash@1{
hash {
algo = "sha1";
};
};
fdt@12 {
fdt-veyron-speedy {
description = "rk3288-veyron-speedy.dtb";
data = /incbin/("arch/arm/boot/dts/rk3288-veyron-speedy.dtb");
type = "flat_dt";
arch = "arm";
compression = "none";
hash@1 {
hash {
algo = "sha1";
};
};
fdt@13 {
fdt-nyan-big {
description = "tegra124-nyan-big.dtb";
data = /incbin/("arch/arm/boot/dts/tegra124-nyan-big.dtb");
type = "flat_dt";
arch = "arm";
compression = "none";
hash@1 {
hash {
algo = "sha1";
};
};
fdt@14 {
fdt-nyan-blaze {
description = "tegra124-nyan-blaze.dtb";
data = /incbin/("arch/arm/boot/dts/tegra124-nyan-blaze.dtb");
type = "flat_dt";
arch = "arm";
compression = "none";
hash@1 {
hash {
algo = "sha1";
};
};
};
configurations {
default = "conf@1";
conf@1 {
kernel = "kernel@1";
fdt = "fdt@1";
default = "conf-snow";
conf-snow {
kernel = "kernel";
fdt = "fdt-snow";
};
conf@2 {
kernel = "kernel@1";
fdt = "fdt@2";
conf-snow-rev5 {
kernel = "kernel";
fdt = "fdt-snow-rev5";
};
conf@3 {
kernel = "kernel@1";
fdt = "fdt@3";
conf-spring {
kernel = "kernel";
fdt = "fdt-spring";
};
conf@4 {
kernel = "kernel@1";
fdt = "fdt@4";
conf-peach-pi {
kernel = "kernel";
fdt = "fdt-peach-pi";
};
conf@5 {
kernel = "kernel@1";
fdt = "fdt@5";
conf-peach-pit {
kernel = "kernel";
fdt = "fdt-peach-pit";
};
conf@6 {
kernel = "kernel@1";
fdt = "fdt@6";
conf-veyron-brain {
kernel = "kernel";
fdt = "fdt-veyron-brain";
};
conf@7 {
kernel = "kernel@1";
fdt = "fdt@7";
conf-veyron-jaq {
kernel = "kernel";
fdt = "fdt-veyron-jaq";
};
conf@8 {
kernel = "kernel@1";
fdt = "fdt@8";
conf-veyron-jerry {
kernel = "kernel";
fdt = "fdt-veryon-jerry";
};
conf@9 {
kernel = "kernel@1";
fdt = "fdt@9";
conf-veyron-mickey {
kernel = "kernel";
fdt = "fdt-veyron-mickey";
};
conf@10 {
kernel = "kernel@1";
fdt = "fdt@10";
conf-veyron-minnie {
kernel = "kernel";
fdt = "fdt-veyron-minnie";
};
conf@11 {
kernel = "kernel@1";
fdt = "fdt@11";
conf-veyron-pinky {
kernel = "kernel";
fdt = "fdt-veyron-pinky";
};
conf@12 {
kernel = "kernel@1";
fdt = "fdt@12";
conf-veyron-speedy {
kernel = "kernel";
fdt = "fdt-veyron-speedy";
};
conf@13 {
kernel = "kernel@1";
fdt = "fdt@13";
conf-nyan-big {
kernel = "kernel";
fdt = "fdt-nyan-big";
};
conf@14 {
kernel = "kernel@1";
fdt = "fdt@14";
conf-nyan-blaze {
kernel = "kernel";
fdt = "fdt-nyan-blaze";
};
};
};