mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
added extra/exiv2
This commit is contained in:
parent
f6e930fe52
commit
96f80ad0f4
2 changed files with 122 additions and 0 deletions
58
extra/exiv2/PKGBUILD
Normal file
58
extra/exiv2/PKGBUILD
Normal file
|
@ -0,0 +1,58 @@
|
|||
# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
|
||||
# Contributor: tobias <tobias@arhlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - upstream fixes for FTBFS on ARM
|
||||
|
||||
pkgname=exiv2
|
||||
pkgver=0.27.3
|
||||
pkgrel=1
|
||||
pkgdesc="Exif, Iptc and XMP metadata manipulation library and tools"
|
||||
url="https://exiv2.org"
|
||||
arch=('x86_64')
|
||||
license=('GPL2')
|
||||
depends=('gcc-libs' 'zlib' 'expat' 'gettext' 'curl')
|
||||
makedepends=('cmake' 'gtest')
|
||||
checkdepends=('python')
|
||||
provides=('libexiv2.so')
|
||||
source=(https://github.com/Exiv2/exiv2/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz
|
||||
arm.patch)
|
||||
sha512sums=('92775e1c79f06f7b4fb4c214cb2732982cbf01d8bc07d0e8f440facca712a41e579ef2baf72a0471889bb74d3f4975fbc76b47adbe6839decb6770458f76a341'
|
||||
'40ceab3f4d27d0fae1f5700b0b880ebdbeccf2da992cdc956e20a39b1c03531e6d03a9aa99f7842d3bfd44763a7f7c1d2b2eaa1a70cd1ead16144d7f73f49de1')
|
||||
b2sums=('f57afed9adbc578c6db0bec843112b12af4aa706a92a12fcd6cfe989ddc07090701f99bc3fb17946d696fe36073d8cefa4ec87a819e8407fda8c48f25d368964'
|
||||
'6904c03d600fd6ffc9a84b96ab5d216ab0c07b6cd8e1a82384809e21ab4cf0f8314363dbe7b58616b6b6459b3e6c63f662a08a9eca7a57a27af2213a049ccb42')
|
||||
|
||||
prepare() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
patch -p1 -i ../arm.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
cmake -B build \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DCMAKE_SKIP_RPATH=ON \
|
||||
-DEXIV2_BUILD_SAMPLES=ON \
|
||||
-DEXIV2_BUILD_UNIT_TESTS=ON \
|
||||
-DEXIV2_ENABLE_VIDEO=ON \
|
||||
-DEXIV2_ENABLE_NLS=ON \
|
||||
-DEXIV2_ENABLE_XMP=ON \
|
||||
-DEXIV2_ENABLE_CURL=ON \
|
||||
-DEXIV2_ENABLE_WEBREADY=ON
|
||||
make -C build VERBOSE=1
|
||||
}
|
||||
|
||||
check() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
make -C build tests
|
||||
}
|
||||
|
||||
package() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
# remove samples instal which are only needed for unit tests
|
||||
sed '/samples\/cmake_install.cmake/d' -i build/cmake_install.cmake
|
||||
make -C build DESTDIR="${pkgdir}" install
|
||||
}
|
||||
|
||||
# vim: ts=2 sw=2 et:
|
64
extra/exiv2/arm.patch
Normal file
64
extra/exiv2/arm.patch
Normal file
|
@ -0,0 +1,64 @@
|
|||
diff --git a/cmake/compilerFlags.cmake b/cmake/compilerFlags.cmake
|
||||
index 0418aa61..ae18583f 100644
|
||||
--- a/cmake/compilerFlags.cmake
|
||||
+++ b/cmake/compilerFlags.cmake
|
||||
@@ -1,4 +1,5 @@
|
||||
# These flags applies to exiv2lib, the applications, and to the xmp code
|
||||
+include(CheckCCompilerFlag)
|
||||
|
||||
if ( MINGW OR UNIX OR MSYS ) # MINGW, Linux, APPLE, CYGWIN
|
||||
if (${CMAKE_CXX_COMPILER_ID} STREQUAL GNU)
|
||||
@@ -23,22 +24,25 @@ if ( MINGW OR UNIX OR MSYS ) # MINGW, Linux, APPLE, CYGWIN
|
||||
|
||||
if (COMPILER_IS_GCC OR COMPILER_IS_CLANG)
|
||||
|
||||
- # This fails under Fedora, MinGW GCC 8.3.0 and CYGWIN/MSYS 9.3.0
|
||||
- if (NOT (MINGW OR CMAKE_HOST_SOLARIS OR CYGWIN OR MSYS) )
|
||||
- if (COMPILER_IS_GCC AND CMAKE_CXX_COMPILER_VERSION VERSION_GREATER_EQUAL 8.0)
|
||||
- add_compile_options(-fstack-clash-protection -fcf-protection)
|
||||
+ # This fails under Fedora - MinGW - Gcc 8.3
|
||||
+ if (NOT MINGW)
|
||||
+ check_c_compiler_flag(-fstack-clash-protection HAS_FSTACK_CLASH_PROTECTION)
|
||||
+ check_c_compiler_flag(-fcf-protection HAS_FCF_PROTECTION)
|
||||
+ check_c_compiler_flag(-fstack-protector-strong HAS_FSTACK_PROTECTOR_STRONG)
|
||||
+ if(HAS_FSTACK_CLASH_PROTECTION)
|
||||
+ add_compile_options(-fstack-clash-protection)
|
||||
endif()
|
||||
-
|
||||
- if( (COMPILER_IS_GCC AND CMAKE_CXX_COMPILER_VERSION VERSION_GREATER_EQUAL 5.0) # Not in GCC 4.8
|
||||
- OR (COMPILER_IS_CLANG AND CMAKE_CXX_COMPILER_VERSION VERSION_GREATER_EQUAL 3.7) # Not in Clang 3.4.2
|
||||
- )
|
||||
+ if(GCC_HAS_FCF_PROTECTION)
|
||||
+ add_compile_options(-fcf-protection)
|
||||
+ endif()
|
||||
+ if(GCC_HAS_FSTACK_PROTECTOR_STRONG)
|
||||
add_compile_options(-fstack-protector-strong)
|
||||
endif()
|
||||
endif()
|
||||
|
||||
add_compile_options(-Wp,-D_GLIBCXX_ASSERTIONS)
|
||||
|
||||
- if (CMAKE_BUILD_TYPE STREQUAL Release AND NOT APPLE AND NOT MSYS)
|
||||
+ if (CMAKE_BUILD_TYPE STREQUAL Release AND NOT APPLE)
|
||||
add_compile_options(-Wp,-D_FORTIFY_SOURCE=2) # Requires to compile with -O2
|
||||
endif()
|
||||
|
||||
@@ -90,7 +94,6 @@ endif ()
|
||||
|
||||
# http://stackoverflow.com/questions/10113017/setting-the-msvc-runtime-in-cmake
|
||||
if(MSVC)
|
||||
-
|
||||
find_program(CLCACHE name clcache.exe
|
||||
PATHS ENV CLCACHE_PATH
|
||||
PATH_SUFFIXES Scripts clcache-4.1.0
|
||||
@@ -137,10 +140,4 @@ if(MSVC)
|
||||
# Object Level Parallelism
|
||||
add_compile_options(/MP)
|
||||
add_definitions(-DNOMINMAX -DWIN32_LEAN_AND_MEAN)
|
||||
-
|
||||
- # https://devblogs.microsoft.com/cppblog/msvc-now-correctly-reports-__cplusplus/
|
||||
- if (MSVC_VERSION GREATER_EQUAL "1910") # VS2017 and up
|
||||
- add_compile_options("/Zc:__cplusplus")
|
||||
- endif()
|
||||
-
|
||||
endif()
|
Loading…
Reference in a new issue