mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/lensfun to 0.3.2-3
This commit is contained in:
parent
727c7296f4
commit
97811f44ea
2 changed files with 44 additions and 7 deletions
|
@ -6,26 +6,36 @@
|
||||||
|
|
||||||
pkgname=lensfun
|
pkgname=lensfun
|
||||||
pkgver=0.3.2
|
pkgver=0.3.2
|
||||||
pkgrel=2
|
pkgrel=3
|
||||||
pkgdesc="Database of photographic lenses and a library that allows advanced access to the database"
|
pkgdesc="Database of photographic lenses and a library that allows advanced access to the database"
|
||||||
arch=(i686 x86_64)
|
arch=(i686 x86_64)
|
||||||
url="http://lensfun.sourceforge.net"
|
url="http://lensfun.sourceforge.net"
|
||||||
license=('LGPL3')
|
license=('LGPL3')
|
||||||
depends=('glibc' 'glib2')
|
depends=('glibc' 'glib2')
|
||||||
makedepends=('python' 'libpng' 'doxygen' 'cmake')
|
makedepends=('python' 'libpng' 'doxygen' 'cmake')
|
||||||
source=("http://sourceforge.net/projects/lensfun/files/${pkgver}/${pkgname}-${pkgver}.tar.gz")
|
source=("http://sourceforge.net/projects/lensfun/files/${pkgver}/${pkgname}-${pkgver}.tar.gz"
|
||||||
sha1sums=('1d978b15aa7304d66a4931fa37ca9f8f89396c16')
|
lensfun-fix-python-install-dir.patch)
|
||||||
|
sha1sums=('1d978b15aa7304d66a4931fa37ca9f8f89396c16'
|
||||||
|
'7bf2b17d0fb85800857eaf990541ea9eccca2f77')
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
cd $pkgname-$pkgver
|
||||||
|
# Fix python module install path
|
||||||
|
patch -p1 -i ../lensfun-fix-python-install-dir.patch
|
||||||
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
cd ${pkgname}-${pkgver}
|
||||||
cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib \
|
cmake . \
|
||||||
|
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||||
|
-DCMAKE_BUILD_TYPE=Release \
|
||||||
|
-DCMAKE_INSTALL_LIBDIR=lib \
|
||||||
-DBUILD_FOR_SSE=off \
|
-DBUILD_FOR_SSE=off \
|
||||||
-DBUILD_FOR_SSE2=off\
|
-DBUILD_FOR_SSE2=off\
|
||||||
.
|
|
||||||
make all
|
make all
|
||||||
}
|
}
|
||||||
|
|
||||||
package() {
|
package() {
|
||||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
cd ${pkgname}-${pkgver}
|
||||||
make DESTDIR="$pkgdir" install
|
make DESTDIR="$pkgdir" install
|
||||||
}
|
}
|
||||||
|
|
27
extra/lensfun/lensfun-fix-python-install-dir.patch
Normal file
27
extra/lensfun/lensfun-fix-python-install-dir.patch
Normal file
|
@ -0,0 +1,27 @@
|
||||||
|
From 3b46bb2a4eada7f29e016d586229782f6d1c35bb Mon Sep 17 00:00:00 2001
|
||||||
|
From: Pino Toscano <toscano.pino@tiscali.it>
|
||||||
|
Date: Sat, 9 Jan 2016 11:47:37 +0100
|
||||||
|
Subject: [PATCH] cmake: fix DESTDIR installation for python
|
||||||
|
|
||||||
|
When running `setup.py install`, respect the value of the DESTDIR
|
||||||
|
environment variable so staged installs (used by distros, for example)
|
||||||
|
work.
|
||||||
|
---
|
||||||
|
apps/CMakeLists.txt | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/apps/CMakeLists.txt b/apps/CMakeLists.txt
|
||||||
|
index 70c77fd..2f6f8f1 100644
|
||||||
|
--- a/apps/CMakeLists.txt
|
||||||
|
+++ b/apps/CMakeLists.txt
|
||||||
|
@@ -42,5 +42,5 @@ IF(PYTHON)
|
||||||
|
IF(NOT DEFINED SETUP_PY_INSTALL_PREFIX)
|
||||||
|
SET(SETUP_PY_INSTALL_PREFIX "${CMAKE_INSTALL_PREFIX}")
|
||||||
|
ENDIF()
|
||||||
|
- INSTALL(CODE "execute_process(COMMAND ${PYTHON} ${SETUP_PY} install --prefix=${SETUP_PY_INSTALL_PREFIX})")
|
||||||
|
+ INSTALL(CODE "execute_process(COMMAND ${PYTHON} ${SETUP_PY} install --prefix=\$ENV{DESTDIR}${SETUP_PY_INSTALL_PREFIX})")
|
||||||
|
ENDIF(PYTHON)
|
||||||
|
--
|
||||||
|
2.6.4
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue