extra/meson to 0.64.1-1

This commit is contained in:
Kevin Mihelich 2022-11-23 02:15:26 +00:00
parent 5cb3111d72
commit 979bcdf3ab
2 changed files with 5 additions and 19 deletions

View file

@ -5,9 +5,8 @@ Subject: [PATCH] Skip broken tests
---
test cases/linuxlike/13 cmake dependency/meson.build | 2 ++
unittests/allplatformstests.py | 2 +-
unittests/linuxliketests.py | 2 ++
3 files changed, 5 insertions(+), 1 deletion(-)
2 files changed, 4 insertions(+)
diff --git a/test cases/linuxlike/13 cmake dependency/meson.build b/test cases/linuxlike/13 cmake dependency/meson.build
index 193ad184b637..e94ba68ac30f 100644
@ -22,21 +21,8 @@ index 193ad184b637..e94ba68ac30f 100644
# Zlib is probably on all dev machines.
dep = dependency('ZLIB', version : '>=1.2', method : 'cmake')
diff --git a/unittests/allplatformstests.py b/unittests/allplatformstests.py
index 1ecbf18e3477..c567bb794138 100644
--- a/unittests/allplatformstests.py
+++ b/unittests/allplatformstests.py
@@ -4352,7 +4352,7 @@ class AllPlatformTests(BasePlatformTests):
self.init(testdir, extra_args=['--werror'], override_envvars={'RUSTC': 'clippy-driver'})
with self.assertRaises(subprocess.CalledProcessError) as cm:
self.build()
- self.assertIn('error: use of a blacklisted/placeholder name `foo`', cm.exception.stdout)
+ self.assertIn('error: use of a disallowed/placeholder name `foo`', cm.exception.stdout)
@skip_if_not_language('rust')
def test_rust_rlib_linkage(self) -> None:
diff --git a/unittests/linuxliketests.py b/unittests/linuxliketests.py
index 8dd9cfc4e1f3..47bd4be1477d 100644
index 25b392f28e47..db8119f63719 100644
--- a/unittests/linuxliketests.py
+++ b/unittests/linuxliketests.py
@@ -359,6 +359,7 @@ class LinuxlikeTests(BasePlatformTests):

View file

@ -6,7 +6,7 @@
# - disable lto in arch-meson
pkgname=meson
pkgver=0.64.0
pkgver=0.64.1
pkgrel=1
pkgdesc='High productivity build system'
url='https://mesonbuild.com/'
@ -22,9 +22,9 @@ checkdepends=('gcc-objc' 'vala' 'rust' 'gcc-fortran' 'mono' 'boost' 'qt5-base' '
source=(https://github.com/mesonbuild/meson/releases/download/${pkgver}/meson-${pkgver}.tar.gz{,.asc}
0001-Skip-broken-tests.patch
arch-meson)
sha512sums=('0656515e983d98350081dc7cd726bff4a83ed1e24d414c022ea804317f2ff86052b53bbbc36e00847541f2cbe19ebe4c87bb35a174bf6321864363512a4cf6b0'
sha512sums=('4896f5a09f89cadce028080f70e5ca005fd3bb2141a730a0ad71ded63d1bde6d1254957fe079f5e4c6e3b9420a9fcc4525b01e689979f0bab6d09d6483ca42ec'
'SKIP'
'521d662c9bbf8c4618f5f3d5f37ad206d61e222b5e29a6bb0df72ad4da3e4e2d14f60b6ea5fefeba501a06729b257cfe7450cb35946bf0cd7589558529591a4a'
'51b5d0b684a03ab884c6d94925bae7edc8544168100497251c36e85502428a0fe89e5512e067b24d983695ab3b468a8a504dfbe5d66c1c17579039bf329d3857'
'278f5e4de3aa1170d9b4f9f212985d664f44d90ffec727febeeea1ed570046c6469558a5d123a41bf4c2fdf99dbe7832515b06f1ace423c63e2e95ba6d0ef235')
validpgpkeys=('19E2D6D9B46D8DAA6288F877C24E631BABB1FE70') # Jussi Pakkanen <jpakkane@gmail.com>