mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
community/mysql-workbench to 8.0.28-2
This commit is contained in:
parent
c2b2a62c29
commit
97fe4ffa11
2 changed files with 46 additions and 5 deletions
12
community/mysql-workbench/0003-include-list.patch
Normal file
12
community/mysql-workbench/0003-include-list.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff --git a/library/parsers/mysql/MySQLBaseLexer.h b/library/parsers/mysql/MySQLBaseLexer.h
|
||||
index 1a8b9ac..8bd3d57 100644
|
||||
--- a/library/parsers/mysql/MySQLBaseLexer.h
|
||||
+++ b/library/parsers/mysql/MySQLBaseLexer.h
|
||||
@@ -26,6 +26,7 @@
|
||||
#include "Lexer.h"
|
||||
#include "MySQLRecognizerCommon.h"
|
||||
#include "mysql-recognition-types.h"
|
||||
+#include <list>
|
||||
|
||||
namespace antlr4 {
|
||||
class PARSERS_PUBLIC_TYPE Lexer;
|
|
@ -13,11 +13,12 @@ highmem=1
|
|||
|
||||
pkgname=mysql-workbench
|
||||
pkgver=8.0.28
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
_mysql_version=${pkgver}
|
||||
_connector_version=${pkgver}
|
||||
_gdal_version=3.4.1
|
||||
_gdal_version=3.4.2
|
||||
_boost_version=1.73.0
|
||||
# bump the antlr4 version as required, this is to match the jar file name
|
||||
_antlr4_version=4.9.3
|
||||
pkgdesc='A cross-platform, visual database design tool developed by MySQL'
|
||||
arch=('x86_64')
|
||||
|
@ -27,15 +28,22 @@ depends=('cairo' 'antlr4-runtime' 'curl' 'desktop-file-utils' 'freetype2' 'gifli
|
|||
'gtkmm3' 'hicolor-icon-theme' 'json-c' 'libgl' 'libsecret' 'libssh'
|
||||
'libxml2' 'libzip' 'pcre' 'proj' 'python' 'rapidjson' 'unixodbc'
|
||||
'vsqlite++' 'zstd')
|
||||
makedepends=('cmake' 'boost' 'mesa' 'swig' 'java-runtime' 'imagemagick' "antlr4=${_antlr4_version}")
|
||||
makedepends=('cmake' 'boost' 'mesa' 'swig' 'java-runtime' 'imagemagick'
|
||||
# tmporary fix for antlr4...
|
||||
#"antlr4=${_antlr4_version}"
|
||||
'git'
|
||||
)
|
||||
validpgpkeys=('859BE8D7C586F538430B19C2467B942D3A79BD29') # MySQL Release Engineering <mysql-build@oss.oracle.com>
|
||||
source=("https://cdn.mysql.com/Downloads/MySQLGUITools/mysql-workbench-community-${pkgver}-src.tar.gz"{,.asc}
|
||||
"https://cdn.mysql.com/Downloads/MySQL-${_mysql_version%.*}/mysql-${_mysql_version}.tar.gz"{,.asc}
|
||||
"https://cdn.mysql.com/Downloads/Connector-C++/mysql-connector-c++-${_connector_version}-src.tar.gz"{,.asc}
|
||||
"https://download.osgeo.org/gdal/${_gdal_version}/gdal-${_gdal_version}.tar.xz"
|
||||
"https://downloads.sourceforge.net/project/boost/boost/${_boost_version}/boost_${_boost_version//./_}.tar.bz2"
|
||||
'https://www.antlr.org/download/antlr-4.9.3-complete.jar'
|
||||
'https://www.antlr.org/download/antlr4-cpp-runtime-4.9.3-source.zip'
|
||||
'0001-mysql-workbench-no-check-for-updates.patch'
|
||||
'0002-disable-unsupported-operating-system-warning.patch'
|
||||
'0003-include-list.patch'
|
||||
'0001-fix-buiild-for-32-bit.patch'
|
||||
'atomic.patch'
|
||||
'arch_linux_profile.xml')
|
||||
|
@ -45,10 +53,13 @@ sha256sums=('a6753b08be1157cd6d67fea7cf6a195ea0af46c7bfa2a6462e102375cba864c8'
|
|||
'SKIP'
|
||||
'cb26fe9de05a3b5f1ed22a199429b6791ece18433eb0465e2a73fcf44586420b'
|
||||
'SKIP'
|
||||
'332f053516ca45101ef0f7fa96309b64242688a8024780a5d93be0230e42173d'
|
||||
'16baf03dfccf9e3f72bb2e15cd2d5b3f4be0437cdff8a785bceab0c7be557335'
|
||||
'4eb3b8d442b426dc35346235c8733b5ae35ba431690e38c6a8263dce9fcbb402'
|
||||
'afcd40946d3de4d81e28d7c88d467289e0587285d27adb172aecc5494a17df36'
|
||||
'5f0af6efd81f476c3e775c486eb0a71c25d6bbc14373e88a64690e2738d68e03'
|
||||
'cdf687f23bc6e8d52dbee9fa02b23d755e80f88476f0fc2e7c4c71cdfed3792f'
|
||||
'2d0f6dcf38f22e49ef7ab9de0230484f1ffac41b7ac40feaf5ef4538ae2f7a18'
|
||||
'e7e66ba68a21a0da87f0513f2b9550359c923a94aa7d16afe6ead063322e3d53'
|
||||
'719501bbd1de673767007c429feed2fc48d1176d456161c4ba69cf3165c0438a'
|
||||
'17294a67637ab7ffff5c39262208e63d21acac72cc2492f616ef1d8e0ae9ac02'
|
||||
'd816164098c90c432b4fe590708c14f95ab137abfe16ad1b7d498b2e83c0e265')
|
||||
|
@ -63,6 +74,9 @@ prepare() {
|
|||
# disable unsupported operating system warning
|
||||
patch -Np1 < "${srcdir}"/0002-disable-unsupported-operating-system-warning.patch
|
||||
|
||||
# add missing include
|
||||
patch -Np1 < "${srcdir}"/0003-include-list.patch
|
||||
|
||||
# remove '-Werror'
|
||||
sed -i '/^\s*set/s| -Werror||' CMakeLists.txt
|
||||
|
||||
|
@ -134,6 +148,18 @@ build() {
|
|||
echo "Install gdal..."
|
||||
make LD_LIBRARY_PATH="${srcdir}/install-bundle/usr/lib/" DESTDIR="${srcdir}/install-bundle/" install
|
||||
|
||||
# temporary fix until wb builds against antlr4-runtime 4.10.x...
|
||||
mkdir "${srcdir}/antlr4-build"
|
||||
cd "${srcdir}/antlr4-build"
|
||||
cmake ../ \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DCMAKE_CXX_STANDARD=17 \
|
||||
-DANTLR4_INSTALL=ON \
|
||||
-DINSTALL_GTEST=OFF
|
||||
make
|
||||
make DESTDIR="${srcdir}/install-bundle/" install
|
||||
|
||||
# Build MySQL Workbench itself with bundled libs
|
||||
mkdir "${srcdir}/mysql-workbench-community-${pkgver}-src-build"
|
||||
cd "${srcdir}/mysql-workbench-community-${pkgver}-src-build"
|
||||
|
@ -148,7 +174,9 @@ build() {
|
|||
-DMySQLCppConn_INCLUDE_DIR="${srcdir}/install-bundle/usr/include/jdbc" \
|
||||
-DGDAL_INCLUDE_DIR="${srcdir}/install-bundle/usr/include" \
|
||||
-DGDAL_LIBRARY="${srcdir}/install-bundle/usr/lib/libgdal.so" \
|
||||
-DWITH_ANTLR_JAR='/usr/share/java/antlr-complete.jar' \
|
||||
-DANTLR4_INCLUDE_DIR="${srcdir}/install-bundle/usr/include" \
|
||||
-DANTLR4_LIBRARY="${srcdir}/install-bundle/usr/lib/libantlr4-runtime.so" \
|
||||
-DWITH_ANTLR_JAR="${srcdir}/antlr-4.9.3-complete.jar" \
|
||||
-DUSE_BUNDLED_MYSQLDUMP=1
|
||||
echo "Build mysql-workbench..."
|
||||
make
|
||||
|
@ -162,6 +190,7 @@ package() {
|
|||
install -D -m0755 "${LIBRARY}" "${pkgdir}"/usr/lib/mysql-workbench/"${BASENAME}"
|
||||
ln -s "${BASENAME}" "${pkgdir}"/usr/lib/mysql-workbench/"${SONAME}"
|
||||
done
|
||||
install -D -m0755 "${srcdir}/install-bundle/usr/lib/libantlr4-runtime.so.4.9.3" "${pkgdir}/usr/lib/mysql-workbench/libantlr4-runtime.so.4.9.3"
|
||||
|
||||
# install bundled mysql and mysqldump
|
||||
install -m0755 "${srcdir}/install-bundle/usr/bin/mysql"{,dump} "${pkgdir}"/usr/lib/mysql-workbench/
|
||||
|
|
Loading…
Reference in a new issue