extra/krita: fix

This commit is contained in:
Kevin Mihelich 2018-05-08 00:01:35 +00:00
parent 630cf1d510
commit 980174c16d
2 changed files with 2 additions and 32 deletions

View file

@ -1,26 +0,0 @@
From 799b445e1cf2ca9810bb7b2a4fca73e897a8da4e Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Mon, 9 Apr 2018 07:56:31 -0600
Subject: [PATCH] Fix ARM build
---
CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index efae71d..8db8c80 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -630,8 +630,8 @@ if (NOT ${CMAKE_SYSTEM_PROCESSOR} MATCHES "arm")
PURPOSE "Required by the Krita for vectorization")
macro_bool_to_01(Vc_FOUND HAVE_VC)
endif()
- configure_file(config-vc.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-vc.h )
endif()
+configure_file(config-vc.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-vc.h )
if(HAVE_VC)
message(STATUS "Vc found!")
--
2.16.2

View file

@ -3,7 +3,6 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - remove makedepend on vc
# - patch to fix building on ARM
pkgname=krita
pkgver=4.0.2
@ -18,16 +17,13 @@ optdepends=('poppler-qt5: PDF filter' 'ffmpeg: to save animations' 'opencolorio:
"krita-plugin-gmic: G'MIC plugin" 'python-pyqt5: for the Python plugins')
conflicts=(calligra-krita krita-l10n)
replaces=(calligra-krita krita-l10n)
source=("https://download.kde.org/stable/krita/$pkgver/$pkgname-$pkgver.tar.gz"{,.sig}
'0001-Fix-ARM-build.patch')
source=("https://download.kde.org/stable/krita/$pkgver/$pkgname-$pkgver.tar.gz"{,.sig})
sha256sums=('8e013b09ec38dbf2d0401a74e868749b9d60e66d89094dc7fc2c51f48d8ad68c'
'SKIP'
'14c43c57daf4fdff8f28abc844c1804a4bc9c898c4782daca7ab5cbd21ae48d2')
'SKIP')
validpgpkeys=('05D00A8B73A686789E0A156858B9596C722EA3BD') # Boudewijn Rempt <foundation@krita.org>
prepare() {
mkdir -p build
patch -p1 -d $pkgname-$pkgver -i ../0001-Fix-ARM-build.patch
}
build() {