mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
community/gpac to 0.5.2-1
This commit is contained in:
parent
4376706138
commit
9839a14d24
2 changed files with 13 additions and 83 deletions
|
@ -5,55 +5,32 @@
|
|||
# - use PIC with armv7
|
||||
|
||||
pkgname=gpac
|
||||
pkgver=5324
|
||||
pkgver=0.5.2
|
||||
pkgrel=1
|
||||
epoch=1
|
||||
pkgdesc="A multimedia framework based on the MPEG-4 Systems standard"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://gpac.sourceforge.net"
|
||||
license=('LGPL')
|
||||
depends=('ffmpeg' 'libjpeg' 'libpng' 'glu' 'libxv')
|
||||
makedepends=('jack' 'a52dec' 'freetype2' 'faad2' 'libmad' 'mesa')
|
||||
optdepends=('jack: for jack support' 'a52dec: for A52 support'
|
||||
'faad2: for AAC support' 'libmad: for mp3 support')
|
||||
depends=('ffmpeg' 'glu' 'libxv')
|
||||
makedepends=('git' 'jack' 'a52dec' 'freetype2' 'faad2' 'libmad' 'mesa' 'sdl2')
|
||||
optdepends=('jack: for jack support'
|
||||
'a52dec: for A52 support'
|
||||
'faad2: for AAC support'
|
||||
'libmad: for mp3 support'
|
||||
'sdl2: for sdl support')
|
||||
options=('staticlibs' '!makeflags')
|
||||
source=(ftp://ftp.archlinux.org/other/community/${pkgname}/${pkgname}-${pkgver}.tar.xz{,.sig} gpac-ffmpeg.patch)
|
||||
sha1sums=('cd00b88aa6da97708532fc8eb7ab65f6a0d0c1e0'
|
||||
'SKIP'
|
||||
'e758b8cdb0b4bca37134241a1b8ccc33d4deb54a')
|
||||
validpgpkeys=('5357F3B111688D88C1D88119FCF2CB179205AC90')
|
||||
|
||||
# source PKGBUILD && mksource
|
||||
mksource() {
|
||||
[[ -x /usr/bin/svn ]] || (echo "svn not found. Install subversion." && return 1)
|
||||
_svnver=${pkgver}
|
||||
_svntrunk="svn://svn.code.sf.net/p/gpac/code/trunk/gpac"
|
||||
_svnmod="$pkgname-${pkgver}"
|
||||
mkdir ${pkgname}-${pkgver}
|
||||
pushd ${pkgname}-${pkgver}
|
||||
svn co $_svntrunk --config-dir ./ -r $_svnver $_svnmod
|
||||
revision="$(svnversion ${pkgname}-${pkgver})"
|
||||
echo "#define GPAC_SVN_REVISION \"$revision\"" > ${pkgname}-${pkgver}/include/gpac/revision.h
|
||||
find . -depth -type d -name .svn -exec rm -rf {} \;
|
||||
tar -cJf ../${pkgname}-${pkgver}.tar.xz ${pkgname}-${pkgver}/*
|
||||
popd
|
||||
rm -r ${pkgname}-${pkgver}
|
||||
gpg --detach-sign --use-agent -u ${GPGKEY} ${pkgname}-${pkgver}.tar.xz
|
||||
}
|
||||
|
||||
prepare() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
patch -p3 -i "${srcdir}/gpac-ffmpeg.patch"
|
||||
}
|
||||
source=(git://github.com/gpac/gpac.git)
|
||||
sha1sums=('SKIP')
|
||||
|
||||
build() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
|
||||
cd ${pkgname}
|
||||
[[ $CARCH == 'armv7h' ]] && CONFIG='--enable-pic'
|
||||
./configure --prefix=/usr --mandir=/usr/share/man --X11-path=/usr --use-js=no $CONFIG
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
cd ${pkgname}
|
||||
make DESTDIR="${pkgdir}" install install-lib
|
||||
}
|
||||
|
|
|
@ -1,47 +0,0 @@
|
|||
--- a/trunk/gpac/modules/ffmpeg_in/ffmpeg_demux.c
|
||||
+++ b/trunk/gpac/modules/ffmpeg_in/ffmpeg_demux.c
|
||||
@@ -54,13 +54,10 @@
|
||||
#endif /* AVERROR_NOFMT */
|
||||
|
||||
|
||||
-#if (LIBAVFORMAT_VERSION_MAJOR >= 54) && (LIBAVFORMAT_VERSION_MINOR >= 20)
|
||||
+#if ((LIBAVFORMAT_VERSION_MAJOR == 54) && (LIBAVFORMAT_VERSION_MINOR >= 20)) || (LIBAVFORMAT_VERSION_MAJOR > 54)
|
||||
|
||||
#define av_find_stream_info(__c) avformat_find_stream_info(__c, NULL)
|
||||
-#ifndef FF_API_FORMAT_PARAMETERS
|
||||
-#define FF_API_FORMAT_PARAMETERS 1
|
||||
-#endif
|
||||
-
|
||||
+#define USE_AVFORMAT_OPEN_INPUT 1
|
||||
#endif
|
||||
|
||||
|
||||
@@ -275,7 +272,7 @@
|
||||
}
|
||||
if (!has_audio && !has_video) goto exit;
|
||||
ret = 1;
|
||||
-#if LIBAVFORMAT_VERSION_MAJOR < 53 && LIBAVFORMAT_VERSION_MINOR < 45
|
||||
+#if ((LIBAVFORMAT_VERSION_MAJOR == 52) && (LIBAVFORMAT_VERSION_MINOR <= 47)) || (LIBAVFORMAT_VERSION_MAJOR < 52)
|
||||
fmt_out = guess_stream_format(NULL, url, NULL);
|
||||
#else
|
||||
fmt_out = av_guess_format(NULL, url, NULL);
|
||||
@@ -588,7 +585,7 @@
|
||||
}
|
||||
/*setup downloader*/
|
||||
av_in->flags |= AVFMT_NOFILE;
|
||||
-#if FF_API_FORMAT_PARAMETERS /*commit ffmpeg 603b8bc2a109978c8499b06d2556f1433306eca7*/
|
||||
+#ifdef USE_AVFORMAT_OPEN_INPUT /*commit ffmpeg 603b8bc2a109978c8499b06d2556f1433306eca7*/
|
||||
res = avformat_open_input(&ffd->ctx, szName, av_in, NULL);
|
||||
#else
|
||||
res = av_open_input_stream(&ffd->ctx, &ffd->io, szName, av_in, NULL);
|
||||
--- a/trunk/gpac/modules/ffmpeg_in/ffmpeg_in.h
|
||||
+++ b/trunk/gpac/modules/ffmpeg_in/ffmpeg_in.h
|
||||
@@ -99,7 +99,7 @@
|
||||
|
||||
#ifndef FFMPEG_OLD_HEADERS
|
||||
|
||||
-#if (LIBAVCODEC_VERSION_MAJOR <= 52) && (LIBAVCODEC_VERSION_MINOR <= 20)
|
||||
+#if ((LIBAVCODEC_VERSION_MAJOR == 52) && (LIBAVCODEC_VERSION_MINOR <= 20)) || (LIBAVCODEC_VERSION_MAJOR < 52)
|
||||
#undef USE_AVCODEC2
|
||||
#else
|
||||
#define USE_AVCODEC2 1
|
Loading…
Reference in a new issue